zmizol mi xorg.conf, ale Xko ide (???)

Sekcia: Aplikácie & Desktop 10.05.2007 | 00:48
miso   Návštevník
Nainstaloval som nove Kubuntu, ok, idem zeditovat xorg.conf, a ono tam nie je. Proste v /etc/X11 nie je xorg.conf, pricom Xko bezi normalne. Locate xorg.conf mi vyhodi iba dany subor na inom disku, ktory mam pripojeny a na ktorom je iny nezavisle od tohto systemu nainstalovany linux. Je to vobec mozne?? Nechapem. Prosim pomoc :)
  • Re: zmizol mi xorg.conf, ale Xko ide (???) 10.05.2007 | 11:14
    Avatar LUcoRP   Používateľ
    xexexe nejaka hovadina, ja mam tiez najnovsie kubuntu a xorg.conf tam mam...
    nemozu tahat obidve instalacky z jedneho xorgu???
    • Re: zmizol mi xorg.conf, ale Xko ide (???) 10.05.2007 | 12:14
      miso   Návštevník
      tiez ma to napadlo. ale to by bola riadna blbost. No nic, idem odpojit ten disk, restartnut a uvidim.
      • Re: zmizol mi xorg.conf, ale Xko ide (???) 10.05.2007 | 12:24
        miso   Návštevník
        no proste NIC. Neni tam ani teraz, a disk s prvym linuxom je odpojeny

        petko@asusik:/etc/X11$ locate xorg.conf
        /usr/share/man/man5/xorg.conf.5.gz
        /var/lib/x11/xorg.conf.roster
        /var/lib/x11/xorg.conf.md5sum

        nechce sa mi kvoli takej prkotine zas instalovat :-(
        • Re: zmizol mi xorg.conf, ale Xko ide (???) 10.05.2007 | 13:21
          duBeN   Návštevník
          nefunguje locate tak ze si vytvori nejaku databazu a potom vyhladava iba v nej - cize ju treba updateovat aby bola aktualna

          ani #find / -name xorg.conf ho nenajde ?
          • Re: zmizol mi xorg.conf, ale Xko ide (???) 10.05.2007 | 13:47
            miso   Návštevník
            pred tym nez som spustil locate, som updatol databazu cez updatedb, ale to nie je podstatne, pretoze ani find ho nenasiel. PREINSTALOVAL SOM CELY SYSTEM A OPAT TO ISTE. nie je tam

            mam linux uz 4 roky ale toto sa mi este nestalo. debilne blbuntu.

            petko@asus:~$ ls -al /etc/X11/
            celkom 80
            drwxr-xr-x 10 root root 4096 2007-04-17 07:31 .
            drwxr-xr-x 98 root root 4096 2007-05-10 11:38 ..
            drwxr-xr-x 2 root root 4096 2007-04-17 07:25 app-defaults
            drwxr-xr-x 2 root root 4096 2007-04-17 07:28 cursors
            -rw-r--r-- 1 root root 13 2007-04-17 07:25 default-display-manager
            drwxr-xr-x 6 root root 4096 2007-04-17 07:23 fonts
            -rw-r--r-- 1 root root 17371 2007-02-13 11:02 rgb.txt
            lrwxrwxrwx 1 root root 13 2007-05-10 13:12 X -> /usr/bin/Xorg
            drwxr-xr-x 2 root root 4096 2007-04-17 07:24 xinit
            drwxr-xr-x 2 root root 4096 2007-04-17 07:21 xkb
            drwxr-xr-x 2 root root 4096 2007-04-17 07:20 Xresources
            drwxr-xr-x 2 root root 4096 2007-04-17 07:28 xserver
            -rwxr-xr-x 1 root root 3911 2006-08-07 21:01 Xsession
            drwxr-xr-x 2 root root 4096 2007-04-17 07:25 Xsession.d
            -rw-r--r-- 1 root root 234 2006-08-07 21:01 Xsession.options
            -rw-r--r-- 1 root root 13 2006-09-12 05:44 XvMCConfig
            -rw------- 1 root root 614 2007-04-17 07:20 Xwrapper.config
            • Re: zmizol mi xorg.conf, ale Xko ide (???) 10.05.2007 | 18:02
              Avatar Tommy Angelo   Používateľ
              skus si znova vytvorit xorg prikazom ::
              xorgconfig
              
              • Re: zmizol mi xorg.conf, ale Xko ide (???) 10.05.2007 | 18:13
                miso   Návštevník
                takyto prikaz nemam. no skusil som si vytvorit xorg rucne a po nejakom tom maturovani sa mi to aj podarilo spustit. Zaujimave je, ze ked tam nejaky xorg.conf dam, tak berie ten, ale ak ho vyhodim resp. tam nebude (aj po defaultnej instalacii!!), tak si to nejak nakonfigure system aj bez neho a Xka idu. Ok, tak vdaka vsetkym
                • Re: zmizol mi xorg.conf, ale Xko ide (???) 10.05.2007 | 18:35
                  Avatar borg ChakraOS, Debian jessie  Administrátor
                  dpkg-reconfigure xserver-xorg
                  • Re: zmizol mi xorg.conf, ale Xko ide (???) 10.05.2007 | 19:13
                    miso   Návštevník
                    aj to som skusal. dpkg-reconfigure skoncil chybovou hlaskou ze xorg.conf neexistuje :-P
                    • Re: zmizol mi xorg.conf, ale Xko ide (???) 10.05.2007 | 21:00
                      :-)   Návštevník
                      a ze vraj v linuxe nic nefunguje samo od seba a vsetko treba manualne konfigurovat v textovej konzole :-)
                  • Re: zmizol mi xorg.conf, ale Xko ide (???) 05.03.2009 | 00:10
                    Avatar dodoedo Linux  Administrátor
                    sudo dpkg-reconfigure xserver-xorg
                    Orwell písal: "V čase všeobecného klamu, hovoriť pravdu, je revolučný čin."
                    • Re: zmizol mi xorg.conf, ale Xko ide (???) 06.03.2009 | 00:04
                      jur0   Návštevník
                      moj osvedceny sposob:

                      ako root:
                      X -configure vytvori subor xorg.conf.new
                      X -config xorg.conf.new
                      mv xorg.conf.new /etc/X11/xorg.conf
                • Re: zmizol mi xorg.conf, ale Xko ide (???) 10.05.2007 | 21:12
                  miro   Návštevník
                  Aj ja som sa divil ked som instaloval gentoo na cistu particiu X-ka bezali bez xorg.conf, ale ked som si robil vlastne nastavenia ide z toho configu co si vytvoris. Tusim tie default hodnoty si najnovsi xorg-server berie cez udev alebo ako to funguje.
  • Re: zmizol mi xorg.conf, ale Xko ide (???) 04.03.2009 | 22:15
    Avatar ondrejandrej Kubuntu 11.04  Používateľ
    Ja mam podobny problem, xorg.conf tam mam, ale ma 0 B. Nic v nom neni. Chcel by som si aspon doplnit sk klavesnicu, aby som sem nepisal bez makcenov ako curak.
    Ja by som si xorg.conf vytvoril aj sam, ale neviem, co tam mam napisat na tie ostatne veci okrem klavesnice, nerad by som ostatne nastavenia (mimo rozlozenie klavesnice) menil, lebo napodiv sa to uz pri instalacii nastavilo celkom dobre.

    Inak mam Xubuntu 8.10
  • Re: zmizol mi xorg.conf, ale Xko ide (???) 05.03.2009 | 00:07
    Avatar peter s.   Používateľ
    najnovšie Xka NEPOTREBUJU xorg.conf,
    podporujú hotplug a autodetekciu myši a monitora...
  • Re: zmizol mi xorg.conf, ale Xko ide (???) 05.03.2009 | 00:19
    Avatar dodoedo Linux  Administrátor
    Je to urobené kvôli a pre *buntu, nová metóda sa volá "XAutoconfiguration", trocha okolo toho pre *buntu, podporuje to aj stávajúci xorg-server 1.5 a asi to čaká všeobecne iné distrá (?).
    Orwell písal: "V čase všeobecného klamu, hovoriť pravdu, je revolučný čin."
  • Re: zmizol mi xorg.conf, ale Xko ide (???) 05.03.2009 | 04:04
    kipikasa   Návštevník
    omg, sak sa pozri do /var/log/Xorg.0.log...
    • Re: zmizol mi xorg.conf, ale Xko ide (???) 05.03.2009 | 21:32
      Avatar Filip Horňák ArchLinux  Používateľ
      Ja som po instalacii Debianu tiez nemal toho v xorgu vela napisaneho, len nieco ako default driver, monitor atd..., Vytvoril som si novy nastavil som ho stary som zalohoval a teraz mi to bezi rychlejsie ako predtym (grafika samozrejme)
    • Re: zmizol mi xorg.conf, ale Xko ide (???) 05.03.2009 | 22:51
      Avatar ondrejandrej Kubuntu 11.04  Používateľ
      Tak som editoval xorg.conf s nadejou, ze ked tam dam len nastavenia klavesnice, ostatne nastavenia budu ponechane. Dal som do xorg.conf nasledovne:
      Section "InputDevice"
      Identifier "AT Translated Set 2 keyboard"
      Driver "kbd"
      Option "XkbRules" "xorg"
      Option "XkbModel" "pc105"
      Option "XkbLayout" "us,sk"
      Option "XkbVariant" ",qwerty"
      Option "XkbOptions" "grp:alt_shift_toggle"
      EndSection

      , kde to "AT Translated Set 2 keyboard" som nasiel v /var/log/Xorg.0.log. Iksy sa s takymto xorg.conf vobec nespustili. Sere ma takyto pristup, kedy sa xorg.conf normalne pouzival, nebol by problem, len by som zmenil tie riadky, ktore mi nevyhovuju...
    • Re: zmizol mi xorg.conf, ale Xko ide (???) 05.03.2009 | 23:06
      Avatar ondrejandrej Kubuntu 11.04  Používateľ
      Inak skusil som spustit aj dpkg-reconfigure xserver-xorg a napodiv xorg.conf uz nie je prazdny, ale pribudlo v nom iba zopar riadkov, sekcie Device, Monitor a Screen. No a ziadne ciselne detaily (o rozliseni a podobne) tam nie su, len napr. Identifier "Configured Video Device"...
      • Re: zmizol mi xorg.conf, ale Xko ide (???) 06.03.2009 | 18:18
        xenol   Návštevník
        ako uz bolo vyssie spomenute, xorg 1.5 funguje aj bez xorg.confu, ale ten sa stale da nastavit na pouzitie. ja tam mam vypnute hotplug. to je zbytocnost pre mna.