SAP GUI na linuxe

Sekcia: Aplikácie & Desktop 13.08 | 15:04
Avatar deathhawk   Používateľ

AHoj,

pokusam sa rozchodit aplikaciu SAP GUI 7.50 rev 6 na debian. Probelm je vtom ze od revizie 5 je potrebna java openjdk 11 a viac ale od 11tky uz nieje zahrnuty modul JavaFX a treba ho pridat zvlast a tu mi to nieje jasne ako. Ma stym niekto uz skusenost, vie poradit? Debian 9 MATE

    • RE: SAP GUI na linuxe 13.08 | 15:15
      Avatar Branislav Poldauf Manjaro, Debian stable  Používateľ

      neviem či ti to tbude fungovať ale mali by to obsahovať balíky openjfx alebo libopenjfx-java

      Linux: the operating system with a CLUE... Command Line User Environment
      • RE: SAP GUI na linuxe 13.08 | 16:39
        Avatar deathhawk   Používateľ

        stiahol som si openjfx-12 ale prikaz

        $ java --module-path $PATH_TO_FX/javafx-sdk-12 
        --add-modules=javafx.controls,javafx.fxml
        

        mi zahlasi chybu:

        "Caused by: java.lang.module.InvalidModuleDescriptorException: Package javafx.beans.property not found in module"

        co stym?

    • RE: SAP GUI na linuxe 13.08 | 15:19
      Avatar bedňa LegacyIce-antiX  Administrátor

      Ja mám v zdrojoch openjfx 11.0.2+1-1.

      Osobne som to nikdy neskúšal, nie je v návode napísané, že to bude potrebovať Javu priamo od Oracle? Niektoré aplikácie na open Jave chodia biedne.

      Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
      • RE: SAP GUI na linuxe 13.08 | 16:41
        Avatar deathhawk   Používateľ

        v popise pri instalacii aplikacie je spomenuta java 11 oracle java nieje priamo vyzadovana. potrebujem aby to bezalo na open jave

        • RE: SAP GUI na linuxe 13.08 | 17:07
          Avatar WlaSaTy   Návštevník

          Radšej by som skúsil javu od oracle. Predsa len v sape to nemusia testovať na všetkých jawách a babetách.