Nevysvetlitelne problemy #002

09.03.2002 14:44 | blackhole

Sú to dokopy dve záhady. Už sú síce vyriešené, ale aj tak. No, vlastne vyriešené ako vyriešené, lebo záhadami zostali aj ďalej. Jednoducho som v škole na serveri nahadzoval nový mysql, apache a php. Php bolo konkrétne 4.1.1, lebo jeho sa týka prvá záhada. Všetko v pohode fungovalo bez úplných problémov.

Potom sa odrazu zo zekundy na sekundu niečo stalo. Nedalo sa prihlásiť nikam na školskú stránku. Tak som sa prešiel k serveru a kukal som čo sa stalo. Nič som nevidel, žiadne chybové hlásenie, žiaden log, len som sa zbežne pozrel do /tmp a čože tam bolo? Všetko to, čo tam malo byť, tým myslím uložené sessions. Tak som sa vrátil k PC a ešte raz skontroloval, či ich náhodou nemá zakázané. Nemal. Nakoniec, všetko ostatné mimo školy fungovalo. Znovu som sa prešiel k serveru a ešte raz pozrel /tmp, ale pozrel som aj veľkosti súborov, čože nevidím, 0bajtov. Ale stále nikde neexistovalo žiadne chybové hlásenie, prípadne aspoň podozrivá činnosť servera. O takejto záležitosti som nikde nečítal, aj keď som hľadal na roznych miestach. Čo ma ešte viac udivovalo bolo, že prečo sa to stalo, lebo doma mám takmer totožnú konfiguráciu, dokonca apdejtujem paralelne.

Tak som odišiel domov atď atď...... Nikto sa toho nechytal. Len ma tak potom napadlo (teraz neviem či hneď druhý deň alebo tretí), že to zapnem ešte raz a uvidím. Spustil som server a ono to bezproblémov fungovalo a funguje aj teraz.

S adminom sme sa zhodli na tom, že v noci museli prísť mimozemšťania a tí niečo urobili.

Približne v tom istom čase vznikol ešte jeden problém, ten sa týkal Xfree. Veselo si zapnem Xká, lebo som sa šiel v niečom hrabať a odrazu blik, čierne pozadie a chybové hlásenie zo štartu Xservera. Niečo v tom zmysle, že smrteľná chyba, lebo chýba font fixed. On tam bol. Zase žiadne iné hlásenie, len to, že chýba. Tak som ho v kompe vymenil za iný ale aj po reboote stále chcel fixed, ktorý tam už nemal čo robiť a nemal čo robiť ani v Xoch, lebo tam nie je použitý.

Inokedy som riešil podobné chyby tým, že som startx spustil ako root, ale teraz som už žiaľ ako root prihlásený bol. Tak som to skúšal manuálne s fontserverom. Super spustil som ho a na ďalšej konzole som spustil Xká. Dobré znamenie, zobrazil sa ukazovateľ myši. Odrazu zase čierne pozadie a pre zmenu hlásenie, že na /tmp nie je dostatok miesta, čo ma neuveriteľne šokovalo, keďže tam bolo ešte asi 17 - 18 giga. Tak som to nechal tak.

Len ma jeden deň po tom, ako tak záhadne začal fungovať apač s php napadlo, že spustím Xfree, čože sa nestalo, nabehli s tak ako boli predtým, bez toho, aby im chýbal akýkoľvek font, či niečo iné. Ďalšia zhoda s adminom, boli tu mimozemšťania ;o)

Akýkoľvek útok, alebo snahy o útok sú vylúčené, lebo server je prístupný len z lokálnej siete, je chránený routerom a ten bol v tej dobe vypnutý. Užívateľské stanice sú win9x.

V čom ma to utvrdilo? Že akákoľvek záhada so sebou prináša záhadu jej záhadného vyriešenia....Krym