Nevysvetlitelne problemy #001

24.02.2002 18:01 | blackhole

Zaciname novy serial s velmi priznacnym nazvom. V tomto serialy budeme uverejnovat cudne, az nevysvetlitelne problemy, ktore vas postretnu pri praci s pocitacom, linuxom, pri programovani a podobne. A hned v prvej casti vam prinasam jeden problem spojeny s php

Predtym ako prejdeme k prvemu problemu, maly uvod. Rozhodol som sa zacat tento serial, pretoze ma cim viac zacinaju stretavat rozne nesystemove a nelogicke veci. A kedze som kdesi cital, ze pocitac je ako clovek naladovy, chcem zaroven aj zistit, ci to nahodou tak nie je. Zaroven som si isty, ze aj vela z vas ma podobne problemy, ktore tazia ich dusu peknych par rokov. Preto dalsie problemy, ktore by som mohol pridat do tohto serialu posielajte plz na: bhole@blackhole.sk .Skuste vase problemy posielat podla vzoru tohoto prveho. Verim, ze tento serial sa dostatocne rozvynie ;).

id: #001
nazov: Prihlasovanie do Redakcneho systemu
obor: PHP (programovanie)
doba riesenia: skoro pol roka ;)
sposoby riesenia: opytal som sa uz 100 ludi, skusal som 100vky nastaveni...

opis:
Ide o prihlasovanie do Redakcneho systemu PHPSYS. Ktory je na blackhole.sk a je o nom aj nas serial o RS. Jednoducho, prihlasovanie funguje pomocou cookies. Pri vyplneni loginu a hesla, sa poslu cookies a podla toho sa v dalsom priebehu prace v RS kontroluje platnost cookies. Cookies vyprsi automaticky po 10 minutach, alebo po kliknuti na ODHLASENIE. A tu nastava cely problem. Na localhoste to funguje pod vsetkymi browsermi od IE cez Operu az po Netscape. Ale ked to hodim na net, tak to nefunguje tak, ako by malo. Prihlasim sa, vpusti ma do RS ale ked kliknem napr. na add_news (alebo na hociaky odkaz) tak to vyhodi stranku aby som sa znova prihlasil. Najvecsia zahada je vsak vtom, ze toto robi ked browsujem cez IE alebo OPERU. Ale ked idem na tu stranku z Netscape 6.0 tak je opat vsetko bez problemove. Pytal som sa dalsieho autora, jemu to ide aj pod IE. Druhemu zasa nie. Mozilla nerobi taktiez problemy.

zaver:
Poviete si, tak mas v IE a v Opere zle nastavene prijimanie cookies. Lenze cookies, ktore sa prijimaju z boardov rovnakymi prikazmi su v poriadku. (na localhoste to ale ide v poriadku) A je jasne, ze cookies sa odosle aj v pripade prihlasovania (lebo ma do RS vpusti) ale ako keby sa doba expiracie nastavila na 0 alebo co. Naozaj som skusal uz vsetko mozne, nastavenia v IE, Opere, Netscape. Pytal som sa uz skoro kazdeho co poznam. Tak dufam, ze tu najdem pomoc.

Vase napady a navrhy riesenia uvitam v komentaroch k clankom.mis0 truban