Beryl a Gentoo

Beryl a Gentoo
17.03.2007 22:00 | Články | Erik Mocný
Pýtate sa, čo ten Beryl vlastne je? Ak áno, pokúsim sa vás s ním oboznámiť, s jeho inštaláciou a takisto nastavením. Ak už Beryl nejaký ten čas používate, zrejme viete, o čom bude reč, no mnohí sa určite pokúšali "rozbehať" Beryl, ale márne. Mojím cieľom je popísať inštaláciu a nastavenie Berylu pod distribúciou Gentoo.

Úvod

Beryl je akcelerované prostredie, ktoré kombinuje použitie window managera (WM) a composite managera v jednom. Je napísaný v jazyku C a využíva grafickú knižnicu OpenGL pre 3D akceleráciu. Vyvíjať ho začal David Reveman z Novellu a použil pritom kód z composite managera Compiz, rozšíril ho a momentálne obsahuje aj množstvo pluginov, bez ktorých by nebol tým, čím je. Hlavnou úlohou Berylu je uľahčiť a spestriť prácu v prostredí X Window. To by bolo na úvod všetko, prejdeme k hardvérovým nárokom.


Ukážka pluginu Scale

Hardvérové nároky

Na bezproblémový beh Berylu je potrebné vlastniť minimálne nasledujúcu zostavu: grafická karta GeForce 3/i855/, Radeon 7500, 256MB RAM a procesor s taktom 1.2 GHz. Beryl funguje pod grafickým prostredím KDE, Gnome a takisto XFCE4. Počítač, na ktorom mám Beryl nainštalovaný je: grafická karta GeForce 6600 GT 128MB/128BIT, procesor AMD Sempron 3100+ s taktom 1.8 GHz a 512MB RAM. Používam grafické prostredie XFCE4 v najnovšej verzii 4.4, ale popíšem nastavenie aj pre KDE a Gnome. Ešte podotknem, že najlepšie zatiaľ pracuje s X.org 7.1, s nižšími verziami som ho netestoval, čiže stopercentnú funkčnosť vám zaručiť nemôžem. Stále je to ešte beta verzia, prvá stabilná mala vyjsť koncom februára, no nestalo sa, a tak si ešte nejaký ten piatok počkáme... :). Ale pusťme sa už do inštalácie...

Inštalácia

Prvá vec, ktorú musíme urobiť, je povoliť testovacie balíčky, aby nám Portage dovolil nainštalovať Beryl, keďže sa jedná o beta verziu. Do súboru /etc/portage/package.keywords pridáme nasledujúce riadky:

x11-wm/beryl
x11-wm/beryl-core
x11-plugins/beryl-plugins
x11-plugins/beryl-dbus
x11-misc/beryl-manager
x11-misc/beryl-settings
x11-apps/xlsclients
x11-wm/emerald
x11-misc/emerald-themes
x11-themes/emerald-themes
x11-wm/heliodor

potom môžeme Beryl nainštalovať

emerge -va beryl

Ďalším krokom je inštalácia dekorátora okien. Na výber máme tri možnosti: Emerald, Aquamarine a Heliodor. Emerald je štandardný dekorátor pre Beryl a je kompatibilný so všetkými pracovnými prostrediami, či už je to KDE, Gnome alebo XFCE4. Tí, ktorí chcú používať aj naďalej témy určené pre KDE, si musia nainštalovať Aquamarine a kto chce mať natívne témy Metacity u Gnome, použije Heliodor. Emerald sa nainštaloval spolu s Berylom a inštaláciu Aquamarine či Heliodor vykonáte jednoducho príkazom emerge.


Na obrázku môžete vidieť minimalizovanie okna

Nastavenie X.org

Keďže mám grafickú kartu NVidia a používam ich binárne ovládače, popíšem tu nastavenie iba pre ne. O nastavení Xgl prípadne AIGLX prikladám na konci článku odkazy na Gentoo Wikipédiu, kde nájdete všetko potrebné. V editore si otvoríme súbor /etc/X11/xorg.conf a do sekcie Device pridáme nasledujúci riadok

Option "AddARGBGLXVisuals" "True"

a na koniec súboru doplníme

Section "Extensions"
Option "Composite" "Enable"
EndSection

Tak a máme nastavené X.org, čiže si nezabudnite reštartovať X server. Teraz môžeme náš Beryl konečne spustiť.

Spúšťanie

Manuálne spustenie (bez managera)

Nasledujúci skript spustí Beryl bez managera:

LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib/ \
beryl --replace dbus settings &
emerald &

KDE

Ak používate KDE, môžeme Beryl spustiť nadefinovaním premennej prostredia v súbore /etc/env.d/99kde-env

KDEWM=/usr/bin/beryl-manager

po tomto aktualizujeme naše prostredie

env-update

Ak chceme používať Aquamarine, musíme použiť skript /usr/local/bin/berylaqua-start

beryl --replace dbus settings &
aquamarine --replace &

ten môžeme potom zavolať bud priamo z KDE sedenia alebo ho použiť v premennej KDEWM

Ak chcete využiť všetky efekty Berylu, musíte mať v nastaveniach Control Center → Appearance & Themes → Style → Effects povolené GUI Effects, ale zakázať by ste mali Combobox, Tooltip, Menu, Menu tear-off handles a Menu Drop Shadow.


Transparentné okná tiež nie sú na zahodenie

Gnome

Ak používate Gnome, pridáme beryl-manager do Gnome Session Managera Gnome Panel → System/Prefs → Sessions → Startup a tam si nadefinujete nový príkaz beryl-manager

Ďalej si nastavíme GDM, aby sa nám Beryl spúšťal, keď sa prihlásime

# mkdir -p ~/.config/autostart

súbor ~/.config/autostart/beryl-manager.desktop obsahuje:

[Desktop Entry]
Name=No name
Encoding=UTF-8
Version=1.0
Exec=beryl-manager
X-GNOME-Autostart-enabled=true

Odteraz, keď spustíte X.org, načíta sa spolu s Gnome aj Beryl.

Ak chceme používať Heliodor, postup je podobný ako u KDE..., vytvoríme si skript /usr/local/bin/berylhelio-start

beryl --replace dbus settings &
heliodor --replace &

ten spúšťame priamo z Gnome sedenia alebo ho pridáme do Gnome Session Managera.

XFCE4.4

Ak používate XFCE 4.4, pridáme príkaz beryl-manager do Autostarted Applications a reštartujeme X server. Pri XFCE4.4 musíme používať Emerald ako dekorátor okien. Ten netreba nijak zvlášť spúšťať, mal by sa načítať automaticky spolu s Berylom. Ak sa tak nestane, otvoríme si shell a zadáme príkaz emerald --replace, čím sa Emerald stane štandardným dekorátorom. K nastaveniam by to malo byť všetko, ďalej popíšem základné problémy a ich riešenie, s ktorými sa väčšina z vás určite stretne.


Prepínanie medzi bežiacimi aplikáciami vyzerá veľmi efektne

Problémy

1. Ak sa vám nezobrazujú dekorácie okien, kliknite na ikonu Berylu v tray lište a v Advanced Beryl Options zmeňte Rendering Path na Copy. Ak to nepomôže, skúste zrušiť premennú prostredia XLIB_SKIP_ARGB_VISUALS=1, ale samozrejme iba v prípade, že ju máte exportovanú. Ak ani to nepomôže, nemáte nastavenú farebnú hĺbku na 24 bitov, vtedy musíte v súbore /etc/X11/xorg.conf do sekcie Screen pridať

DefaultColorDepth 24

2. Druhým problémom je to, že Beryl má štandardne zle nastavené obnovovanie obrazovky (refresh rate), čo má za následok spomalenie systému. To si zmeníme tak, že do shellu zadáme príkaz beryl-settings alebo klikneme na ikonu Berylu v tray lište a zvolíme Beryl Settings Manager. Pod položkou General odškrtneme Detect Refresh Rate a číselnú hodnotu Refresh rate nastavíme na 200. Ak to nepomohlo, skúste odškrtnúť aj Sync to VBlank.

Podotýkam, že s týmto som sa stretol aj ja a pomohlo mi to. Ak by ste s tým mali však problémy alebo ste sa stretli s niečim iným a neviete si rady, kľudne napíšte do komentárov alebo sa ozvite na môj e-mail a rád pomôžem ak to bude v mojich silách :).

Základné klávesové skratky

Alt + koliesko na myši - nastavuje transparentnosť aktuálneho okna
Alt + Tab - prepína medzi aplikáciami aktuálnej pracovnej plochy
Ctrl + Alt + Tab - prepína medzi aplikáciami všetkých plôch
Pravý horný roh obrazovky - keď sa tam presuniete myškou, Beryl zotriedi a rozmiestni okná z aktuálnej pracovnej plochy
Ctrl + Alt + Pravá/Ľavá šípka - otáča kockou do strán (prepína jednotlivé pracovné plochy)
Ctrl + Alt + klinutie a ťahanie myškou - otáčate kocku manuálne
Alt + Ľavé tlačítko myši - presúvanie okna
Ctrl + Alt + Ľavé tlačítko myši - presúvanie okna, ale s prichytávaním o okraje obrazovky
Dvojkliknutie na záhlavie okna - efektne zroluje okno

To by bolo k základným príkazom všetko, je ich totiž veľa a pre každý plugin si môžete nadefinovať vlastné klávesové skratky, čiže tento prehľad berte len orientačne, všetko záleží na nastavení, ktoré nájdete v Beryl Settings Manager. Takisto ich popis berte s nadhľadom, snažil som sa to popísať čo najzmysluplnejšie, ale poviem k tomu len toľko, že "treba vidieť... :)" a hlavne si to všetko odskúšať.


Otáčajúca sa kocka v svojej plnej kráse

Odkazy

Na záver ešte pár užitočných odkazov...

Beryl Project
Beryl Wiki
Beryl Forum
Beryl Themes
Beryl FAQ
Howto XGL
Howto AIGLX

Záver

Dúfam, že článok pomohol tým, ktorí to potrebovali a hádam sa mi podarilo v skratke zhrnúť moje skúsenosti s Berylom. Ak máte nejaké nejasnosti, prípadne pripomienky, vyjadrite sa v komentároch alebo mi pošlite e-mail.

    • re: 17.03.2007 | 23:53
      Avatar uid0 Debian  Používateľ
      tie poziadavky na grafiku a CPU su prehnane

      > najlepšie zatiaľ pracuje s X.org 7.1
      ono to chodilo aj so 7.0? mne sa zda, ze nVidia AIGLX ide az od 7.1
      Debian. apt-get into it…
      • Re: re: 18.03.2007 | 00:15
        dream   Návštevník
        ano, lenze binarky od nvidie boli uz aj pod 7.0.. myslim nvidia-drivers a s nimi starsie verzie pracovali/pracuju ;)
        • Re: re: 18.03.2007 | 00:39
          Avatar uid0 Debian  Používateľ
          nerozumiem. tak funguje nVidia so 7.0?
          Debian. apt-get into it…
          • Re: re: 18.03.2007 | 03:14
            dream   Návštevník
            neskusal som... ale teoreticky ano mal by fungovat aj s X.org 7.0 ;) treba vyskusat...
            • Re: re: 18.03.2007 | 11:41
              Avatar uid0 Debian  Používateľ
              omg, z dovodu, ktory som vyssie uviedol nemusi fungovat... ja som len narazal na dovod, preco by mal fungovat so 7.1 "lepsie"
              Debian. apt-get into it…
      • Re: re: 18.03.2007 | 03:27
        dream   Návštevník
        a mimochodom tie poziadavky na hw su prebrate z oficialnej stranky Berylu a ci su prehnane by mali vediet ti co to tam napisali ;) Beryl som tu chcel predstavit objektivnym pohladom nan a nie vlastymi ocami aj ked bez niecoho subjektivneho by to nebolo ono...
        • Re: re: 18.03.2007 | 11:43
          Avatar uid0 Debian  Používateľ
          tak mne to islo na GF2 MX a na nete je kopec postov, ze to chodi na nejakych 800 a 700 MHz CPU. pamat moze byt primerana, ale to plati aj ked tam nie je beryl...
          Debian. apt-get into it…
          • Re: re: 23.03.2007 | 21:29
            Avatar Oliver Kišš Ubuntu, Slax  Používateľ
            ja mam gf2mx, celeron800mhz a okolo 460mb ram a beryl mi slape v pohode. oproti compizu je o cosi pomalsi, defaultne nastavenie mi mierne trhalo pri presuvani okien (wobbly plugin) ale bolo to sposobene len tym ye beryl ma v defaultnych nastaveniach omnoho mensiu grid size ako compiz. po mensom nastaveni beryl funguje uplne plynulo, co sa tyka rychlosti mam s neho lepsi pocit nez z metacity, hlavne pri presuvani okien
      • Re: re: 18.03.2007 | 08:32
        Avatar Tomáš Srnka Barz čo, už asi všetko  Administrátor
        chodilo, ale len s XGL... :-)
        Dlho som robil linuxos.sk, neskôr založil vpsFree.cz, posledných pár rokov ako tech. riaditeľ vo Websupporte
        • Re: re: 18.03.2007 | 11:42
          Avatar uid0 Debian  Používateľ
          XGL je FUJ, XGL nie je X.org
          Debian. apt-get into it…
      • Re: re: 27.03.2007 | 19:50
        Avatar cHicKi Gentoo  Používateľ
        http://gentoo-wiki.com/HOWTO_nVidia_GL_Desktop_Effects
      • driver 03.04.2007 | 14:30
        Avatar samox86 arch, debian  Administrátor
        pekny clanok, ale chyba mi tam driver - ci si to rozbehaval na opensource alebo fglrx / nvidia (na opensource sa to da pomerne velmi lahko rozbehat ale ten vykon je mizerny; ak mam kvoli 3D "kocke" dat oss driver a dojist o moznost hrat hry tak sa to moc neoplati...)
        lnx.sk - virtualne servery; Lnx@Lnx.sk
        • Re: driver 03.04.2007 | 15:09
          Avatar Erik Mocný arch  Používateľ
          Pouzivam ovladace od nVidie... cize binarne :) Neviem ako je to s opensource drivermi, neskusal som.
    • zaciatocnik 18.03.2007 | 02:58
      Cyrus   Návštevník
      bola by to zla volba pre zaciatocnika?
      mam len zopar skusenosti s live cd linuxami, ale novym znalostiam sa nestitim :)
      • Re: zaciatocnik 18.03.2007 | 03:18
        dream   Návštevník
        teraz som celkom nepochopil ci sa pytas, ze ci je Beryl vhodna volba pre zaciatocnikov alebo hovoris o Gentoo?
      • Re: zaciatocnik 18.03.2007 | 11:43
        Avatar Tommy Angelo   Používateľ
        no na ubuntu to ide bezproblemov a nie je to ani také ťažké nainštalovať. A samotné Ubuntu myslím že nie je až také ťažké...
      • Re: zaciatocnik 18.03.2007 | 11:45
        Avatar uid0 Debian  Používateľ
        ano. beryl ma daleko k dokonalosti a moze byt problem to rozchodit (alebo sa nagooglis ako kon, ked nevies co vsetko musi byt na tvojom systeme este splnene)
        Debian. apt-get into it…
      • Re: zaciatocnik 18.03.2007 | 20:35
        Cyrus   Návštevník
        aha dik..
        jo myslel som beryl bo som u kamosa videl tu kocku na ktorej su plochy a otaca sa a sa mi to hrozne videlo len nevim co to bola za distrib... newite nahodou taku? okrem beryl
        tak asi ostanem pri kubuntu zatim
        • Re: zaciatocnik 19.03.2007 | 08:08
          Avatar 321Peto PCLinuxOS 2007  Používateľ
          skus sa pozret na http://www.mcnlive.org/ - je to live CD, tak si to mozes vyskusat pred instalaciou, ako ti to bude fungovat na tvojom stroji.
    • Aero bezi aj na GMA950 18.03.2007 | 15:30
      Jack   Návštevník
      Neviem ako beryl, ale aero bezi perfektne aj na integrovanej grafike Intel 950, takze zase ma Windows navrch ;-)

      P.S.: Nejake zlozitejsie vypocty nebudu? :-D
      • Re: Aero bezi aj na GMA950 18.03.2007 | 15:40
        kiub   Návštevník
        aj beryl bezi
      • Re: Aero bezi aj na GMA950 18.03.2007 | 15:54
        tommy   Návštevník
        to by som chcel vidiet ako Aero bezi na integrovanej grafike :), napis kolko mas fps.
        Mne bezi dpma Beryl na GeForce 2 MX 400, a 1,1 Ghz Durone a 386 MB RAM. Grafika nepodoruje shadery takze tie vodne efekty nejdu ale inak to to ide svizne.
        • Re: Aero bezi aj na GMA950 18.03.2007 | 16:41
          Avatar uid0 Debian  Používateľ
          ta integrovana grafka ma opengl a myslim, ze je vykonnejsia nez GF2
          Debian. apt-get into it…
          • Re: a pojde aj na Unichrome 28.03.2007 | 17:41
            skywaker   Návštevník
            Caute, neviete nahodou ci to bude slapat na microATx doske s Via Unichrome ? mam tam nejaky Celeron s 2.6ghz. a grafina Via Unichrome 3d Pro. asi bude lepsie pouzit unichrome driver? nez via?
      • Re: Aero bezi aj na GMA950 20.03.2007 | 18:04
        Avatar Marián Sova Ubuntu 10.10  Administrátor
        Beží bez problémov
        Čo ťa nezabije, to ťa posilní | Leták na propagáciu jabbera v pdf | www.mikroprocesory.sk
    • Chyba v uvode 19.03.2007 | 10:50
      Avatar NasaK Arch Linux  Používateľ
      Len, ze David Reveman nezacal vyvijat Beryl forkom z Compizu.. David Reveman je povodnym autorom Compizu.. Z neho sa forkol compiz-quinn, co mala pod palcom Quinnstorm.. A nasledne sa compiz-quinn premenoval na Beryl.. Tot vse.. ;)
      Freedom for everyone! Use Free Software...
      • Re: Chyba v uvode 21.03.2007 | 14:09
        Gentooista   Návštevník
        Este jedna vec. Najlepsie je veci tahat z gentoo overlay, http://www.gentoo-xeffects.org
        Odporucam instalovat cez Layman.
    • problem s emergovanim 23.03.2007 | 19:40
      dunmer   Návštevník
      Pri emergovani x11-plugins/beryl-plugins-0.2.1 vypise nasledujucu chybu:

      !!! ERROR: x11-plugins/beryl-plugins-0.2.1 failed.
      Call stack:
      ebuild.sh, line 1630: Called dyn_setup
      ebuild.sh, line 702: Called qa_call 'pkg_setup'
      ebuild.sh, line 38: Called pkg_setup
      beryl-plugins-0.2.1.ebuild, line 32: Called die

      !!! x11-libs/cairo missing glitz support
      !!! If you need support, post the topmost build error, and the call stack if relevant.
      !!! A complete build log is located at '/var/tmp/portage/x11-plugins/beryl-plugins-0.2.1/temp/build.log'

      neviete mi poradit co s tym?
      berte prosim ohlad nato ze som zaciatocnik .)
      vdaka
      • Re: problem s emergovanim 23.03.2007 | 20:33
        Avatar Erik Mocný arch  Používateľ
        Zrejme nemas zakompilovanu podporu glitz v kniznici cairo... Riesenie: bud zadas nasledujuci prikaz USE="glitz" emerge -av cairo alebo si nastavis USE flag pre kniznicu cairo pridanim riadku x11-libs/cairo glitz do suboru /etc/portage/package.use a nasledne skompilujes emerge -av cairo, alebo je tu este tretia moznost globalne pridat USE flag glitz do suboru /etc/make.conf, vykonat update prostredia a nasledne skompilovat kniznicu cairo. To by malo stacit ;)
      • Re: problem s emergovanim 23.03.2007 | 20:35
        WlaSaTy   Návštevník
        :x11-libs/cairo missing glitz support

        $ grep cairo /etc/portage/package.use
        #x11-plugins/beryl-plugins-0.2.1 need cairo with glitz
        x11-libs/cairo glitz

        kto by to bol cakal, ze? ale na zaciatocnika dat si gentoo, no skoda ze sa jedna o tak mladu distribuciu.
        • Re: problem s emergovanim 23.03.2007 | 21:23
          dunmer   Návštevník
          omg, ja som vazne slepy
          som cekol len tuto cast

          !!! ERROR: x11-plugins/beryl-plugins-0.2.1 failed.
          Call stack:
          ebuild.sh, line 1630: Called dyn_setup
          ebuild.sh, line 702: Called qa_call 'pkg_setup'
          ebuild.sh, line 38: Called pkg_setup
          beryl-plugins-0.2.1.ebuild, line 32: Called die

          a usudil som ze neviem co mam robit .))
          takze sorry za zbytocny post
          a obom dakujem, samozrejme .)

          btw, nejake distra som skusal aj predtym takze nie som uplny zaciatocnik. gentoo je jednoznacne najlepsie .)
      • Re: problem s emergovanim 24.03.2007 | 07:59
        dunmer   Návštevník
        tak nakoniec som sa aj tak zasekol na compile failure pri emergovani tohto gnome-base/nautilus-2.16.3
        • Re: problem s emergovanim 24.03.2007 | 19:08
          Avatar Andrej "karči" Krajči Gentoo  Administrátor
          preboha naco ti je nautilus pri beryle?
          "IB, thy name is homework." -- IB
          • Re: problem s emergovanim 24.03.2007 | 19:13
            dunmer   Návštevník
            hmm. to neviem. ja ani neviem co je natulis .)
            jednoducho te emerguje po zadani 'emerge beryl'
            takze som si myslel ze je to nejaka sucast berylu a ze to potrebuje.
            • Re: problem s emergovanim 24.03.2007 | 20:09
              Avatar Erik Mocný arch  Používateľ
              Ono to jednoducho robi preto, lebo chce kompilovat aj zavislosti pre gnome a tie mozes docasne vypnut tak, ze si beryl skompilujes nasledovne: USE="-gnome" emerge -av beryl ;)
              • Re: problem s emergovanim 25.03.2007 | 01:57
                dunmer   Návštevník
                -av pouzivam .)
                v kazdom pripade vdaka za rady. -gnome mam uz v use flagoch v make.conf
                neviem preco som to tam nedal doteraz
            • Re: problem s emergovanim 24.03.2007 | 21:47
              Avatar Andrej "karči" Krajči Gentoo  Administrátor
              Ak mas KDE alebo XFCE4 a nemas Gnome tak si vypni gnome USE flag ... a odporucam pouzivat prikaz emerge -av :) sa ta opyta ci chces emergovat to co ti vyhodi, uvidis co emergujes, ake useflagy to ma, a podobne vecicky. :)

              nautilus -> gnome-base/nautilus - A file manager for the GNOME desktop :)
              "IB, thy name is homework." -- IB
    • nejak to nejde .) 26.03.2007 | 19:40
      dunmer   Návštevník
      no... mam KDE a nainstaloval som beryl presne podla tohto navodu. ked som v KDE, beryl sa tvari ze je zapnuty [v pravo dole na liste mam ten diamant, ci co to je .)] ale nejako mi nefunguju tie klavesove skratky, ani sa nijako inak neprejavuje..
      nieco robim zle?
      • Re: nejak to nejde .) 26.03.2007 | 19:50
        Avatar Erik Mocný arch  Používateľ
        Skus sa najprv pozriet do nastaveni berylu cez tu ikonu v tray liste, ci mas zvoleny ako window manager skutocne Beryl a nie ten od KDE...
        • Re: nejak to nejde .) 26.03.2007 | 19:55
          dunmer   Návštevník
          hmm..
          no mam tam ten od KDE.. horsie ale je ze ked skusim nastavit Beryl tak prebliknu okna ale Beryl tam nenastavi. Namiesto toho tam posunie ten pre Gnome ./
          • Re: nejak to nejde .) 26.03.2007 | 22:14
            Avatar Andrej "karči" Krajči Gentoo  Administrátor
            pockaj typnem si ... nemas ATi? :)
            "IB, thy name is homework." -- IB
            • Re: nejak to nejde .) 26.03.2007 | 22:39
              dunmer   Návštevník
              ak tym ati myslis graficku kartu tak nie. mam nvidiu..
              ak tym myslis nieco ine tak neviem o com hovoris .)
            • Re: nejak to nejde .) 26.04.2007 | 15:37
              Miro   Návštevník
              Ja mam ATI 9250 a robi mi to prestne to iste.
              Som zaciatocnik a hrabat sa v konfigurakoch X.org je pre mna smrt !!!!!!!!!
              Uz par krat mi to spadlo a bol som rad, ze som to nahodil spat !
              Neviem ci mi to za to stoji.
              Neviete o dakom navode ako to rozchodit na grafike ATI 9250 ????
              • Re: nejak to nejde .) 26.09.2009 | 12:49
                BMjgwoibXpCYnZ   Návštevník
                auto insurance mlaqd [url="http://www.hollywoodbobbers.com/auto-insurance-online.html"]auto insurance quotes[/url] 570 http://www.hollywoodbobbers.com/auto-insurance-online.html ohs
          • Re: nejak to nejde .) 27.03.2007 | 00:03
            Avatar Erik Mocný arch  Používateľ
            Aku mas verziu Berylu? 0.2.0? pripadne 0.2.1? Ak ano, tak skus zadat do shellu prikaz beryl --replace a checkni si co ti to vypisuje... pripadne sem mozes hodit vypis ;)
            • Re: nejak to nejde .) 27.03.2007 | 03:42
              dunmer   Návštevník
              verzia beryl-0.2.1

              vypis beryl --replace:


              **************************************************************
              * Beryl system compatiblity check *
              **************************************************************

              Detected xserver : NVIDIA

              Checking Display :0.0 ...

              Checking for XComposite extension : passed (v0.3)
              Checking for XDamage extension : passed
              Checking for RandR extension : passed
              Checking for XSync extension : passed

              Checking Screen 0 ...

              Xlib: extension "GLX" missing on display ":0.0".
              Root visual is not a GL visual
    • XFCE + Beryl 09.04.2007 | 13:32
      aRagornol   Návštevník
      Nema niekto skusenost s XFCE4 + Beryl ? Mam Intel GMA950 grafiku a pri zavadzani Berylu Check for XComposite extensio failne.

      Checking for XComposite extension : Failed

      No composite extension
      beryl: SmcOpenConnection failed: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
      beryl : No composite extension
      • Re: XFCE + Beryl 09.04.2007 | 16:15
        Avatar Erik Mocný arch  Používateľ
        Ono, kebyze si precitas clanok tak zistis, ze Beryl som rozbehal s XFCE4.4 bez problemov ;)... lenze tvoj problem nema nic s XFCE ale s tym, ze mas zle nastaveny konfigurak pre X-ka, preto by nebolo na skodu hodit sem jeho vypis. /etc/X11/xorg.conf ;)
    • Mandriva 25.04.2007 | 09:23
      Hosak   Návštevník
      Ludia pojde mi to aj na Mandrive 2007 s GENOME?