Pomos s pripojenim na net (UBUNTU)

Sekcia: Konfigurácia 23.10.2007 | 14:21
Marek D.   Návštevník
Zdravim, nainstaloval som si ubuntu 7.04 a co sa tyka linuxu som uplny zaciatocnik. Doma mam router cez ktory sa pripajam do internetu a na ten chcem pripojit moj notebook s Ubuntu 7.04 . Skusal som to podla navodu ktory je v helpe ubuntu ale nedari sa mi to. Linux najde ethernet ale ked testuje spojenie tak pise (volne povedane) ze server alebo co neodpoveda. Mohli by ste mi prosim pomoct? Mozte pisat aj na email - marek.dovina@gmail.com . Vopred dakujem
    • Re: Pomos s pripojenim na net (UBUNTU) 23.10.2007 | 14:27
      Avatar Marián Sova Ubuntu 10.10  Administrátor
      Pripájaš sa na router káblom alebo cez wifi? Máš na routri nastavené DHCP?
      Čo ťa nezabije, to ťa posilní | Leták na propagáciu jabbera v pdf | www.mikroprocesory.sk
    • Re: Pomos s pripojenim na net (UBUNTU) 23.10.2007 | 15:19
      Avatar Frantisek Klabzuba Debian  Používateľ
      ja nastabujem v ubuntu siet (ako root) takto, pretoze tiez niesom schopny to naklikat, tiez mam router (nejaky zyxel, tusim 2002p ci ako):
      ifconfig eth0 down
      ifconfig eth0 192.168.5.101 netmask 255.255.255.0 up
      route add default gw 192.168.5.1
      echo nameserver 192.168.5.1 > /etc/resolv.conf

      Kde:
      192.168.5.101 - ip adresa mojho pc
      192.168.5.1 - ip adresa routera, co je zaroven brana a dns 
      • Re: Pomos s pripojenim na net (UBUNTU) 23.10.2007 | 20:45
        Marek D.   Návštevník
        dik, skusim to... treba nieco nastavovat aj na routri?
      • Re: Pomos s pripojenim na net (UBUNTU) 23.10.2007 | 22:07
        Marek D.   Návštevník
        tak skusil som to a po zadani ifconfig eth0 down mi vypisalo SIOCSIFFLAGS: Permission Denied, ked som skusil aj nasledujuci prikaz tak mi vypisalo niekolko podobnych hlaseni
        • Re: Pomos s pripojenim na net (UBUNTU) 23.10.2007 | 23:42
          Avatar borg Arch, Debian jessie  Administrátor
          pouzil si sudo?
          • Re: Pomos s pripojenim na net (UBUNTU) 24.10.2007 | 00:33
            Marek D.   Návštevník
            ano napadlo ma to... pohol som sa o prikaz dalej... po zadani druheho hore uvedeneho prikazu (s vlastnymi hodnotami a s pouzitim sudo) mi vypisalo podobnu chybu akurat s textom no such file or directory
        • Re: Pomos s pripojenim na net (UBUNTU) 24.10.2007 | 12:14
          Avatar Misko Kripel slackware  Používateľ
          cele to musis robit ako root takze

          sudo su
          asdf
          • Re: Pomos s pripojenim na net (UBUNTU) 24.10.2007 | 18:25
            Marek D.   Návštevník
            aj tak mi pise tie chyby.. je to asi tym ze som tam ako root(at)marek-laptop:/home/marek/# (resp. takto nejako to tam je napisane :) podla hlasky (no such file or directory usudzujem zeby som tam mal byt asi v hlavnom adresari / (cize root(at)marek-laptop:/#) .. ako to urobim? moze sa zdat ze mam primitivne otazky :) no s linuxom nemam ziadne skusenosti a help mi moc nepomohol... dakujem
            • Re: Pomos s pripojenim na net (UBUNTU) 24.10.2007 | 19:07
              ---   Návštevník
              takze mas v menu system-sprava polozku network kde sa da aktivovat pripojenie po kabli , skusal si to aktivovat? (pises ze je to v helpe ubuntu ale to zase ja neviem co tam je a co si teda skusal)
              • Re: Pomos s pripojenim na net (UBUNTU) 25.10.2007 | 01:14
                Marek D.   Návštevník
                OK dozvedel som sa ze na moju lan kartu si musi stiahnut ovladace a instalovat ich no bude to sranda nevim jak sa to takto robi :) hh... no a wifi by mi mala ist.. postupoval som podla navodu http://vntutor.blogspot.com/2007/10/how-to-use-graphical-tool-to-configure.html ... uz neviem kde moze byt chyba... ked pingnem ip routra tak vypisuje network is unreachable... mozno nieco treba nastavit na routri... mam Vigor2600V series annex B s internetom od te-comu :)
                • Re: Pomos s pripojenim na net (UBUNTU) 25.10.2007 | 01:21
                  Avatar Marián Sova Ubuntu 10.10  Administrátor
                  Router ak si neprenastavoval, tak je nastavený od výroby na DHCP a má povolenú wifi sieť bez šifrovania (tuším názov siete je T-COM). Čo ukazuje nm-applet pri hodinách? Alebo ešte lepšie, čo vypíše príkaz sudo iwlist scan ?
                  Čo ťa nezabije, to ťa posilní | Leták na propagáciu jabbera v pdf | www.mikroprocesory.sk
                  • Re: Pomos s pripojenim na net (UBUNTU) 25.10.2007 | 01:42
                    Marek D.   Návštevník
                    mam nastavene sifrovanie WEP 64bit ... no ukazuje nulovy signal :) idem zistit co vypise prikaz...
                  • Re: Pomos s pripojenim na net (UBUNTU) 25.10.2007 | 14:25
                    Marek D.   Návštevník
                    vypisalo nieco v zmysle

                    lo: nepovolene skenovanie

                    eth0: nepovolene skenovanie: zariadene nenajdene

                    (prelozene do slovenciny:) nezapamatal som si to poriadne
                    • Re: Pomos s pripojenim na net (UBUNTU) 25.10.2007 | 15:22
                      ---   Návštevník
                      a co je to za sietova karta? nejaka exotika?
                    • Re: Pomos s pripojenim na net (UBUNTU) 25.10.2007 | 22:53
                      Avatar Marián Sova Ubuntu 10.10  Administrátor
                      To ale znamená, že ti nefunguje sieťová karta. lo je loopback, eth0 je lan sieťovka a wifi tam nikde nevidím. Takže daj lspci, nech vidíme, čo máš za sieťovku.
                      Čo ťa nezabije, to ťa posilní | Leták na propagáciu jabbera v pdf | www.mikroprocesory.sk
    • Re: Pomos s pripojenim na net (UBUNTU) 23.10.2007 | 20:44
      Marek D.   Návštevník
      s kablom, pretoze potrebujem stiahnut ovladace na wifi alebo co to bude dalsi krok :)
      • Re: Pomos s pripojenim na net (UBUNTU) 23.10.2007 | 21:25
        Avatar lime Debian, Red Hat, Fedora Core 3  Používateľ
        wifi :) ta si nastuduj este iwconfig :))
        Prejdite z modrej obrazovky k linuxu :))
        • Re: Pomos s pripojenim na net (UBUNTU) 23.10.2007 | 21:50
          Avatar samox86 arch, debian  Administrátor
          vcera som sa odhodlal prejist z kubuntu 7.04 na 7.10. co ma dost zarazilo ze po instalacii nefungoval net (mam LAN modem s dhcp) co mi na vsetkych ostatnych distrach defaultne ide. kubuntu ma pekne klikatko (systemove nastavenia) kde sa da nastavit aj siet. po kliknuti na eth0 sa objavi konfiguracny dialog. tam zdam ip, masku a branu. stlacim OK. vtedy sa nastavenia pouziju (a naozaj ide net). pri zatvarani klikatka (systemove nastavenia) sa vsak spyta ci pouzit zmeny. dam ano - zas vypisuje ze nastavuje eth0 ale to ostava nenakonfigurovane (odporucam preto kliknut na "Zahodit zmeny", pripadne ukoncit tlacidlom "Zrusit"). zrejem nejaky bug ??? (neviem ako v ubuntu)
          lnx.sk - virtualne servery; Lnx@Lnx.sk