problem s RTL8111/8168B

Sekcia: Hardware a Drivery 11.12.2007 | 22:19
rado   Návštevník
caw ludia, mam problem s touto sietovou kartou na ubuntu (2.6.22-14-generic). Robi to asi tolko ze vsetko ide ok pokial nestahujem nejake vacsie subory, ked zacnem stahovat nieco vacsie tak mi odpoji eth0 akoby sa zhodil ovladac..... v ifconfig -a to vypise
eth0      Link encap:Ethernet  HWaddr 00:18:F3:C6:F5:03  
          inet addr:147.175.186.10  Bcast:147.175.186.255  Mask:255.255.255.0
          inet6 addr: 2001:4118:10:ba00:218:f3ff:fec6:f503/64 Scope:Global
          inet6 addr: fe80::218:f3ff:fec6:f503/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:206494 errors:0 dropped:0 overruns:0 frame:0
          TX packets:137047 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:291771744 (278.2 MB)  TX bytes:11482046 (10.9 MB)
          Interrupt:20 Base address:0x4000 

a na nejaky cas som odpojeny od netu, ked dam
ifconfig eth0 down

vypise
no device 
alebo nieco podobne...
po nejakom case sa ti spravi (priblizne 1 min) , alebo ked odoberiem modul r8169 a znova ho natiahnem tak to znova ide.... skusal som to aj s driverom od realteku r8168 bolo to to iste....

tu je daky log :
Dec 11 15:02:24 rood-laptop kernel: [ 2570.720000] ACPI: PCI interrupt for device 0000:02:00.0 disabled
Dec 11 15:03:43 rood-laptop kernel: [ 2650.268000] r8169 Gigabit Ethernet driver 2.2LK loaded
Dec 11 15:03:43 rood-laptop kernel: [ 2650.268000] ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [LNEA] -> GSI 17 (level, low) -> IRQ 20
Dec 11 15:03:43 rood-laptop kernel: [ 2650.272000] eth0: RTL8168b/8111b at 0xf8d04000, 00:18:f3:c6:f5:03, XID 38000000 IRQ 20
Dec 11 15:03:43 rood-laptop kernel: [ 2650.296000] r8169: eth0: link down
Dec 11 15:03:43 rood-laptop kernel: [ 2650.296000] r8169: eth0: link down
Dec 11 15:03:43 rood-laptop kernel: [ 2650.300000] ADDRCONF(NETDEV_UP): eth0: link is not ready
Dec 11 15:03:45 rood-laptop kernel: [ 2651.916000] r8169: eth0: link up
Dec 11 15:03:45 rood-laptop kernel: [ 2651.920000] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Dec 11 15:03:51 rood-laptop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.host_name
Dec 11 15:03:51 rood-laptop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.nis_domain
Dec 11 15:03:51 rood-laptop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.nis_servers
Dec 11 15:17:09 rood-laptop kernel: [ 3455.988000] NETDEV WATCHDOG: eth0: transmit timed out


prosim vas o pomoc... niesom si az tak velmi isty tym co som sem napisal (som zaciatocnik) tak ak nieco este treba tak dopisem

dikes vsetkym....
    • Re: problem s RTL8111/8168B 27.12.2007 | 10:01
      Avatar kvaso kubuntu, debian  Používateľ
      zdar, takto nejako sa spravala aj jedna moja masina a po dlhom patrani bol vysledok - chybna sietova karta. Ale prve co vyskusaj (kedze pouzivas ubuntu) tak si v /etc/network/interfaces nastav vsetky rozhrania rucne (nie cez avahi), lebo avahi robi kope ludom dost velke problemy(ak nevies ako tak napis - poradime :) )ak to nepomoze tak odporucam este pospekulovat s kablom (aky dlhy je kabel k switchu? aky switch to je? neskusal si vymenit na skusku switch?), mozno skusit ine jadro(alebo este lepsie distro).
      • Re: problem s RTL8111/8168B 24.06.2008 | 17:37
        ftakopysq   Návštevník
        Chyba nebude v sieťovej karte. Inštaloval som teraz dve nové dosky od Intelu s týmito sieťovkami a ani jednu mi pri inštalácii nenašlo. Inštaloval som CentOS, nevie rozpoznať tieto sieťovky, takže predpokladám že aj pri iných linuxoch to robí podobný bordel.
        • Re: problem s RTL8111/8168B 25.06.2008 | 12:19
          Avatar Peter Kotrčka Debian GNU/Linux Sid @ KDE  Používateľ
          centos s akym jadrom? jebo podpora pre 8168 je v jadre len kratko.. od 2.6.18 alebo 19
    • Re: problem s RTL8111/8168B 27.06.2008 | 17:36
      Avatar nardew debian  Používateľ
      pokial viem, jednalo sa o bug v ovladacoch, dokonca aj tie priamo na realtekackej stranke boli chybne. ja som to vtedy riesil rucnym fixovanim, ale myslim ze teraz staci nahodit novsi kernel a tam to je uz v poriadku (minimalne co sa tyka gentoo opatchovaneho jadra).