Problem s 3D akceleraciou Ati

Sekcia: Konfigurácia 27.02.2008 | 19:48
deex   Návštevník
Zdravim.Mam linux kratko.Mam problem s 3D akceleraciou na mojej grafickejn karte Ati Radeon.Notebook Hp Amd sempron,Mandriva 2008 powerpack.V MCC hardware mi pise Radeon X200 Series 5955 a v nastaveni grafickeho servera mam Radeon 9500 X850.Tak neviem.V nastaveni graf servera sa spyta ci chcem pouzit ovladac ktory je dostupny ,zadam ano.Ale asi to nie je spravny ovladac.Alebo ho treba configurovat nejak.Nedostanem sa ani na ATI catalyst control center,pise,ze bud nie je nainstalovany ziadny ovladac,alebo nepracuje spravne.Ze mam skusit config.Mam par otazok.
1.Ako zistim nainstalovany driver,respektive jeho verziu cez konzolu
2.Ako zistim verziu Xorg,ak bude treba,na Ati stranke su nejake ovladace,len musia sediet na Xorg,neviem este sa v tom moc nevyznam.Cital som aj o nejakych free driveroch
3.Ako zistim ktoru kartu vlasne mam?Tu X200 series ci 9500-asi trochu primitivna otazka,sorry
4.Ako odinstalovat ovladac a install novy
5.Ako ho configurovat/co zadat do konzoly

Moj vypis z xorg.config

# File generated by XFdrake (rev 230776)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
#DontZap # disable <Ctrl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
#DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us(alt-intl)"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "InputDevice"
Identifier "SynapticsMouse1"
Driver "synaptics"
Option "SHMConfig" "on"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "Flat Panel 1024x768"
HorizSync 31.5-90
VertRefresh 60

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "ATI Technologies Inc"
BoardName "ATI Radeon 9500 - X850"
Driver "fglrx"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
InputDevice "SynapticsMouse1" "AlwaysCore"
Screen "screen1"
EndSection

Myslim,ze asi ta sekcia Device je dolezita.Ako je to s tou podporou fglrx,tiez v tom mam hokej.Dost som aj googloval.Ak treba este nejaky vypis,hodim to sem.Dakujem vopred za rady
    • Re: Problem s 3D akceleraciou Ati 28.02.2008 | 18:13
      Avatar samox86 arch, debian  Administrátor
      fglrx sa ti nenacita pokial nevypnes composite (ak ho vypnes nespustis beryl ani compiz).
      jednoducho mas ati a preto mas smolu...

      http://gentoo-wiki.com/HOWTO_ATI_Drivers#Configure_X

      konkretne:

      Section "Extensions"
      Option "Composite" "false"
      EndSection
      lnx.sk - virtualne servery; Lnx@Lnx.sk
      • Re: Problem s 3D akceleraciou Ati 29.02.2008 | 10:01
        DanoD   Návštevník
        Mam podobny problem notebook acer 3020, Ati x600, ubuntu 7.10. Sprava neslobodnych ovladacov nainstaluje grafiku uspesne. vsetko vyzera ze je v poriadku.... ale composite extensions are not available...
        skusal som instalovat aj ATI Proprietary Linux Driver... chovalo sa to este horsie
        Podarilo sa to niekomu rozbehat na tejto karte?

        Chcelo by to trosku viac si prestudovat tuto problematiku... ako funguje Xorg, ako je to vlastne s tymi ovladacmi, ktory ovladac je ktory, kde je vlastne problem.
        Ale fakt nemam na toto cas :( (praca)
        Nechce sa niekomu o tom napisat nejaky clanok :) roznych postupov ako nainstalovat ati je na internete fura. Ale chubaju mi nejake fakty... A aby som aj rozumel co robim a preco.

        Inak odpoved ze mas ati mas smolu znamena ze mi to jednoducho nepojde?
        • Re: Problem s 3D akceleraciou Ati 29.02.2008 | 11:03
          Avatar Predrag Ubuntu 10.04  Používateľ
          tu mas navod ako treba nainstalovat ati pre rozne distribucie
          Fujitsu Siemens Amilo Pa 1510, Ati Radeon x 1100.
      • Re: Problem s 3D akceleraciou Ati 29.02.2008 | 16:41
        Avatar Peter Drábik ArChLiNuX  Používateľ
        ja mam composite zapnute s najnovsim fglrx a nemam problem... viz http://gentoo-wiki.com/HOWTO_AIGLX
        I am Sentinel because my Eyes are both Electric... Judas Priest POWAAAA!!!
        • Re: Problem s 3D akceleraciou Ati 03.03.2008 | 17:18
          deex   Návštevník
          Tak som prisiel na to,ze ked vypnem efekty v MCC,tak sa dostanem aj do Ati catalyst centra a aj v konzole ukazuje ze direct rendering Yes.Len by ma zaujimalo,preco to nejde mat zapnute naraz aby to slo.Nevie niekto poradit?