localhost

Sekcia: Konfigurácia 28.07.2008 | 13:39
Avatar pistik   Používateľ
Nazdar, kedze som v linuxe iba kratko prosim o strpenie. Pouzivam mandrivu 9.2. Vo volnom case pisem weby. Jedna z veci ktoru potrebujem je testovat ich na localhoste. Z toho dovodu potrebujem vediet kam prislusne subore ukladat (stranky a mysql subory). Moze mi niekto v kocke poradit ako na to?
    • Re: localhost 28.07.2008 | 13:48
      Avatar Dare_devil Debian, OpenSuse  Používateľ
      Podla navodu ktory je v databazy znalosti ( pre ubuntu ) si nainstaluj apache + php + mysql ( predsa len, je jedno akym sposobom to instalujes, ale potrebne baliky su vzdy rovnake ). Po zapnuti a nastaveni prav pre /var/www/ ( obcas /var/www/html/ ) [ aby mohol ukladat aj bezny user, vykonas to su -c 'chmod 777 /var/www/' ] sa tato zlozka zobrazuje ako localhost
      There is no flag large enough to cover the shame of killing innocent people
      • Re: localhost 28.07.2008 | 14:49
        Avatar pistik   Používateľ
        vyzera ze som na dobrej ceste, len mi apache vyhadzuje 403 forbidden.
        • Re: localhost 28.07.2008 | 23:34
          Avatar Marián Sova Ubuntu 10.10  Administrátor
          Pravdepodobne máš zle nastavené práva na súbory vo www priečinku. Pozri sa či ich môžu čítať aj ostatný.
          Čo ťa nezabije, to ťa posilní | Leták na propagáciu jabbera v pdf | www.mikroprocesory.sk
          • Re: localhost 29.07.2008 | 18:08
            Avatar pistik   Používateľ
            dal som mu chmod 777 uz predtym takze pes bude zakopany inde
            • Re: localhost 29.07.2008 | 18:11
              --   Návštevník
              daj na pastebin.org konfiguracny subor pre apache

              a daj tam aj vypis z ls -lR /var/www
    • Re: localhost 28.07.2008 | 15:18
      --   Návštevník
      este sa da v konfiguracii nastavit (neviem ci to mas v default konfiguracii) aby sa ti adresar ~/public_html zobrazoval na adrese http://localhost/~pouzivatel/ osobitne pre kazdeho pouzivatela.

      neviem ako to bude u teba kedze mas pomerne stare distro ale v mojom konfigu (niekde v /etc/apache, resp. /etc/apache2) je nieco take:
      LoadModule userdir_module /usr/lib/apache2/modules/mod_userdir.so
      
      <IfModule mod_userdir.c>
              UserDir public_html
              UserDir disabled root
      
              <Directory /home/*/public_html>
                      AllowOverride FileInfo AuthConfig Limit
                      Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
              </Directory>
      </IfModule>