Problém s načítaním médií

Sekcia: Hardware a Drivery 24.09.2008 | 01:50
Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
No vyskytol sa mi takýto problém. Poraď, kto môžeš.
Dal som preč openSUSE 11.0 aby som vyskúšal StudioUbuntu 8.04. To som dal preč, lebo to šlo pomaly ako hladnému.... no dal som späť 11.0-ku.
Problém je, že v záložke media (v stromovej štruktúre, čo je na pravej strane okna keď kliknem, čo ja viem, napr. na domovský adresár), mi nenáčíta ani HDD, ani CD-ROM, ani USB a ani Flopy disc.. Výsledkom toho je, že Mplayer mi nič nespustí (teda DVD), lebo nevidí cestu k hardvéru. "Tento počítač" mi ich ale zobrazí. No, mohol by som to celé reinštalovať, ale ja by som to radšej opravil. Nevie niekto poradiť, ako pripojiť médiá tak aby sa mi v kolonke "media" zobrazili?
Vďaka.
    • Re: Problém s načítaním médií 24.09.2008 | 02:10
      Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
      Opravujem sa. USB mi v kolonke "media" zobrazí.
      • Re: Problém s načítaním médií 24.09.2008 | 09:59
        l_barbarossa   Návštevník
        v Gnome ci v KDE?
        • Re: Problém s načítaním médií 24.09.2008 | 12:42
          Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
          Sorry to mi nejak vypadlo. V KDE 3.5
          • Re: Problém s načítaním médií 24.09.2008 | 18:35
            Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
            Nikto nič ? Tak to budem musieť asi reinštalovať :-(
            • Re: Problém s načítaním médií 24.09.2008 | 19:49
              l_barbarossa   Návštevník
              klasicka rada - ako sa to sprava pod inym, povedzme ze aj nanovo vytvorenym uzivatelom?
              • Re: Problém s načítaním médií 24.09.2008 | 20:09
                Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
                Akurát to idem skúsiť...
              • Re: Problém s načítaním médií 24.09.2008 | 20:19
                Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
                Áno, chová sa to rovnako.
                • Re: Problém s načítaním médií 24.09.2008 | 23:19
                  l_barbarossa   Návštevník
                  a co tak pre skusku mountnut najprv media z konzoly (ako root)?
                  Pri DVD-cku zadaj aj parameter suboroveho systemu -t iso9660 namiesto auto, alebo udf
                  • Re: Problém s načítaním médií 25.09.2008 | 00:01
                    Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
                    Vďaka, ale skonzolou absolútne neviem pracovať.. Linux ako OS ešte stále nechápem...
                    ...ale dal som do konzolly "mount" a vyhodil mi toto..neviem čo ti to povie

                    abraxas@linux-6beo:~> mount
                    /dev/sdb3 on / type ext3 (rw,acl,user_xattr)
                    proc on /proc type proc (rw)
                    sysfs on /sys type sysfs (rw)
                    debugfs on /sys/kernel/debug type debugfs (rw)
                    udev on /dev type tmpfs (rw)
                    devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
                    /dev/sdb2 on /home type ext3 (rw,acl,user_xattr)
                    /dev/sdb1 on /windows type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_p ermissions,blksize=4096)
                    /dev/sda1 on /windowsC type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_ permissions,blksize=4096)
                    fusectl on /sys/fs/fuse/connections type fusectl (rw)
                    securityfs on /sys/kernel/security type securityfs (rw)
                    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
                    • Re: Problém s načítaním médií 25.09.2008 | 01:36
                      l_barbarossa   Návštevník
                      napr. mount /dev/sdb1
                      • Re: Problém s načítaním médií 25.09.2008 | 02:15
                        Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
                        Skúsil som to a napísal toto :

                        Error opening '/dev/sdb1': Prístup odmietnutý
                        Failed to mount '/dev/sdb1': Prístup odmietnutý
                        Please check '/dev/sdb1' and the ntfs-3g binary permissions,
                        and the mounting user ID. More explanation is provided at
                        http://ntfs-3g.org/support.html#unprivileged
                        abraxas@linux-6beo:~>
                      • Re: Problém s načítaním médií 25.09.2008 | 02:31
                        Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
                        potom som skúsil CD-ROM-ky:

                        abraxas@linux-6beo:~> mount /dev/sr0
                        mount: can't find /dev/sr0 in /etc/fstab or /etc/mtab

                        abraxas@linux-6beo:~> mount /dev/sr1
                        mount: can't find /dev/sr1 in /etc/fstab or /etc/mtab
                      • Re: Problém s načítaním médií 25.09.2008 | 02:37
                        Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
                        tak som si pozrel etc/fstab , a tam je toto:

                        dev/disk/by-id/scsi-SATA_WDC_WD6400AACS-_WD-WCAUF0024874-part4 swap swap defaults 0 0
                        /dev/disk/by-id/scsi-SATA_WDC_WD6400AACS-_WD-WCAUF0024874-part3 / ext3 acl,user_xattr 1 1
                        /dev/disk/by-id/scsi-SATA_WDC_WD6400AACS-_WD-WCAUF0024874-part2 /home ext3 acl,user_xattr 1 2
                        proc /proc proc defaults 0 0
                        sysfs /sys sysfs noauto 0 0
                        debugfs /sys/kernel/debug debugfs noauto 0 0
                        usbfs /proc/bus/usb usbfs noauto 0 0
                        devpts /dev/pts devpts mode=0620,gid=5 0 0
                        /dev/disk/by-id/scsi-SATA_WDC_WD6400AACS-_WD-WCAUF0024874-part1 /windows ntfs-3g users,gid=users,fmask=133,dmask=022,locale=sk_SK.UTF-8,umask=0002 0 0
                        /dev/disk/by-id/scsi-SATA_SAMSUNG_SV0761D0249J1FNB04944-part1 /windowsC ntfs-3g users,gid=users,fmask=133,dmask=022,locale=sk_SK.UTF-8,umask=0002 0 0
                      • Re: Problém s načítaním médií 25.09.2008 | 02:43
                        Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
                        a v dev/mtab, mám zas toto:

                        /dev/sdb3 / ext3 rw,acl,user_xattr 0 0
                        proc /proc proc rw 0 0
                        sysfs /sys sysfs rw 0 0
                        debugfs /sys/kernel/debug debugfs rw 0 0
                        udev /dev tmpfs rw 0 0
                        devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
                        /dev/sdb2 /home ext3 rw,acl,user_xattr 0 0
                        /dev/sdb1 /windows fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
                        /dev/sda1 /windowsC fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
                        fusectl /sys/fs/fuse/connections fusectl rw 0 0
                        securityfs /sys/kernel/security securityfs rw 0 0
                        none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
                        • Re: Problém s načítaním médií 25.09.2008 | 10:08
                          l_barbarossa   Návštevník

                          1. mountovat musis ako root, ak tak robis, skoc na bod 3

                          2. opticke mechaniky musis v tvojom pripade mountovat v "zakladnom zneni" prikazu, prave preto, ze nemas o nich zmienku v /etc/fstab. Cize najprv si ako root vytvor priecinok kam ich budes chciet mountnut, napr.: mkdir /media/cdrom_1 a potom disk mountnes mount -t iso9660 /dev/sr0 /mnt/cdrom_1

                          3. /etc/fstab ti hovori o tom, co sa ma kam a ako pripojit a /etc/mtab zas o tom, co je kam a ako pripojene - cize tvoje win particie by uz mali byt pripojene vo /windows a /windowsC (a snad preto ich - bez volby remount - nemozes znova pripojit do toho isteho adresara ani ako root - vid bod 1)


                          Sorry, ze ti zivim nadej, pretoze ani KDE ani Suse nepoznam, a to, o com sa bavime je iba uplny zaklad.
                          • Re: Problém s načítaním médií 25.09.2008 | 11:27
                            Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
                            ...ktorý nepoznám. Len tak medzi rečou. Ale vďaka. Lenže ako dlho mi nikto nenapísal, tak je som systém reinštaloval. No v media sa mi zobrazí len to médium ktoré je v počítači. T.j len tie CD alebo DVD, a USB. HDD nie. Ale je dosť možné, že to v SUSE ani tak nemá byť, lebo vsetky tie HDD, FD, CD-DVD rom, sa mi zobrazia v "Storage Media" Teraz neviem, či Mplayer, ktorý teraz ešte na openSUSE 11.0 KDE nemám nainštalovaný, mi svojim prehľadávačom umožní vidieťaj túto položku, alebo či mi DVD nespustí hneď, kedď kliknem na Play DVD.
                            ..ináč si to preštudujem, čo si písal a dík za základy, lebo Linuxu naozaj nerozumiem. Ešte ako tak okná ale v čom to spočíva, to ešte určite nie.
                          • Re: Problém s načítaním médií 25.09.2008 | 11:29
                            Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
                            ...ale dám vedieť :-)
                          • Re: Problém s načítaním médií 25.09.2008 | 15:53
                            Avatar Abraxas Debian 505 Xfce; VL 6.0-light; Xubuntu 8.10  Používateľ
                            ..tak Páni ja asi kašlem na celé KDE 3.5

                            Proste to od nainštalovania nefičí jak má. Kaffein neprehráva video, lebo je orezaný. Tak ho upgradnem s PackMana, a ten zas nemá cestu k médiám a video mo neprehrá. a keď aj, lebo jednu CD-rom sa mu ráči vidieť, tak sa nedajú preskakovať tracky. Mplayer detto.. tak isto nevidí cestu k Hardvéru myslím DVD-romky. A tiež, keď skúsim dať ďalší track, tak mi padne, lebo vraj "bad usage" . Toto sú veci s ktorými sa užívateľ nemá čo babrať. Proste sa to naištaluje a má to fachčiť. Alebo sa mýlim? Akože sorry ešte skúsim dať GNOME, ale keď sa aj to bude srať, neviem, či sa na celý Linux nevyseriem...