Fedora 10 a zvuk v Gnome+KDE+Xfce

Sekcia: Hardware a Drivery 17.01.2009 | 17:40
Avatar ninu Slackware, Android  Používateľ
Dobrý den,
pred nedavnom som si nainstaloval Fedoru 10 na svoj notebook HP Compaq 6735s a pri instalacii som zvolil prostredie Gnome aj KDE aj Xfce (Gnome uz poznam z Ubuntu a tak chcem skusit aj KDE a Xfce).

Chcem sa spytat ci pre kazde prostredie treba zvlast nastavovat graficku kartu, zvukovu a wifi a tieto veci, alebo to staci spravit v jednom prostredi a funguje to vo vsetkych ?

Pytam sa, pretoze v Gnome som rozchodil zvuk podla navodu z netu, konkretne takto:

-- nahodil som Alsa, alsamixer, alsamixergui
-- treba vytvoriť súbor sound a do neho dať nasledujúce riadky:
options snd slots=snd-hda-intel
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=laptop
-- novovytvorený subor sound nakoniec prekopírovať do /etc/modprobe.d/
-- nakoniec restart


Takto mi zvuk ide v pohode, ale iba v Gnome. Ked sa prepnem do KDE alebo Xfce tak tam uz zvuk neide.
V com je problem ? Preco to v ostatnych prostrediach neide ? Treba aj v nich instalovat este raz alsu, alebo co ?

Okrem toho, instaloval som Fedoru z DVD 32bit system a nainstalova sa mi strasne vela programov, je to kvoli tomu ze som zvolil 3 graficke prostredia ?

Dakujem kazdemu za dobre rady ...
Slackware
    • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 17:54
      Avatar marcel.h Mint, KDE, Gnome  Používateľ
      >ZVUK = skus v KDE nastaviť aby ovladac zvuku bol "pulseaudio"

      >PROGRAMY = každé grafické prostredie má svoje preddefinovane programy, ale asi si tam mal aj na vyber, ktore chces a ktore nie. Programov, ktore ti nevyhovuju sa zbaviš lahko (Grafická verzia programu sa volá "pirut", alebo aj ako synaptic je tam "yumex "), tam si to vieš odstrániť.
    • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 17:55
      Avatar Peter Kotrčka Debian GNU/Linux Sid @ KDE  Používateľ
      v kazdom prostredi pre istotu nastav napevno alsu a nie pulseaudio..

      potom by malo byt jedno, v ktorom prostredi si, nakolko toto nastavenie, ktore si napisal plati pre cely system, je to nastavenie kernel modulu, ktory obhospodaruje tvoju (a vela podobnych) zvukoviek.

      v klasickom KDE menu daj System => System settings a v nom klikni na Audio.

      v kazdej polozke daj namiesto najvyssieho pulseaudia tu polozku, kde je nazov zvukovky alebo cipu (ja tam mam napr. Cmedia CMI8738 (model 37)).

      a odhlas sa a prihlas.. a napis, ci sa nieco pohlo.
      • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 18:07
        Avatar ninu Slackware, Android  Používateľ
        OK, dakujem obom, bolo treba nastavit to audio, len kedze som bol v neznamych prostrediach, som bol troska dezorientovany a fascinovany novymi vecami. Zvuk aj grafika uz vsade slapu.

        Budem musiet zopar programov dat prec, lebo mam asi 5 textovych editorov, 4 konzole, atd ... Budem musiet spravit nejaky poriadok.

        Este by som mal otazocku. Tato sa tyka procesora. Mam totiz 2 jadrovy AMD Athlon X2, ono Fedora detekuje sice obe jadra, ale vypisuje ze su iba 1000 MHz a pritom by som mal mat 1800 MHz. Jak sa toto da napravit ?
        Slackware
        • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 18:13
          Avatar Peter Kotrčka Debian GNU/Linux Sid @ KDE  Používateľ
          chces mat stale procak naplno? chod do nastaveni sluzieb (podla prostredia ti poviem, ze kde presne to je) a vypni cpuspeed...

          co sa tyka programov, samozrejme somariny odinstaluj.. zbytocne ti bude openoffice aj koffice na jednom pocitaci.

          aj s prostrediami nakoniec skoncis tak, ze jedno postaci (odporuam gnome pre zaciatocnika kvoli slovencine),
          • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 18:42
            Avatar ninu Slackware, Android  Používateľ
            Takto co sa tyka tej zvukovky. Spravil vsetko podla toho navodu co je vyssie a potom bolo treba v
            Gnome - v Ovladani Hlasitosti nastavit Device na HDA ATI SB (Alsa Mixer)
            KDE - System-System Settings – Sound a tam som vsade dal svoju HDA ATI SB (AD198x Analog)--co je moja zvukovka, hore na prvu poziciu
            Xfce - dal som Nastavenia hlasitosti – Subor – Nastavenie – a tam som zariadenie prepol na HDA ATI SB


            Co sa tyka toho procaku, ja nechcem aby isiel stale naplno ked nemusi, ale ak je to potrebne aby som mal k dispozicii plny vykon mojho procaku.
            Ked som zadal prikaz cat /proc/cpuinfo vo vypise som vydel cpu cores : 2, ale pri cpu MHz bolo iba 1000, a ja by som mal mat 1800 MHz.
            Slackware
          • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 19:57
            Avatar ninu Slackware, Android  Používateľ
            V Gnome som nasiel nastavenia sluzieb a je tam aj cpuspeed, ale co vlastne robi tato sluzba ? Lebo ked je to dobra a uzitocna vec, tak to predsa vypinat nebudem.
            Ja som sa len zlakol ze mi system detekuje len 1000 MHz ...
            Slackware
            • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 20:32
              Avatar Peter Kotrčka Debian GNU/Linux Sid @ KDE  Používateľ
              no ona je vyhodna pre notebooky.. lebo ked nepotrebujes plny vykon procesora, tak mu to znizi frekvenciu.. a asi to vedia aj desktopove cpu.

              tolko to robi.. skus to vypnut (nie zakazat) a zisti, ci to ma nejaky ucinok
              • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 20:59
                Avatar ninu Slackware, Android  Používateľ
                No dobre, a ked budem potrebovat plny vykon, tak to zas automaticky zvysi frekvenciu ???
                Slackware
              • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 21:02
                Avatar ninu Slackware, Android  Používateľ
                inak vyskusal som vypnut tuto sluzbu a mal som frekvenciu 1900 MHz, takze to funguje ... Je to vlastne automaticka regulacia frekvencie cpu, a tym padom by to malo setrit bateriu nie ?
                Slackware
                • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 21:17
                  Avatar Peter Kotrčka Debian GNU/Linux Sid @ KDE  Používateľ
                  ano, take cosi..

                  tak fajn, ze to funguje.. som rad.
        • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 18:13
          Avatar Peter Kotrčka Debian GNU/Linux Sid @ KDE  Používateľ
          ozaj, zabudol som.. dal si to teda na alsu? alebo co pomohlo? mohol by si to pridat do databazy znalosti.
          • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 18:16
            Avatar marcel.h Mint, KDE, Gnome  Používateľ
            jojo, pridaj bo sa aj ja chystam na Fedorku, a s tou grafikou si podla coho postupoval? Ja mam ATI-nu.
            • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 18:20
              Avatar Peter Kotrčka Debian GNU/Linux Sid @ KDE  Používateľ
              veru.. poriadne sa nachystaj... aj ja mam dnes za sebou cerstvu instalaciu na jeden strojcek... a chodi to vynikajuco.. .
              • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 18:28
                Avatar marcel.h Mint, KDE, Gnome  Používateľ
                "ninu" tu grafiku si podla coho robil? dik
                • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 18:34
                  Avatar ninu Slackware, Android  Používateľ
                  Tu ATI-nu som poriesil podla tohto navodu ...


                  Okreto toho som to riesil na tu na fore v tejto teme
                  Ten prvy navod fungoval, len este bolo treba v grub.conf vymazat argument "rhgb", potom to uz vsetko fungovalo.
                  Slackware
                  • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 18:41
                    Avatar marcel.h Mint, KDE, Gnome  Používateľ
                    dak pekne ;-)
                    • Re: Fedora 10 a zvuk v Gnome+KDE+Xfce 17.01.2009 | 18:44
                      Avatar ninu Slackware, Android  Používateľ
                      rado sa stalo :-)
                      Slackware