Problémy s ATI drivermi

Sekcia: Ostatné 04.06.2009 | 21:18
Miroslav Chodil   Návštevník
Dobrý deň, práve som s pomocou doinštaloval Debian Etch (5.00), no potreboval by som pomoc s drivermi. Materska doska je Asus M4A78T-E, s integrovanou Ati Radeon HD 3300 grafickou kartou. Ovládače som stiahol z oficiálneho webu Amd.com, no po inštalácii sa namiesto Log in screenu zobrazí iba "biely štvorec s čiernym štvorcom v pravom dolnom rohu": Chybu prisudzujem novo nainštalovanému driveru, takže by som ho potreboval znova odinštalovať. Neviem to však urobiť cez terminál, tak by som potreboval nejaký príkaz na obnovu/reštart driverov. Za odpovede vopred ďakujem.
    • Re: Problémy s ATI drivermi 04.06.2009 | 21:48
      Avatar Branislav Poldauf Ubuntu LTS, Debian stable  Používateľ
      prepac ze zbytocne reagujem aje pojem/nazov MATERSKA doska sa mi velmi zapacil, jed to take mile, odteraz to budem pouzivat (aj ked to mozno nie je spravne - gramaticky)

      k problemu:
      po nabootovani sa prepni do inej tty (ctr+alt+F3) a skus spustit startx mozno to vyhodi chybu ktora sa bude dat riesit

      riesenie by sa dalo dosiahnut upravou suoru /etc/X11/xorg.conf ale nepoviem ti ako (ja to zasadne dobabrem)

      mozes skusit pouzit iny ovladac (viem ze pre ATI su rozne verzie nech napise niekto kto ma skusenosti s ati)
      Linux: the operating system with a CLUE... Command Line User Environment
      • Re: Problémy s ATI drivermi 05.06.2009 | 21:36
        Miroslav Chodil   Návštevník
        Pri startx mi vypise:

        1. Creating new autority file /home/user/.Xautority
        2. Creating new autority file /home/user/.Xautority
        3. Fatal Server Error
        Server is already active for display 0. If server is no longer running, remove /temp/.X0-lock and start again.

        Dakujem.
    • Re: Problémy s ATI drivermi 05.06.2009 | 22:49
      Avatar Jan Hovancik debian, win  Používateľ
      no myslim ze by pomohlo jednoducho nainstalovat free xorg driver

      resp. predpokladam ze ten oficialny driver niekde na webe ma pokyn ako to odinstalit
      - peace, not war -
      • Re: Problémy s ATI drivermi 06.06.2009 | 00:31
        Avatar Peter Barlik Gentoo  Používateľ
        1. skus napisat aticonfig --initial a potom restartnut ak nepomoze
        skusil by som zistit na com spadli X-ka v logu by to mohlo byt popisane less /var/log/Xorg.0.log
        2. co sa tyka opensource driverov tak podla mna su lepsim riesenim aj ked vyvoj niektorych ovladacov nie je v takom stadiu ako v ovladacoch z ATI.com
        • Re: Problémy s ATI drivermi 06.06.2009 | 20:09
          Avatar martin001 Ubuntu 9.10; a iné..  Používateľ
          pripadne hned na zaciatku skus restartovat x.ko ctrl+alt+backspace .. je to sice rada ako z windows vystrihnuta (reboot and reboot) ale co uz
    • Re: Problémy s ATI drivermi 07.06.2009 | 15:14
      Miroslav Chodil   Návštevník
      Jan Hovancik: Na Linux som úplný začiatočník, takže by som rád požiadal o nejaký link na stiahnutie toho free xorg driver.
      Peter Barlik: príkaz aticonfig --intial mi nejako nefunguje, po reštarte sa mi x javí ako keby normálne fungoval: systém sa normálne naštartuje, zobrazia sa už spomínané štvorce, potom len tak do ničoho zadám meno a heslo, preblikne čierna obrazovka, potom opäť tie štvorce. Čo sa týka tých open source driverov, bez problémov vyskúšam aj tie, len by som potreboval nejaký konkrétnejší link.

      Neskôr som vyskúšal preinštalovať drivre. Po inštalácii mi vypísalo, že oobsahovala nejaké chyby, a že pre podrobnejšie informácie si mám zobraziť nejaký log. Súbor:
      [Message]: Trying to install precompiled kernel module
      [Message]: Precompiled kernel module mismatched
      No kernel module build enviroment.

      O Linuxe neviem takmer nič, ale myslím že problém by mal byť zrejmí práve kvôli tomuto logu. Ďakujem.
      • Re: Problémy s ATI drivermi 07.06.2009 | 16:13
        Avatar Peter Barlik Gentoo  Používateľ
        ok tak pomaly co presne ti vypise aticonfig --initial ?? resp ako vies ze nefunguje?
        dufam ze sa vies dostat co konzoly (napr ctrl+alt+F1 alebo ine F napr F3 F4 .... nie vsak vyssie ako 6)
        do konzoly napis cat /var/log/Xorg.0.log | grep WW a hod sem vypis

        cosi podobne cat /var/log/Xorg.0.log | grep EE a tiez hod vypis

        a este by to mozno chcelo vidiet aky mas /etc/X11/xorg.conf otvor to napr pomocou nano /etc/X11/xorg.conf

        co sa tyka tych open driverov tak predpokladam ze ich debian pri instalacii uz nainstaloval ale ak nie tak sudo apt-get install xserver-xorg-video-ati a potom sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri by ich malo preinstalovat vsetko co sa tyka driverov grafickej karty

    • Re: Problémy s ATI drivermi 09.06.2009 | 19:31
      Miroslav Chodil   Návštevník
      Grafické prostredie v Debiane mi už teraz funguje, petože som nainštaloval iný driver. Výpis z uvedených súborov však nemôžem poskytnúť, pretože sa mi do cesty postavil iný problém. Pred niekoľkými dňami som bol nútený nainštalovať Windows (na hardisk svojho brata, pretože jemu to nejako nešlo), ktorý samozrejme po inštalácii zrušil grub. To by ani tak nebol problém, keby mi pri oprave grubu nevyhodilo, že nenašiel partíciu. Po dlhšom skúmaní som zistil, že Ubuntu neropoznáva formát jedného z mojich hardiskov, ktorý však sformátovať nemôžem, pretože sa na ňom nachádza Debian a všetky moje dáta. Preto som teraz odkázaný na Windows Xp, na ktorý však dokáže tento hardisk rozpoznať. Ďakujem.
      • Re: Problémy s ATI drivermi 10.06.2009 | 12:23
        Avatar Peter Barlik Gentoo  Používateľ
        ako si opravoval grub? ako vies aku particiu si mal davat grubu ako default? ubuntu je postavene na debiane tak by nemal byt problem s kompatibilitou FS a navyse ubuntu spusta snad vsetko co sa len da cize neverim zeby nejaky fs nespustilo
        • Re: Problémy s ATI drivermi 10.06.2009 | 22:44
          Miroslav Chodil   Návštevník
          Postupoval som podľa návodu nájdeného vo vyhľadávači Google, konkrétne sa jedná o návod na http://wiki.ubuntu.cz/GRUB/Obnova?action=show&redirect=Obnova+boot+mana%C5%BEeru+Grub+po+reinstalaci+Windows. Pri pokuse o opätovnú inštaláciu Grubu mi však Ubuntu vyhlási, že danú partíciu nenašiel. Preto som sa pozrel do Partition Editoru, kde bolo môj disk aj s danou partíciou označený ako nealokovaný. Formátovanie pre mňa nieje riešením, keďže mám na ňom svoje dáta, aj so všetkými nainštalovanými systémami. Disk je samozejme v poriadku, keďže na ňom mám nainštalovaný Windows Xp, z ktorého práve píšem.