Veľký problém s particiou

Sekcia: Konfigurácia 28.11.2009 | 19:59
Oklep   Návštevník
Môj HDD mám rozdelený na 5 particií... Na jednej je windows s ntfs, na jednej linux s ext3, a dalšie tri klasické súborové, tiež ext3.

Vo windowse som mal nainštalovany Ext2Fsd, aby sa ext3 disky tvarily ako klasicke ntfs. Takto som to použival bezproblemov cca tri roky...

Dnes som však reštartoval windows a nechcel mi nabehnúť... Úvodné boot logo a nasledne reštart, a tak stale dokola. Povedal som si že zase "chcípol" tak som sa rebootol do linuxu...
Avšak môj usmev klesol po tom, čo všetky oddiely sa dali bezproblemov mountnuť, až na jeden. Jedná sa o súborovú particiu, kde mám dôležite subory o ktore nechcem prísť.

Totok píše dolphin (kde4) pri pokuse o mount particie
http://i49.tinypic.com/ictm49.jpg

čo sa mohlo stať? ako to opraviť?
    • Re: Veľký problém s particiou 28.11.2009 | 20:03
      Oklep   Návštevník
      ****@rapid:~$ dmesg | tail
      [ 745.461631] EXT3-fs error (device sda7): ext3_check_descriptors: Block bitmap for group 0 not in group (block 1750281819)!
      [ 745.461948] EXT3-fs: group descriptors corrupted!
      [ 761.500744] EXT3-fs error (device sda7): ext3_check_descriptors: Block bitmap for group 0 not in group (block 1750281819)!
      [ 761.501311] EXT3-fs: group descriptors corrupted!
      [ 761.980440] EXT3-fs error (device sda7): ext3_check_descriptors: Block bitmap for group 0 not in group (block 1750281819)!
      [ 761.980734] EXT3-fs: group descriptors corrupted!
      [ 762.383926] EXT3-fs error (device sda7): ext3_check_descriptors: Block bitmap for group 0 not in group (block 1750281819)!
      [ 762.384298] EXT3-fs: group descriptors corrupted!
      [ 762.783759] EXT3-fs error (device sda7): ext3_check_descriptors: Block bitmap for group 0 not in group (block 1750281819)!
      [ 762.784053] EXT3-fs: group descriptors corrupted!
      • Re: Veľký problém s particiou 28.11.2009 | 20:13
        Avatar borg Arch, Debian jessie  Administrátor
        skus na tu particiu spustit fsck.ext3
        • Re: Veľký problém s particiou 28.11.2009 | 20:24
          Oklep   Návštevník
          totok su rpemna nove veci, takže sa preistotu spytam rpedtym než dačo zbabrem... :)

          takto?
          fsck.ext3 -a /dev/sda7
          • Re: Veľký problém s particiou 29.11.2009 | 16:15
            Avatar Viliam Oravec Kubuntu 10.04 (MSI GX700PX)  Používateľ
            ano je to tak. nezabudaj na sudo.
            Všichni mněli ruce od krve, jenom já hubu... :)
            • Re: Veľký problém s particiou 29.11.2009 | 18:38
              WlaSaTy   Návštevník
              Toto by so si ja osobne dovolil az na kopii daneho disku.

    • Re: Veľký problém s particiou 29.11.2009 | 16:10
      Dragon   Návštevník
      Jedna moja skusenost, ktoru neviem dost dobre zdovodnit, ale myslim, ze suvisi s temou, takze sa podelim:
      Jedna sa o particie s FS NTFS. Cez graficke "klikatko" nesli pripojit a ked som to skusil cez konzolu nesli tiez. Ale ked som pri pripajani zadal aj typ FS, pripojili sa uplne krasne.
      Vie niekto, preco to reagovalo takto? Nemoze to mat nejaky suvis s tymto problemom?
      • Re: Veľký problém s particiou 29.11.2009 | 16:17
        Avatar Viliam Oravec Kubuntu 10.04 (MSI GX700PX)  Používateľ
        ee. pravdepodobne nie. pokial ma pamat neklame tak tiez som musel na starsom Mandrake 10.1 specifikovat filesystem na zariadeni ktore som pripajal. teraz to uz mam cez automount.
        Všichni mněli ruce od krve, jenom já hubu... :)