problém s rozpoznaním flash mp3 prehrávača MERCURY

Sekcia: Ostatné 20.02.2005 | 16:17
Avatar Joyo15 MDK 10  Používateľ
Ak pripojím hociaký iný flash disk cez usb, tak sa mi "mountne" do priečinku "/mnt". Ak pripojím flash mp3 prehrávač MERCURY KOB MP330 nepripjí sa tam. "Usb Viewer" ho spozná (napíše ho červenou farbou). Kontrolné centrum ho zobrazuje na dvoch pozíciách. Zobrazí ho medzi skenermi (?) na porte "libusb:001:002". Zobrazí ho aj medzi "neznámymi" - "Modul: neznámy". Vie mi niekdo pomôcť rozbehať to? moja konfigurácia MDK 10 KDE 3.2 za radu vopred ďakujem
    • Re: problém s rozpoznaním flash mp3 prehrávača MER 31.01.2005 | 23:39
      Avatar lukipuki Gentoo  Používateľ
      Podľa mňa je na disku nejaká partícia s internou pamäťou prehrávača. Skús príkaz "fdisk /dev/sda" a v ňom je tuším m pre pomoc a p pre výpis partícii. A možno to naklikáš v control centre, matne si spomínam na nejakého disk druida, či čo. Prípadne skús "dmesg", ale v ňom si všimni len koniec výpisu.
      • Re: Re: problém s rozpoznaním flash mp3 prehrávača 01.02.2005 | 22:56
        Avatar Joyo15 MDK 10  Používateľ
        pri zadaní fdisk /dev/sda napíše: [root@localhost dodik]# fdisk /dev/sda Unable to open /dev/sda [root@localhost dodik]# vo výpise DMESG je spomenuté "full speed USB", pýtal som sa v obchode, kde som kúpil ten prehrávač a povedali, že tu rýchlosť treba znížiť, neviem ako:-) ospravedlňujem sa že tu pchám taký kus výpisu, po zadaní "dmesg": . . . Uniform CD-ROM driver Revision: 3.20 ide-floppy driver 0.99.newide drivers/usb/core/usb.c: registered new driver hiddev drivers/usb/core/usb.c: registered new driver hid drivers/usb/input/hid-core.c: v2.0:USB HID core driver NET: Registered protocol family 17 PCI: Setting latency timer of device 0000:00:06.0 to 64 intel8x0_measure_ac97_clock: measured 49515 usecs intel8x0: clocking to 47377 parport0: PC-style at 0x378 [PCSPP,TRISTATE] parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) lp0: using parport0 (polling). lp0: console ready nvidia: no version for "struct_module" found: kernel tainted. nvidia: module license 'NVIDIA' taints kernel. NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-6106 Wed Jun 23 08:14:01 PDT 2004 Linux agpgart interface v0.100 (c) Dave Jones atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0). atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly. atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0). atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly. Installing knfsd (copyright (C) 1996 okir@monad.swb.de). bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 0 changed to on bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 1 changed to on bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 2 changed to on bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 3 changed to on bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 4 changed to on bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 5 changed to on SCSI subsystem initialized st: Version 20040122, fixed bufsize 32768, s/g segs 256 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 usb 1-2: new full speed USB device using address 2 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 usb 1-2: USB disconnect, address 2 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 NET: Registered protocol family 10 Disabled Privacy Extensions on device c035fe60(lo) IPv6 over IPv4 tunneling driver parport0: PC-style at 0x378 [PCSPP,TRISTATE] parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) lp0: using parport0 (polling). lp0: console ready parport0: PC-style at 0x378 [PCSPP,TRISTATE] parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) lp0: using parport0 (polling). lp0: console ready usb 1-2: new full speed USB device using address 3 drivers/usb/core/config.c: config descriptor too short (expected 512, got 39) usb 1-2: can't read configurations, error -22 usb 1-2: new full speed USB device using address 4 Initializing USB Mass Storage driver... scsi0 : SCSI emulation for USB Mass Storage devices Vendor: Model: DeluxClassicCAM Rev: 1.00 Type: Direct-Access ANSI SCSI revision: 02 SCSI device sda: 245760 512-byte hdwr sectors (126 MB) sda: assuming Write Enabled sda: assuming drive cache: write through /dev/scsi/host0/bus0/target0/lun0: p1 Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0 Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0 WARNING: USB Mass Storage data integrity not assured USB Mass Storage device found at 4 drivers/usb/core/usb.c: registered new driver usb-storage USB Mass Storage support registered. end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 VFS: Can't find ext2 filesystem on dev sda1. end_request: I/O error, dev fd0, sector 0 usb 1-2: USB disconnect, address 4 scsi0 (0:0): rejecting I/O to dead device SCSI error: host 0 id 0 lun 0 return code = 4000000 Sense class 0, sense error 0, extended sense 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 usb 1-2: new full speed USB device using address 5 niform CD-ROM driver Revision: 3.20 ide-floppy driver 0.99.newide drivers/usb/core/usb.c: registered new driver hiddev drivers/usb/core/usb.c: registered new driver hid drivers/usb/input/hid-core.c: v2.0:USB HID core driver NET: Registered protocol family 17 PCI: Setting latency timer of device 0000:00:06.0 to 64 intel8x0_measure_ac97_clock: measured 49515 usecs intel8x0: clocking to 47377 parport0: PC-style at 0x378 [PCSPP,TRISTATE] parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) lp0: using parport0 (polling). lp0: console ready nvidia: no version for "struct_module" found: kernel tainted. nvidia: module license 'NVIDIA' taints kernel. NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-6106 Wed Jun 23 08:14:01 PDT 2004 Linux agpgart interface v0.100 (c) Dave Jones atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0). atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly. atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0). atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly. Installing knfsd (copyright (C) 1996 okir@monad.swb.de). bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 0 changed to on bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 1 changed to on bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 2 changed to on bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 3 changed to on bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 4 changed to on bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3). bootsplash: status on console 5 changed to on SCSI subsystem initialized st: Version 20040122, fixed bufsize 32768, s/g segs 256 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 usb 1-2: new full speed USB device using address 2 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 usb 1-2: USB disconnect, address 2 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 NET: Registered protocol family 10 Disabled Privacy Extensions on device c035fe60(lo) IPv6 over IPv4 tunneling driver parport0: PC-style at 0x378 [PCSPP,TRISTATE] parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) lp0: using parport0 (polling). lp0: console ready parport0: PC-style at 0x378 [PCSPP,TRISTATE] parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) parport0: cpp_daisy: aa5500ff(38) parport0: assign_addrs: aa5500ff(38) lp0: using parport0 (polling). lp0: console ready usb 1-2: new full speed USB device using address 3 drivers/usb/core/config.c: config descriptor too short (expected 512, got 39) usb 1-2: can't read configurations, error -22 usb 1-2: new full speed USB device using address 4 Initializing USB Mass Storage driver... scsi0 : SCSI emulation for USB Mass Storage devices Vendor: Model: DeluxClassicCAM Rev: 1.00 Type: Direct-Access ANSI SCSI revision: 02 SCSI device sda: 245760 512-byte hdwr sectors (126 MB) sda: assuming Write Enabled sda: assuming drive cache: write through /dev/scsi/host0/bus0/target0/lun0: p1 Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0 Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0 WARNING: USB Mass Storage data integrity not assured USB Mass Storage device found at 4 drivers/usb/core/usb.c: registered new driver usb-storage USB Mass Storage support registered. end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 VFS: Can't find ext2 filesystem on dev sda1. end_request: I/O error, dev fd0, sector 0 usb 1-2: USB disconnect, address 4 scsi0 (0:0): rejecting I/O to dead device SCSI error: host 0 id 0 lun 0 return code = 4000000 Sense class 0, sense error 0, extended sense 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 end_request: I/O error, dev fd0, sector 0 usb 1-2: new full speed USB device using address 5
        • Re: Re: Re: problém s rozpoznaním flash mp3 prehrá 01.02.2005 | 23:38
          Avatar lukipuki Gentoo  Používateľ
          Skopíroval si to sem dvakrát, ale nevadí. V tom výpise vidno problémy pri komunikácii s USB a SCSI (v Linuxe prebieha komunikácia s USB diskami cez SCSI emuláciu). Tie chyby I/O pre fd0 asi nepatria USB, lebo fd0 by mala byť disketová mechanika. Podľa mňa to bude nejakým neštandardným formátom disku, keďže si písal, že iné disky ti idú dobre. Tu je ešte môj dmesg pre fotoaparát Olympus a kernel 2.6.10, môžeš porovnať: usb 2-3: new full speed USB device using ohci_hcd and address 3 Initializing USB Mass Storage driver... scsi0 : SCSI emulation for USB Mass Storage devices usbcore: registered new driver usb-storage USB Mass Storage support registered. usb-storage: device found at 3 usb-storage: waiting for device to settle before scanning Vendor: OLYMPUS Model: u20D,S400D,u400D Rev: 1003 Type: Direct-Access ANSI SCSI revision: 02 usb-storage: device scan complete SCSI device sda: 256000 512-byte hdwr sectors (131 MB) sda: assuming Write Enabled sda: assuming drive cache: write through SCSI device sda: 256000 512-byte hdwr sectors (131 MB) sda: assuming Write Enabled sda: assuming drive cache: write through sda: sda1 Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
          • Re: Re: Re: Re: problém s rozpoznaním flash mp3 pr 02.02.2005 | 01:49
            Avatar omicro freebsd, debian  Používateľ
            Ja vidim problem v tom, ze sa system snazi najst na flashke ext2 filesystem. Skusii by som ho pripojit takto: mount -t vfat /dev/sda1 /mnt
            • Re: Re: Re: Re: Re: problém s rozpoznaním flash mp 02.02.2005 | 21:39
              Avatar Joyo15 MDK 10  Používateľ
              asi nie je na "sda1", ako sa da zistit kde je? [root@localhost dodik]# mount -t vfat /dev/sda1 /mnt/mp3player mount: special device /dev/sda1 does not exist [root@localhost dodik]# Mutex destroy failure: Device or resource busy ICE default IO error handler doing an exit(), pid = 3196, errno = 0 (priecinok mp3player mam) dakujem za ochotu
            • Re: Re: Re: Re: Re: problém s rozpoznaním flash mp 02.02.2005 | 22:22
              Avatar lukipuki Gentoo  Používateľ
              Veď systém mu píše, že zariadenie neexistuje, takže chyba nie je v súborovom systéme.
              • Re: Re: Re: Re: Re: Re: problém s rozpoznaním flas 03.02.2005 | 20:51
                Joyo15   Návštevník
                Skúšal som to aj vo Windovse a tam to tiež nefunguje
          • Re: Re: Re: Re: problém s rozpoznaním flash mp3 pr 02.02.2005 | 21:16
            Avatar Joyo15 MDK 10  Používateľ
            ja tam mam fat 16
    • Re: problém s rozpoznaním flash mp3 prehrávača MER 20.02.2005 | 16:17
      X-man   Návštevník
      skus: mount /dev/sdX /mnt/hocico