nastavenie swap particie

Sekcia: Konfigurácia 05.07.2010 | 14:20
xxxx   Návštevník
dobry, potreboval som si prehodit swap z hda4 na hda5 - vytvoril som swap na hda5, zmenil zaznam vo fstab - po restarte mi v pohode system detekuje swap na hda5, ale
- kinit slale hlada resume image na hda4
- samotna hibernacia mi pada na hlaske, ze nie je pripojeny swap (hlada swap na hda4)
na hibernaciu pouzivam pm-utils

kde este treba okrem fstab zmenit prislusne nastavenia, aby mi hibernacia a dehibernacia detekovala aktualne vytvoreny swap? mam 64bit debain lenny. vdaka...
    • Re: nastavenie swap particie 05.07.2010 | 14:24
      Avatar borg Arch, Debian jessie  Administrátor
      musis upravit konfiguracny subor svojho bootloaderu (lilo, grub). musis pridat/zmenit argument pre jadro, ktory sa vola resume (nastavit spravnu cestu k novej swap particii)
      • Re: nastavenie swap particie 05.07.2010 | 14:36
        xxxx   Návštevník
        na toto som tiez myslel, ale pri update jadra sa mi menu.lst prepisuje, navyse standardne nemam parameter resume zadefinovany... to nastavenie musi byt este aj niekde inde...
        • Re: nastavenie swap particie 05.07.2010 | 14:42
          WlaSaTy   Návštevník
          Pri pouziti Grub2 je v jeho konfiguraku (niekde v /boot/grub/*cfg) upozornenie aby si ho nemenil, ale aby si to menil niekde v /etc/default/grub ci ako.

          Nebude to tento pripad?
          • Re: nastavenie swap particie 05.07.2010 | 14:46
            xxxx   Návštevník
            nie, nemam grub2, ale grub - ale skusim mu predsa len nastavit parameter resume, aj ked len docasne, ci "sa to niekde neprepise" na jeho zaklade...
            • Re: nastavenie swap particie 05.07.2010 | 15:01
              WlaSaTy   Návštevník
              Jaaj, no. Debian asi este nepouziva grub2. V Gentoo je tiez len na vlastne riziko :)

              Inak, odporucil by som zistit v ktorom konfiguracnom subore je ulozena ta povodna hodnota pre hibernacnu particiu:

              grep -R -i -e resume /etc

              Teda, ak si dobre spominam na syntax.
              • Re: nastavenie swap particie 05.07.2010 | 15:19
                Avatar Jaroslav Petráš Debian sid/experimental@amd64  Používateľ
                Pri instalacii distribucie Debian, konkretne testing verzie (myslim ze asi aj v stable) sa instalator opyta ci radsej nenainstalovat Grub2 namiesto Grub-legacy. Povodny Grub (0.97) sa uz snazia pomaly vytlacit.

                Ja pouzivam Grub2 k spokojnosti. Aj ked mal som aj krusne chvile. Momentalne najlepsie fungujuca verzia je v unstable repozitaroch.
                301 Keyboard Error <br/> Press any key to resume or F1 for setup...<br/> cyberasylum.eu
              • Re: nastavenie swap particie 05.07.2010 | 18:36
                xxxx   Návštevník
                diky - toto bude ono
                /etc/initramfs-tools/conf.d/resume:RESUME=/dev/hda4