Nvidia problem s ovladacom a modulom

Sekcia: Hardware a Drivery 15.07.2011 | 10:05
Marko   Návštevník
Dobry den, mam NV 9500GT a ubuntu 11.04. Vcera som si nainstaloval aktualne jadro a taktiez najnovsi ovladac GK zo stranky nvidie. Po instalacii a restarte pocitaca Xserver nenabehol a pri pokuse o jeho spustenie som dostal priblizne takuto hlasku: Chyba API, kernel modul je verzie 270.45.XX a vas ovladac je verzie 270.09.07. Po dlhych peripetiach sa mi podarilo korektne spustit xserver, no po restarte som dostal tuto hlasku opat. Ovladac, ktory som instaloval je verzie 275.09.07. Ako to dam do poriadku? Dakujem za rady.

PS: Je ta zevraj nejaky BUG
    • Re: Nvidia problem s ovladacom a modulom 15.07.2011 | 10:20
      Avatar Róbert Dúbravský Kubuntu 64bit  Používateľ
      Ahoj,
      Najnovší stabilný drajver je 275.09.07, a to blbé ubuntu ešte asi stále nevie aký drajver ma kde použiť.
      Ja už ubuntu vyše roka nemám, ale mal by si zabezpečiť aby si mal rovnaké drajvre na tu verziu jadra ktorú spúšťaš. Vždy po každom upgrade jadra a drajvra (nvidia) som ručne v synapticu mazal staré jadro aby po prvom štarte sa mi vytvoril (natiahol, nalinkoval) aktuálny drajver na práve spúštané jadro. Ak som zabudol spraviť túto vec, naštartoval som do starého jadra a urobil to.

      Mne sa zase na Sabayone a funkčnom konfigu ktorý používam viac než rok po inštalácii poslednej verzie 275.09.07 tiež nenabehlo X-ko. Mal som kopec hlášok typu no load acpi, dri a pod. Nakoniec mi stačilo vygenerovať nový konfig príkazom nvidia-xconfig. Na PC kde mám ten istý viac menej ten istý softvér mi nvidia-xconfig neporadilo (vygenerovalo konfig, ale nefungoval). Skopíroval som si konfig z notebooku a ten šlape.
      Tvorba internetových stránok - webdizajn, Joomla www.treborplus.net
      • Re: Nvidia problem s ovladacom a modulom 15.07.2011 | 10:27
        Marko   Návštevník
        Skusil som to blbe ubuntu spustit so starym jadrom, ale stalo sa uz to iste. Cez nvidia-installer som cez prikaz --uninstall odinstaloval driver a vyhodil som z jadra aj modul nvidia. Nainstaloval som driver opat, zaviedol som modul a nic. Novy xconf som generoval pri instalacii ovladaca a stale nic. Skusim este asi nvidia-xconfig
        • Re: Nvidia problem s ovladacom a modulom 15.07.2011 | 10:46
          Avatar default Debian  Používateľ
          preco vlastne instalujes drivere takouto metodou ked v ubuntu je na to utilita ktora to zvladne? ja mam Nvidia Geforce 9800 GT a nainstaloval som doporuceny driver a nemam problem,a nemusim nic textovo riesit ani po upgrade jadra
          R.K
          • Re: Nvidia problem s ovladacom a modulom 15.07.2011 | 10:50
            Marko   Návštevník
            No stale som to tak robil a bolo vsetko OK, teraz to ale potrebujem dat spat do pouzitelneho stavu
            • Re: Nvidia problem s ovladacom a modulom 15.07.2011 | 10:55
              Avatar default Debian  Používateľ
              lenze nie v kazdom systeme je dobre instalovat ovladace rovnako, dakde mas vlastne repozitare , napriklad fedora, gentoo, ubuntu, archlinux , .... , uz tam budes mat strasny bordel, ak ten system nemas zariadeny tak navrhujem, format a cisty install
              R.K
              • Re: Nvidia problem s ovladacom a modulom 15.07.2011 | 11:25
                Marko   Návštevník
                Toto robit nemozem, zozeniem ovladac rtakej verzie, ktoru potrebujem pre jadro a vsetko nainstalujem od zaciatku. To nieje mozne, aby taka prkotina dodrbala system tak, aby nebol pouzitelny.
                • Re: Nvidia problem s ovladacom a modulom 15.07.2011 | 11:36
                  Avatar default Debian  Používateľ
                  ok tak to skus, ja ti len hovorim , ze ubuntu ma aj vlastny ovladac v ponuke okrem toho nvidiackeho -> doporuceneho pre to ubuntu, a ze by bolo lepsie pouzit ten ich, este je taka moznost ze znova zaktivujues nouveau ovladac v xorg.confu pojdes do classic modu a odtial doinstalujes tie doporucene drivere
                  R.K
                  • Re: Nvidia problem s ovladacom a modulom 15.07.2011 | 12:09
                    Marko   Návštevník
                    Asi to tak spravim, pokusim sa system opat spustit a supnem tam tie odporucane ovladace