Debian, chyba inštalácie GRUB pri vytvorení RAID 1 a 5

Sekcia: Konfigurácia 24.08.2012 | 18:42
emissary   Návštevník
Dobrý deň prajem,

snažím sa nainštalovať Debian na môj "server" no mám veľké problémy s inštaláciou zavádzača FRUB. Mám 3x 2TB HDD. Rozdelenie všetkých troch diskov som spravil nasledovne:
sda - sdb - sdc

č. 1 200 MB
č. 2 2 GB
č. 3. 15GB
č. 4. 10GB
č. 5 4GB
č. 6. 2TB (skoro...je to zbytok čo zostal)

Následne som vytvoril v nastavení RIDE takéto oddiely:

RAID 1 zariadenie č. 0 200 MB Linux Software Raid Array
č.1 200 MB ext4 /boot

RAID 1 zariadenie č. 1 4 GB Linux Software Raid Array
č.1 4GB swap

RAID 1 zariadenie č. 2 30GB Linux Software Raid Array
č.1 30 GB ext4 /

RAID 1 zariadenie č. 3 20GB Linux Software Raid Array
č.1 20 GB ext4 /home

RAID 1 zariadenie č. 4 10GB Linux Software Raid Array
č.1 10 GB ext4 /var

RAID 1 zariadenie č. 5 3,9TB Linux Software Raid Array
č.1 3,9 TB ext4 /data


Inštalátor sa spýta "Nainštalovať GRUB na hlavný štartovací záznam (MBR)? ja dám "ano"

Zlyhalo vykonanie grub-install "/dev/sda".


Viete mi niekto poradiť, kde robím chybu?

Inštaláciu som robil podľa návodu, ktorý som našiel na youtube. Jedna jediná vec, ktorá nie je identická je, že sa ma vôbec nepýta, či má byť disk primárny alebo logický.

http://www.youtube.com/watch?v=0QynsHQU1Ec&feature=g-hist

Zo začiatku som to robil bez bez RAID1.... bez toho oddielu "/boot" Kamarát mi potom povedal, že GRUB nemôže byť inštalovaný na RAID 5....jedine na RAID 1 alebo 0....tak som vytvoril tento oddiel... ale stále rovnaká chyba.