nvidia - 20minút kým sa zapne displej

Sekcia: Hardware a Drivery 26.01.2015 | 20:18
Avatar Zer0 Blbuntu 16.04 gnome-session-flashback | Debian 8  Používateľ

Používam nvidia-prime(driver 346.35, ale skúšal som aj iné a asi to nie je tým)

Keď fungujem pod intel hd, tak nič, systém nabootuje spustí sa plocha(gnome, unity, atď) a môžem robiť, čo chcem.

Problém nastane až po prepnutí na nvidiu, všetko sa spustí, ale displej je vypnutý, ale pri tom pc reaguje - po pamäti si kludne otvorím terminál, niečo naťukám napr. reboot a rebootne. No ak počkám, tak asi za 20 minút nabehne aj obraz :D.

Čiže ak chcem niečo robiť pod nvidiou, tak môžem okrem reštartu čakať ešte 20 minút na zapnutie displeja. Niekedy sa stávalo, že bol po update len prepnutý na iný výstup(u mňa Fn+F8), ale tentokrát nie.

Neviem, čo by som mohol ešte uviesť.

Skúšal som meniť driver a reinštaloval xserver -> možno odveci, neviem, raďte.

    • RE: nvidia - 20minút kým sa zapne displej 26.01.2015 | 22:00
      Avatar samaklobasa   Návštevník

      display je vypnuty uplne, alebo cierny, alebo v standby rezime? vypne ti ho hned pri bootovani, alebo kedy? co je v logoch?

      skus spustit xrandr ked je monitor vypnuty a potom zapnuty a uloz niekde vystup...

      • RE: nvidia - 20minút kým sa zapne displej 26.01.2015 | 23:37
        Avatar Zer0 Blbuntu 16.04 gnome-session-flashback | Debian 8  Používateľ

        syslog > http://pastebin.com/N54nfTCX

        xorg.0.log > http://pastebin.com/ezUnSKaK

        xrandr terminál - stále rovnaké > http://pastebin.com/6B9s6egY

        Neviem, či je to jasné - jedná sa o notebook.

        Display úplne zhasne po zmiznutí ubuntu boot screen. Môžem sa prepnúť na tty cez ctrl+alt+F1, ale startx má rovnaký výsledok(vypnutý display).

        Ešte nikdy som nepostoval logy, hádam je to dobre.

      • RE: nvidia - 20minút kým sa zapne displej 27.01.2015 | 00:30
        Avatar Zer0 Blbuntu 16.04 gnome-session-flashback | Debian 8  Používateľ

        Ešte skúsim, či mi nepôjde bumblebee. No prime bolo omnoho jednoduchšie a s bumblebee som mal vždy nejaký problém.

        • RE: nvidia - 20minút kým sa zapne displej 27.01.2015 | 01:21
          Avatar samaklobasa   Návštevník

          akurat ze nepouzivas prime technologiu (nouveau), ale Optimus (proprietarne ovladace nvidia). ako prepinas vystup?

          posli este logy, ked ti po tych 20-tich minutach nabehne monitor, ci tam nieco nepribudlo...

          • RE: nvidia - 20minút kým sa zapne displej 03.02.2015 | 20:20
            Avatar Zer0 Blbuntu 16.04 gnome-session-flashback | Debian 8  Používateľ

            Aby to neostalo neuzavreté. Čierna obrazovka začala aj po reinštale ostávať až po update xserver-niečo-niečo-nouveau, intel atď.(asi 6 vecí sa naraz updatlo)

            Xorg log vypisoval, že nevie nájsť monitor. Keď som monitor pridal priamo do xorg.conf, tak sa xorg.conf prepísal na deafultné hodnoty.

            No nič, iba som cez prime-select intel, prepol s5 na intel, skúsil nainštalovať bumblebee a čuduj sa svete, bumblebee šlape ako švajčiarske auto... všetko OK.