? namiesto diakritiky v nazvoch suborov... //Slack

Sekcia: Konfigurácia 27.02.2006 | 20:40
Avatar Jaroslav Petráš Debian sid/experimental@amd64  Používateľ
Moj problem: Ked pisem diakritikou nazvy suborov tak mi to ulozi ako ? namiesto napr. : č š ž ť.. Konqueror potom vyhodi hore v paneli /bla/%3Flanok.. Kde je chyba??? Co mam spravit aby ma pochopil?? Chyba sa vyskytuje pri zapise na ext3 fs... To ze mi necita spravne nazvy na fat a ntfs ma az tak netrapi...
301 Keyboard Error <br/> Press any key to resume or F1 for setup...<br/> cyberasylum.eu
    • Re: ? namiesto diakritiky v nazvoch suborov... //S 17.02.2006 | 13:38
      azurIt   Návštevník
      problem je vo fontoch. tie subory su take, ako si ich nazval, len sa ti tie nazvy zle zobrazia. ono vseobecne nie je velmi dobry napad davat do nazvov suborov/adresarov diakritiku. sposobuje to viac problemov ako uzitku.
      • Re: Re: ? namiesto diakritiky v nazvoch suborov... 17.02.2006 | 13:54
        Avatar Jaroslav Petráš Debian sid/experimental@amd64  Používateľ
        Ja viem ze sa to neoplati ale co uz s niektoryi ludmi... A krem toho som Slovak... Inak pochybejm ze su tak zapisane.. Bo mam fonty napr... Arial... ktore spravne zobrazenie podporuju...
        301 Keyboard Error <br/> Press any key to resume or F1 for setup...<br/> cyberasylum.eu
        • Re: Re: Re: ? namiesto diakritiky v nazvoch suboro 17.02.2006 | 15:58
          WlaSaTy   Návštevník
          font sluzi na zobrazovanie pisma pod urcitou znakovou sadou, ci uz 8 bit alebo unicode. to ze mas font schopny zobrazovat stredoeuropske neznamena ze to mas korektne zapisane. skus sem dat vystup prikazu: env | grep LC a zaznam z /etc/fstab na dany disk. potom ti skor niekto poradi.
          • Re: Re: Re: Re: ? namiesto diakritiky v nazvoch su 20.02.2006 | 10:49
            Jaroslav Petráš   Návštevník
            Oki... Diky za vysvetlenine.... Prosim Ta mohol by si mi objasnit to nastavenie??? (Ako to nastavim korektne, ako si spominal...)
            • Re: Re: Re: Re: Re: ? namiesto diakritiky v nazvoc 21.02.2006 | 20:06
              WlaSaTy   Návštevník
              zrejme mas nastavene nejake kuriozne locale (regionalne nastavenie). skus sem dat vypis tych prikazov.
              • Re: Re: Re: Re: Re: Re: ? namiesto diakritiky v na 22.02.2006 | 13:29
                Jaroslav Petráš   Návštevník
                Hmmm.... No jasan... Ale mne by viac pomohlo keby si mi sem dal ako to locale nastavim... Abo pozriem doma man a dam vediet co a ako...
                • Re: Re: Re: Re: Re: Re: Re: ? namiesto diakritiky 25.02.2006 | 21:32
                  Jaroslav Petráš   Návštevník
                  No... locale som nastavil a uz vsetko ide... Avsak ste mi to mohli poradit skorej... Som sa musel doma trapit kym som to nasiel... :-( Tak teda dakujem aspon za indiciu... :-)
                  • Re: Re: Re: Re: Re: Re: Re: Re: ? namiesto diakrit 25.02.2006 | 22:22
                    WlaSaTy   Návštevník
                    :Avsak ste mi to mohli poradit skorej... :Som sa musel doma trapit kym som to nasiel... :-( prajete si plateny helpdesk? my vy sme radi poradili aj skor, keby ste nam nezatajovali chybu a nastavenie. no, ale hlavne ze je to vyriesene.
                    • Re: Re: Re: Re: Re: Re: Re: Re: Re: ? namiesto dia 27.02.2006 | 14:51
                      Jaroslav Petráš   Návštevník
                      Chybu som nezatajil... Z problemu bolo uz dalej zrejme ze sa jedna o locale... Stacila veta: Skus pozriet do /etc/profile.d/lang.sh ... Totiz env | grep LC vypisal> LC_COLLAGE=C Co mam nastavene aj teraz tak isto... Ale ako hovorim> Dakujem za indiciu!! Som vdacny a nechajme to tak...
                      • Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: ? namiesto 27.02.2006 | 20:40
                        WlaSaTy   Návštevník
                        niet za co. ale uz sa tesim ze sa ozve niekto s takymto istym problemom za dva tyzdne a riesenie tu nenajde. tento portal nie je na zadavanie otazok ale na hladanie odpovedi. na zadavanie otazok je plateny helpdesk.
    • Re: ? namiesto diakritiky v nazvoch suborov... //S 22.02.2006 | 14:24
      marek   Návštevník
      ked v linuxe vytvorim subor s diakritikou vsetko je ok ale pod vmware s windows xp subor sa vobec nezobrazi. Naopak , ak vytvorim subor vo vmware+windowsxp s diakritikou , samozrejme ze subor v Linuxe vidim ale nazov ma posahanu diakritiku. bez diakr. to funguje ok. potrebujem pristup s oboch systemov do jedneho adresara ako to riesit?
      • Re: Re: ? namiesto diakritiky v nazvoch suborov... 22.02.2006 | 18:25
        WlaSaTy   Návštevník
        ak tomu dobre rozumiem, tak mas 4 instalacie operacneho systemu (windows/linux, normalne/wmware). je to tak?
        • Re: Re: Re: ? namiesto diakritiky v nazvoch suboro 23.02.2006 | 16:51
          marek   Návštevník
          instalovany je linux a na nom bezi vmware a vo vmware windows .