gcc

Sekcia: Konfigurácia 14.03.2006 | 00:46
Wan_L   Návštevník
Mam problem s gcc...nainstaloval som si gcc-.src.rpm potom som xcel v adresary /opt/nmap-3.9999 skompilovat nmap lebo bol rozbaleny... tu je to z linuxu vsetko [root@Wan opt]# rpm -Uvh gcc-4.0.1-5mdk.src.rpm 1:gcc ########################################### [100%] [root@Wan opt]# cd /opt/nmap-3.9999 [root@Wan nmap-3.9999]# ./configure checking for gcc... no checking for cc... no checking for cc... no checking for cl... no configure: error: no acceptable C compiler found in $PATH See `config.log' for more details. [root@Wan nmap-3.9999]# gcc bash: gcc: command not found [root@Wan nmap-3.9999]# whereis gcc gcc: [root@Wan nmap-3.9999]# [root@Wan nmap-3.9999]# verim ze mi pomozete dakujem
    • Re: gcc 13.03.2006 | 23:37
      Avatar Ondrej Hučko Kubuntu  Administrátor
      Nainštalovali ste si zdrojáky gcc (gcc-4.0.1-5mdk.src.rpm). Nainštalujte si normálny balík s gcc (bez "src") a pôjde vám to.
      • Re: Re: gcc 13.03.2006 | 23:41
        Wan_L   Návštevník
        okej..idem to skusi..velmi diik..
        • Re: Re: Re: gcc 14.03.2006 | 00:04
          Wan_L   Návštevník
          ece mi to hlasi ze [root@Wan nove]# rpm -Uvh gcc-3.3.1-2mdk.i586.rpm error: failed dependencies: binutils >= 2.14.90.0.5-1mdk je nutné pro gcc-3.3.1-2mdk gcc-cpp = 3.3.1-2mdk je nutné pro gcc-3.3.1-2mdk libgcc >= 3.3.1-2mdk je nutné pro gcc-3.3.1-2mdk glibc-devel >= 2.2.5-14mdk je nutné pro gcc-3.3.1-2mdk [root@Wan nove]# potrebujem tieto veci ece ztiahnut ze ?? a potom co mam s nimi?? velmi dakujem..budem cakat na odpoveda..caute..
          • Re: Re: Re: Re: gcc 14.03.2006 | 00:46
            Avatar Ondrej Hučko Kubuntu  Administrátor
            Vyrozumel som, že máte Mandrake (Mandrivu). Nemusíte sťahovať balíky a ručne ich inštalovať. Spustite predsa z menu inštalátora balíkov, zadajte gcc a nainštalujte to. Vyrieši to automaticky aj závislosti, pretože všetko by malo byť na CD/DVD.