pomozte mi so zvukom v debiane

Sekcia: Ostatné 23.03.2005 | 17:44
ghost   Návštevník
mam zvukovu kartu na doske Nforce2 a nejde mi zvuk v linuxe.Mam debian a s kamaratom som si kompiloval kernel aj kombajnoval.Ja sa do toho velmi nerozumiem a on tu nieje.Aj som si stiahol ovladace na zvuk,nainstaluje mi ich ale aj tak nejde zvuk.X mam KDE.Ked dam vlastnosti zvuku v KDE tak tam je aj manualna cesta na zvuk,ale neviem kde sa nachadza ovladac.A zvuk mam nastaveny na autodetekciu.Pomozte mi prosim ak viete.Dakujem.
    • Re: pomozte mi so zvukom v debiane 20.03.2005 | 13:11
      Avatar lukipuki Gentoo  Používateľ
      Mám rovnaký čipset a jadro som kompiloval takto: Advanced Linux Sound Architecture ---> PCI devices ---> Intel/SiS/nVidia/AMD/ALi AC97 Controller Potom stačí pustiť alsaconf a zvuk by už mohol ísť. Pri štarte by sa ešte malo púšťat "/etc/init.d/alsa start".
      • Re: Re: pomozte mi so zvukom v debiane 22.03.2005 | 13:54
        ghost   Návštevník
        dakujem za pomoc, len neviem zakompilovat do jedra to hore vyssie uvedene.kernel si spustim ale neda sa mi do neho zapisovat... Som v tom novy.
        • Re: Re: Re: pomozte mi so zvukom v debiane 22.03.2005 | 22:48
          Avatar lukipuki Gentoo  Používateľ
          No nejak ťa nechápem. Čo myslíš tým "kernel si spustim ale neda sa mi do neho zapisovat..."? Ak myslíš "make menuconfig", tak je to v Device drivers -> Sound -> Alsa a to ďalej som písal vyššie. Inak môžeš zmeniť v súbore .config hodnotu CONFIG_SND_INTEL8X0=m.
          • Re: Re: Re: Re: pomozte mi so zvukom v debiane 22.03.2005 | 23:34
            ghost   Návštevník
            prepac zle sa vyjadrujem.spustim make menuconfig, ale tam nemam device drivers ->sound->Alsa mam kernel 2.4.18 ale device drivers som vazne nikde nenasiel,asi nemam v kerneli Alsa.
            • Re: Re: Re: Re: Re: pomozte mi so zvukom v debiane 23.03.2005 | 07:30
              lubo   Návštevník
              to nemas, stiahni si 2.6.X jadro
              • Re: Re: Re: Re: Re: Re: pomozte mi so zvukom v deb 23.03.2005 | 17:44
                Avatar lukipuki Gentoo  Používateľ
                V 2.4 nie je ALSA ešte v kerneli, takže si musíš nainštalovať ALSU zo zdrojákov. Tuším sa tomu dáva parameter pre configure, aby si nekompiloval všetky možné ovládače. Skús teda ./configure --help a potom pusti ./configure s takým parametrom, aby si kompiloval iba modul pre tvoju zvukovku.