APACHE

Sekcia: Konfigurácia 12.04.2007 | 22:52
janko   Návštevník
ahojte

ked si linux nieco vezme do hlavy nie a nie mu to z tade vypatlat,
mam takyto problem, nainstaloval som si apache 1.3
vsetko slapalo v pohode, tak som naistaloval
apacha2 a potom som apacha 1.3 odinstaloval
no a teraz zadam /etc/ini.d/apache2 start
a nic, skoci na na novy riadok, ziadna sprava ze apache2 running alebo ze failed proste nic...
mam debian a instaloval som
apt-get install apache2 apache2.2-common

co by s tym mohlo byt?
    • Re: APACHE 12.04.2007 | 22:59
      Avatar borg Arch, Debian jessie  Administrátor
      no skus pre srandu pozret do logov, ci tam nieco nebude
      • Re: APACHE 12.04.2007 | 23:08
        janik   Návštevník
        pozeral som
        /var/log/apache2/
        access.log - prazdny
        error.log - prazdny

    • Re: APACHE 12.04.2007 | 23:29
      --   Návštevník
      zeby aptitude reinstall apache2 apache2.2-common ?
      • Re: APACHE 12.04.2007 | 23:48
        janik   Návštevník
        tak zeby nie !!! :)
        uz som na to prisiel,
        kedze som tam mal predtym apacha 1.3 po isntalacii apache2 sa apache2 vypol kym sa poriadne nenastavi aby sa nebyl so svojim starsim bratom aspon ja to tak chapem ;)
        takze v /etc/default/apache2
        treba zmenit
        NO_START z jednotky na 0
        0 = start on boot
        1 = don't start on boot
        takze
        NO_START=0
        potom zadam /etc/init.d/apache2 start
        a "vuala"
        starting web server (apache2)....

        ale dik vsetkym za snahu ;)
        • Re: APACHE 13.04.2007 | 01:02
          janik   Návštevník
          kurnaaaa, tak som to zase pojebaaaal :(

          som sa drbkal aby som ta rozbehol phppko a teraz mi to uz nenacita ani normalne html,
          documentroot mam /var/www/
          mam tam ulozeny subor index.html
          a vsak ked zadam do prehliadaca tak mi vyhodi strankau nejde najst a v logu
          cat /var/log/apache2/error.log
          mam ze
          [Thu Apr 12 22:56:41 2007] [error] [client 92.116.12.11] File does not exist: /htdocs

          a to preco? :(
          • Re: APACHE 13.04.2007 | 01:10
            Avatar uid0 Debian  Používateľ
            lol. to je sila
            Debian. apt-get into it…
            • Re: APACHE 13.04.2007 | 01:49
              janik   Návštevník
              tak to je sila,
              doteraz som s tym jebkal, musel som apt-get remove apache2 apache2.2-common
              a potom
              aptitude install apache2 apache2.2-common
              tak a teraz uz len tu php4 rozbehat, vie niekto o nejakom bezpecnom navode ;) ???
              • Re: APACHE 13.04.2007 | 03:18
                --   Návštevník
                slusnejsie by sa vyjadrovat nedalo?
    • Re: APACHE 13.04.2007 | 02:16
      Avatar Misko Kripel slackware  Používateľ
      inak ked mas problem so startom apacha tak sa na nejake blbe rc.d skripty vykasli a spusti ho priamo (#apachectl start), ked nabehne tak vies ze chyba je v init skriptoch apachu
      asdf
      • Re: APACHE 13.04.2007 | 11:37
        janik   Návštevník
        tak musim povedat ze apache 1.3 bol prehladnejsi co sa konfigu tyka,
        mam takuto halusku,
        ked zadam 12.12.12.12/phpmyadmin <- funguje bez problemov
        ale ked uz zadam povedzme 12.12.12.12/skuska
        a v tom skuska adresari mam subor index.php, ktory obsahuje
        <?
        phpinfo();
        ?>
        tak uz mi ho nezobrazi ale ponukne na stiahnutie ako daky iny subor???

        To co je za halusku? Stretol sa uz niekto s niecim podobnym?
        Dik
        • Re: APACHE 13.04.2007 | 13:40
          Avatar uid0 Debian  Používateľ
          mas nainstalovany php modul? a je zapnuty? a2enmod

          alebo pogugli na debian-administration webe
          Debian. apt-get into it…
          • Re: APACHE 13.04.2007 | 17:47
            janik   Návštevník
            jo tak som sa nakoniec nasrrrrrdil a kompletne som odinstaloval php4 php4-common apacha2 apacha2.2-common aj apacha 1.3 a postupoval takto
            apt-get install apache2
            a potom
            apt-get install php4
            odfajal som RedirectMatch ^/$ /apache2-default/
            (podla mna to tam len zbytocne pletie)
            a vyskusal php, fungovalo parada,
            no a vyskusal som zase nieco ine napriklad 12.12.21.12/test
            a zase nic :(((((
            no a potom po par hodinach googlenia a preklinania vsetkeho mozneho som to pochopil
            a2ensite - zapnem virtualnu stranku(server)
            a2dissite - vypnem virtualnu stranku(server)
            takze to uz slape ako chcem...

            teraz sa vsak cudujem ze zase pre zmenu neviem najst
            apt-cache search apache2-ssl-certificate

            Tak ako si mam vygenerovat certifikat?
            • Re: APACHE 13.04.2007 | 17:58
              Avatar borg Arch, Debian jessie  Administrátor
              http://gagravarr.org/writing/openssl-certs/ca.shtml
              • Re: APACHE 17.04.2007 | 11:47
                janik   Návštevník
                Zdarec,
                tak mam uz certifikat, ale mam dalsi problemik :(

                cez a2enmod som zapol ssl mod,
                potom som do virtual pridal nieco taketo
                <IfModule mod_ssl.c>
                #NameVirtualHost *:443
                
                <VirtualHost *>
                    ServerAdmin webmaster@domena.tld
                    ServerName  www.web.domena.tld
                    ServerAlias web.domena.tld
                
                    # Indexes + Directory Root.
                    DirectoryIndex index.php
                    DocumentRoot /var/www/web.domena.tld/mojweb/
                
                    # Logfiles
                    ErrorLog  /var/www/web.domena.tld/logs/error.log
                    CustomLog /var/www/web.domena.tld/logs/access.log combined
                
                    # SSL
                    SSLEngine on
                    #SSLProtocol All
                    #SSLCipherSuite -ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:-LOW:+SSLv2
                    #SSLSessionCacheTimeout 600
                
                    SSLCertificateFile /etc/apache2/ssl/apache.pem
                
                </VirtualHost>
                
                </IfModule>
                

                No a problem je v tom ze ked restartnem apacha2 tak mi vypise failed, ale nic viac ziadnu inu hlasku, ani neviem kde by som to mohol hladat co sa mu nepaci...
                Avsak akonahle zamriezkujem # SSLEngine on a startnem apacha2
                znova bezi vsetko OK, samozrejme ale bez podpory SSL...
                Zrejme nebudem mat este daco OK, nevie mi niekto poradit?

                Dakujem
                • Re: APACHE 17.04.2007 | 12:33
                  janik   Návštevník
                  tak predsa len, v logu mam toto
                  [Tue Apr 17 10:21:25 2007] [error] Init: Unable to read server certificate from file
                   /etc/apache2/ssl/apache.pem
                  [Tue Apr 17 10:21:25 2007] [error] SSL Library Error: 218529960 
                  error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag
                  [Tue Apr 17 10:21:25 2007] [error] SSL Library Error: 218595386 
                  error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1 error
                  
                  • Re: APACHE 17.04.2007 | 16:28
                    janik   Návštevník
                    tak chyba bola zrejme v tom ze som mal naprd vytvorene certifikaty
                    a tiez som pridal do virtualhost este riadok
                    SSLCertificateKeyFile /cesta/webkey.pem