Kubuntu problem zo swapom

Sekcia: Konfigurácia 29.04.2007 | 15:47
Avatar t0mas Archlinux a ubuntu 9.10  Používateľ
Nazdar,

pri beznom spusteni systemu mi vsetky programy zeru 600 - 700 MB ram (RAM mam 521 + 256 MB) a vôbec sa nepouziva swap...ako to opravit?
Linux4ever frasier@jabbim.sk
    • Re: Kubuntu problem zo swapom 29.04.2007 | 15:48
      Avatar borg Arch, Debian jessie  Administrátor
      to je normalne, velka cast sa pouziva na diskovu cache. uvolni sa v pripade potreby.
      • Re: Kubuntu problem zo swapom 29.04.2007 | 16:34
        t0mas   Návštevník
        ale preco sa mi nepozuiva swap ani kb z neho sa nevyuziva a pri starte sa zapina
        • Re: Kubuntu problem zo swapom 29.04.2007 | 16:51
          Avatar borg Arch, Debian jessie  Administrátor
          pretoze system nepotrebuje swapovat.
    • Re: Kubuntu problem zo swapom 29.04.2007 | 19:02
      WlaSaTy   Návštevník
      Aby sa linux choval tak ako ocakavas, tak by v nom niekto musel pokazit memory managment na kvalitu nejakeho ineho menej kvalitneho operacneho systemu. Z akeho OS prechadzas ze ocakavas takto problematicke chovanie aj od linuxu, ak sa smiem spytat?
      • Re: Kubuntu problem zo swapom 29.04.2007 | 20:06
        Avatar Róbert Dúbravský Kubuntu 64bit  Používateľ
        Ja som mal tiež problém so Swap-om. Myslel som si že je to nejaký inštalačný bug. Vôbec sa nepoužíval.(nepripájal)
        Tak som ho pripojil ručne.
        # /etc/fstab: static file system information.
        #
        # <file system> <mount point> <type> <options> <dump> <pass>
        proc /proc proc defaults 0 0
        # /dev/sda1
        UUID=45e74e79-978e-4875-9387-4c0b75432e9b / ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
        # /dev/sda4
        UUID=1de5bae4-a027-45fc-b094-3058a98d7692 /media/sda4 ext3 nouser,defaults,atime,auto,rw,dev,exec,suid 0 2
        # /dev/sda3
        /dev/hda3 none swap sw 0 0
        /dev/scd0 /media/cdrom0 udf,iso9660 user,atime,noauto,rw,dev,exec,suid 0 0
        A ešte moje hda oddiely pripojil ako sda. No všetko funguje ako má.
        Tvorba internetových stránok - webdizajn, Joomla www.treborplus.net
        • Re: Kubuntu problem zo swapom 29.04.2007 | 20:17
          Avatar borg Arch, Debian jessie  Administrátor
          to je normalne, ze oddiel ktory sa ma pouzivat ako swap musi byt v /etc/fstab, aby sa pripojil pocas startu
        • Re: Kubuntu problem zo swapom 29.04.2007 | 20:21
          WlaSaTy   Návštevník
          ahoj,
          swap sa nepripaja (mount), swap sa aktivuje (swapon) a system ho pouzije len ak ma na to dovod.

          a este jedna poznamka, tvoje oddiely pripojil podla UUID ktorym je jedno na akom subsysteme su pripojene a v akom poradi.

          ale aby sme sa vratili k povodnej otazke, swap sa skutocne pouzije len ak je na to dovod. linux ma memory managment na skutocne vysokej urovni.
          • Re: Kubuntu problem zo swapom 29.04.2007 | 20:51
            Avatar t0mas Archlinux a ubuntu 9.10  Používateľ
            dakujem za informacie
            Linux4ever frasier@jabbim.sk
          • Re: Kubuntu problem zo swapom 29.04.2007 | 21:58
            trebor   Návštevník
            Takže ten swap sda3 mám dať do pôvodného stavu - čiže vymazať? Mam na notase len 480mb + občas virtualbox, a dosť to vytažujem pri práci. Dik za info.
            • Re: Kubuntu problem zo swapom 29.04.2007 | 22:12
              WlaSaTy   Návštevník
              ak pamet dost vytazujes pri praci, tak ten swap radsej nehaj. inac ak nebudes mat pamet (ram alebo swap), tak sa to spadne.