php-4.4.7 - INSTALL

Sekcia: Konfigurácia 21.05.2007 | 21:43
php-4.4.7   Návštevník
Caute,
uz asi 2h sedim nad instalaciou php a som nuteny vas poprosit o radu,apache aj mysql uz mam :-)
[root@localhost php-4.4.7]# ./configure --with-apxs2=/usr/local/apache2/bin/apxs--with mysql
creating cache ./config.cache
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking host system type... Invalid configuration `mysql': machine `mysql' not recognized

checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking whether gcc and cc understand -c and -o together... yes
checking how to run the C preprocessor... gcc -E
checking for AIX... no
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for re2c... exit 0;
checking whether ln -s works... yes
checking for gawk... gawk
checking for bison... no
checking for byacc... no
configure: warning: You will need bison if you want to regenerate the PHP parsers.
checking for flex... lex
checking for yywrap in -ll... no
checking lex output file root... ./configure: line 2554: lex: command not found
configure: error: cannot find output from lex; giving up

vzdy mi to takto skonci s chybou,mam linux mandriva 2007 CZ
    • Re: php-4.4.7 - INSTALL 21.05.2007 | 21:46
      WlaSaTy   Návštevník
      ako prve si skontroluj medzery v argumentoch a ako druhe nainstaluj lexical parser (lex: command not found).
      • Re: php-4.4.7 - INSTALL 21.05.2007 | 21:48
        php-4.4.7   Návštevník
        lexical parser???hmmm o tom som nepocul , ok skusim to pozriet,ale instalujem to z navodu co bol v infoware a tam sa o lexical parser nic nehovorilo :-) http://www.google.sk/search?hl=sk&q=lexical+parser+for+linux&btnG=H%C4%BEada%C5%A5&meta= nejako to nemozem najst
        • Re: php-4.4.7 - INSTALL 21.05.2007 | 22:02
          WlaSaTy   Návštevník
          asi si potom ten vystup z configure necital.:

          checking for flex... lex
          checking for yywrap in -ll... no
          checking lex output file root... ./configure: line 2554: lex: command not found
          configure: error: cannot find output from lex; giving up

          takze pokial sa ti to nechce citat, tak si radsej instaluj balicky cez standardny nastroj na to urceny. predides tym sklamaniam ktore sa ti zacnu vyskytovat uz za chvilu.
          • Re: php-4.4.7 - INSTALL 21.05.2007 | 22:23
            Avatar Frantisek Klabzuba Debian  Používateľ
            Len pokoj, nikto WlaSaTy ešte z neba nespadol ;)
            • Re: php-4.4.7 - INSTALL 21.05.2007 | 22:29
              WlaSaTy   Návštevník
              som len sucho skonstatoval a rozculovat sa na takej blbosti nebudem.
              • Re: php-4.4.7 - INSTALL 21.05.2007 | 22:33
                php-4.4.7   Návštevník
                namiesto sprostych reci mudrlantov by mi pomohlo to ze kde by som lexical parser nasiel a potom si to nainstaloval :-) , ak by som mal zaujem o sproste reci tak pojdem do krcmy a budem vychvalovat Slovan Bratislava v Trnave :-)
                • Re: php-4.4.7 - INSTALL 21.05.2007 | 22:40
                  :-)   Návštevník
                  ake mas distro?
                  • Re: php-4.4.7 - INSTALL 21.05.2007 | 22:42
                    php   Návštevník
                    mam linux mandriva 2007 CZ

                    (pisal som to hned v prvom prispevku!)
                    • Re: php-4.4.7 - INSTALL 21.05.2007 | 22:48
                      :-)   Návštevník
                      sorry, nevsomol som si :-)
                      ak mandriva obsahuje balicek flex tak si ho nainstaluj. pomocou nastroja pouzivaneho na instalaciu balickov
                      • Re: php-4.4.7 - INSTALL 21.05.2007 | 22:49
                        WlaSaTy   Návštevník
                        tak tak, aj configure to pisalo:
                        flex... lex
                        • Re: php-4.4.7 - INSTALL 21.05.2007 | 22:53
                          php   Návštevník
                          njn,idem sa na to pozriet ... inak ten flex/lex sluzi vlastne na co?
                          • Re: php-4.4.7 - INSTALL 21.05.2007 | 23:07
                            php   Návštevník
                            takze mandriva to v sebe nema,rad by som si to teda doinstalovat ;-) zatial som nasiel iba perl-ParseLex
                            • Re: php-4.4.7 - INSTALL 21.05.2007 | 23:39
                              php   Návštevník
                              bol by som rad ak by mi niekto pomohol najst to co hladam,lebo nemozem to ani vygooglit nejako.Prosim :-)
                              • Re: php-4.4.7 - INSTALL 21.05.2007 | 23:41
                                Avatar borg Arch, Debian jessie  Administrátor
                                a co si daval do google, stacilo 2 slovicka (mandriva a flex)
                            • Re: php-4.4.7 - INSTALL 21.05.2007 | 23:40
                              Avatar borg Arch, Debian jessie  Administrátor
                              http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/flex
                            • Re: php-4.4.7 - INSTALL 21.05.2007 | 23:42
                              WlaSaTy   Návštevník
                              ale ma, minimalne v contribe pre 2007.1 som to videl, kompilovane pre uclibc.
                              • Re: php-4.4.7 - INSTALL 22.05.2007 | 18:17
                                php   Návštevník
                                je to dost mozne,ale mam 2007.0 :-(
                                • Re: php-4.4.7 - INSTALL 22.05.2007 | 18:39
                                  php   Návštevník
                                  borgcube - -> dik za tvoju snahu,ale bohuzial som to nainstaloval ale stale to nemam v poriadku,php nejde nainstalovat s tou istou chybou...
                                • Re: php-4.4.7 - INSTALL 22.05.2007 | 18:53
                                  WlaSaTy   Návštevník
                                  mam sa ti pozriet ci to nie je v kontribe aj pre 2007.0?
                                  • Re: php-4.4.7 - INSTALL 22.05.2007 | 19:00
                                    Avatar lime Debian, Red Hat, Fedora Core 3  Používateľ
                                    http://rpmseek.com/rpm-pl/flex.html?hl=com&cs=flex:PN:0:0:0:0
                                    Prejdite z modrej obrazovky k linuxu :))