system nenabieha korektne

Sekcia: Hardware a Drivery 17.06.2007 | 18:49
marian34   Návštevník
Zdravim,mam problem s modemom ad 2622,veľmi tomu nerozumiem,takže ak budem nepresny tak ma ospravedlnte.Ide o to,že pri štarte mi system(linux mandriva 2007 spring):
-keď štartujem z vypnuteho počitača tak 50:50 system nabehne
-keď rebootujem z windows system nenabehne
-keď rebotujem z linuxu system nabehne(väčšinou)
Problem je v modeme a jeho ovladači.Pri detekcii
udev
mi to vyhodí chybu
cxacru failed blablabla....
riešim to tak,že pred štartom modem odpojim a zapnem ho až po detekcii dev.Myslim,že existuje aj elegantnejšie riešenie-help....
    • Re: system nenabieha korektne 17.06.2007 | 22:32
      marian34   Návštevník
      Ide o to,že pri detekcii dev zariadeni sa z nejakych pričin(tie by som radšej nerozoberal,lebo s tým idiotskym modemom som si už užil svoje) cely system zasekne.Riešenie vidim v tom,že by sa modul cxacrunespušťal pri udev,ale neskôr(napr. až nakoniec).Možno trepem somariny,ale zda sa mi,že by to mohlo pomôcť.Len neviem ako a kde sa tie spušťacie veci nastavuju...
      • Re: system nenabieha korektne 19.06.2007 | 23:28
        marian34   Návštevník
        Dopracoval som sa zatiaľ k tomu,že sa cxacru nespúšťa pri štarte a neblokuje system.Ale ako dosiahnúť aby sa potom spustel automaticky?
        • Re: system nenabieha korektne 20.06.2007 | 11:16
          Avatar georw Ubuntu 12.04  Používateľ
          A aky pouzivas firmware? Mal by byt pokial mozno ten isty, co je vo Windowse. Ak ides podla navodu tuna na linuxos.sk, tak vyskusaj aj ten druhy, ked ti nejde ten prvy. A vypis cele znenie tej chyby, co vyhodi.
          • Re: system nenabieha korektne 20.06.2007 | 13:19
            marian34   Návštevník
            Čo sa tyka firmwaru mam ten novší,ale v mandrive 2006 som používal ten starší a tiež to blblo.Ta chyba vyzerá nejak takto:
            usbcore: registered new driver cxacru
            cxacru 1-2:1.0:found firmware cxacru-fw.bin
            Spúšťa sa udev cxacru 1-2:1.0: FirmwarePllFClkValue failed: -22 
            a tym to končí.
            • Re: system nenabieha korektne 20.06.2007 | 13:58
              Avatar georw Ubuntu 12.04  Používateľ
              Tu je navod na Vigor318 DSL. Skus ist podla toho. Firmware tam dava do /lib/hotplug/firmware. Pise tam tiez, ze
              Tento br2684ctl chodí bez chyb len na Mandrive2006
              Tak skus ten balik najst v original repozitaroch Mandrivy a nainstalovat odtial. Ci to pomoze netusim.
              .
              Este skus popisat ako sa sprava modem, pri kazdej situacii. Pravdepodobne tam bude kontrolka, podla ktorej zistis, ci je firmware v modeme. Kedysi som mal Vigor usb modem, sice fungovalo vsetko bez problemov, ale som rad, ze som sa ho zbavil a mam teraz Chello.
              • Re: system nenabieha korektne 20.06.2007 | 14:36
                marian34   Návštevník
                Ten modem som inštaloval už x-krát,nie je problem ho rozbehať-ide o tu spomínanu chybu.Nerád by som sa hrabal v ovladačoch,pretože za 1. tomu nerozumiem a za 2.je to beh na dlhé trate.Preto to chcem riešiť už spomenutým spôsobom,aj keď sa zdá,že ani to nie ja najšťastnejšie riešenie,pretože keď rebootujem z XP a modul cxacru zavediem ručne,tak to stejne cele zmrzne.Nato je zas len jeden liek-resetoveť modem(ručne ho odpojiť-pripojiť)....a stále dookola.....proste modem za všetky drobné...
                • Re: system nenabieha korektne 23.06.2007 | 13:23
                  Avatar Lubos21   Používateľ
                  Ten modem aj mne v mandrive blbne. A to aj v pripade ze nerebootujem z windowsu. Aj po spusteni mandrivi sa mi vacsinou nepodari ho pomocou prikazu stdsl.sh start spustit. Sice mi ziadnu chybu neoznami, ale jednoducho to nejde. A musim vseljak v ovladacom centre to pripojenie rekonfigurovat aby sa uracilo spustit. Vzdy to vyjde na zhruba 5 pokus. V ubuntu a inich debian? distribucii kde sa da nasavit pripojenie pomocou pppoeconf je vyhoda v tom, ze je tam moznost zvolit aby sa modem inicializoval az po nabootovani a tim padom nehrozi mrznutie systemu ani po rebootovni z windowsu. Od kedy som zvolil tuto moznost ubuntu mi z dovodu modemu ani raz nezamrzol. Kym som to nemal navolene aby sa modem inicializoval az po nabootovani bol som na tom rovnako ako pises v prispevku. Mandrivu mam len 2 dni. Mozno aj tam by sa dal nainstalovat balik pppoeconf a nastavit pripojenie cez neho. Zatial som mandrivu velmi neskusal tak neviem.
                  • Re: system nenabieha korektne 23.06.2007 | 15:36
                    marian34   Návštevník
                    Moje zatial najlepšie riešenie v mandrive je také,že modul cxacru najskôr v /etc/modprobe.d/ldetect-lst.conf najskôr zakážem editovaním a pridaním blacklist cxacru a v /etc/rc.d/rc.local tento modul necham pri štarte nahrať ako posledný modprobe cxacru.Mám istotu,že z vypnutého železa štartujem do mandrivy bez problemov.Pri reboote z wind. ten ovladač ešte môže robiť problém,ale s tým si už hlavu nelámem.
                    • Re: system nenabieha korektne 26.06.2007 | 00:19
                      Avatar zeleno Mandriva, OpenSuse  Používateľ
                      Mne sa tiež systém zasekával a pomohlo v ovládacom centre zaškrtnúť spustenie služby pppoe pri štarte.