gentoo

Sekcia: Konfigurácia 24.06.2007 | 16:16
miso   Návštevník
pri butovani gentoo mi vypisuje chybu Block device /dev/sda3 is not a valid root device... The root block device is unspecified or not dected please specify a device to boot, or "shell" for a shell.. boot() :: uz som skusal aj toto ale nic nepomohlo neviete co s tym
mam amd turion 64
100GB HHD rozdeleny: /dev/sda1 50MB boot /dev/sda2 1200 swap /dev/sda3 hlavny adresar
    • Re: gentoo 24.06.2007 | 16:43
      Avatar Miroslav Bendík Gentoo  Administrátor
      Takze predpokladam, ze kernel nema podporu pre disky. Treba priamo do jadra zakompilovat podporu pre sda, alebo pouzit initrd.
      Pripadne je tu este jedna moznost - pouzit genkernel, tam by mala byt konfiguracia jednoduchsia.
      • Re: gentoo 24.06.2007 | 17:14
        miso   Návštevník
        ale ja mam genkernel
        tak ako to mam nastavit v nom??
        • Re: gentoo 24.06.2007 | 17:32
          Avatar Miroslav Bendík Gentoo  Administrátor
          No klasika v menuconfig .. akurat neviem co vsetko tam treba zapnut, sda som v zivote nevidel.
          • Re: gentoo 26.06.2007 | 13:10
            Avatar nardew debian  Používateľ
            nikdy si nemal v linuxe pichnutu flashku?:)
            • Re: gentoo 27.06.2007 | 09:57
              Avatar Igor Hlina Mac OS ML  Používateľ
              sda je tusim od verzie kernelu 2.6.19.xx spolocne pre vsetky disky aj IDE.
              while (2*2 == 5) { echo "If you're reading this, something is definitely wrong"; }
              • Re: gentoo 27.06.2007 | 14:32
                WlaSaTy   Návštevník
                zaumijaue, a od ktorej ak sa smiem spytat?
                 $ uname -a && df -k /
                Linux rybnik 2.6.19-gentoo-r6 #1 Wed Feb 7 16:09:37 CET 2007 ppc 7447A, altivec supported PowerMac10,1 GNU/Linux
                Filesystem           1K-blocks      Used Available Use% Mounted on
                /dev/hda6             19099240  17600172    528872  98% /
                
                myslim ze som skusal aj novsie jadra ale nezdalo sa mi ze to berie ATA, este tak PATA mozno koli biosom ale ja bios nemam.
                • Re: gentoo 27.06.2007 | 18:02
                  Avatar Peter Rozum Arch Linux  Používateľ
                  tiez sa mi to nezda. mam mix pata a sata a co si pamatam tak len raz neiaka live distro mi pata oznacovala ako sda.
                  Everything is proceeding as I have foreseen.
                  • Re: gentoo 27.06.2007 | 18:51
                    WlaSaTy   Návštevník
                    ano, pametam aj ja ako boli nejake tlaky zjednotit subsystem ATA/PATA/SATA/SCSI ale kedysi bol podobny omyl aj emulacia IDE-SCSI :-)
                • Re: gentoo 02.07.2007 | 22:19
                  Avatar Igor Hlina Mac OS ML  Používateľ
                  Co to mas, Apple, ked nemas BIOS?

                  Inak je to taq, aspon v Archu alebo Ubuntu, vsade mam svoje PATA disky ako sda. Koli tomu mam aj problem s hdparm, nejde zapnut DMA (mozno uz je default zapnute) a 32bit I/O.
                  info na Arch-news
                  while (2*2 == 5) { echo "If you're reading this, something is definitely wrong"; }
      • Re: gentoo 24.06.2007 | 17:25
        miso   Návštevník
        default 0
        timeout 30
        splashimage=(hd0,0)/boot/grub/splash.xpm.gz

        title=Gentoo Linux
        root (hd0,0)
        kernel /boot/kernel-genkernel-x86_64-2.6.19-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda3 udev
        initrd /boot/initramfs-genkernel-genkernel-x86_64-2.6.19-gentoo-r5
    • Re: gentoo 26.06.2007 | 13:27
      Avatar eNuke Gentoo macosx  Používateľ
      To som mal aj ja.Mam mrte sata diskov a naprd radic.Proste prekompiluj kernel s genkernel --menuconfig all daj v sekcii driverov radicov na vsetko co ti pripada ze by sa ta malo tykat hviezdicku ;-)
      Learnt to farth!!!