strigi na kubuntu gutsy

Sekcia: Aplikácie & Desktop 21.10.2007 | 18:57
Avatar Slavomír Tuleja Ubuntu 7.10  Používateľ
Ahojte. Mam jeden problem so Strigi v novom Kubuntu 7.10. Zrejme suvisi s nastavenim character encoding.

Ak dam vyhladat nejaky subor, v ktoreho ceste alebo v mene sa nachadza slovensky znak s diakritikou (napr. ž, ť, ...) tak ho sice Strigi najde, ale v linku na tento najdeny subor su pokazene znaky a ked nan kliknem, tak mi oznami, ze taky subor neexistuje.

Ak zadam v konzole
echo $LANG
vypise mi
en_US.UTF-8

Poznate niekto na toto riesenie?
    • Re: strigi na kubuntu gutsy 21.10.2007 | 19:25
      Avatar Stanislav Hoferek Greenie, Manjaro, Q4OS, Lubuntu  Používateľ
      niekto tu necital manual...

      alt+f2: kdesu kate /etc/environment
      • Re: strigi na kubuntu gutsy 21.10.2007 | 22:09
        slavomir   Návštevník
        Žiaľ, nevyriešilo to môj problém.

        Pozrel som si v Tvojom manuáli (verzia 1.7.5) na strane 29/66 rady ohľadom nastavení jazyka. Pokúšal som sa nastaviť takto jazyk systému, ale prepísanie obsahu súboru /etc/environment neviedlo ani po reštarte X-ka ku zmene premennej $LANG.

        Tak som teda priamo v SYSTEM SETTINGS nastavil v položke REGIONAL&LANGUAGE systémový jazyk na slovenčinu, pričom po nálsednom reštarte X-ka bol obsah súboru /etc/environment nasledujúci:

        PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
        LANG="sk_SK.UTF-8"
        LANGUAGE="sk_SK:sk:en_GB:en"

        Vypol som potom u programu STRIGI indexovanie a vypol som aj démona. Potom som zmazal celý priečinok .strigi v mojom domácom priečinku.

        Následne som znovu spostil strigi démona a spustil indexovanie.

        Žiaľ, po hodine indexovania stále tá istá chyba: keď dám vyhľadať slovo s diakritikou, vyhodí mi to výsledky vypísané v úplne ODVECI znakovej sade. Kliky-háky.

        Netuším, či sa dá v strigi interne nastaviť encoding, aby používalo pri indexovaní aj vypisovaní UTF-8.

        Vie niekto pomôcť?