sys-fs/fuse

Sekcia: Aplikácie & Desktop 09.04.2008 | 18:41
Marwin   Návštevník
mam takyto problem:
chcel som nahodit fuse ale vypisalo mi (v Gentoo) ze:
You need to build the FUSE module from the kernel source, because your kernel is too new
* Please check to make sure these options are set correctly.
* Failure to do so may cause unexpected problems.
* Once you have satisfied these options, please try merging
* this package again.

neviete niekto poradit co s tym?
    • Re: sys-fs/fuse 09.04.2008 | 18:49
      Avatar borg Arch, Debian jessie  Administrátor
      vsak emergni ten modul

      emerge sys-fs/fuse (ci aka je syntax emerge)
      • Re: sys-fs/fuse 09.04.2008 | 20:59
        WlaSaTy   Návštevník
        pokial nebude musiet zamaskovat ten novsi kernel, predsa len:
        because your kernel is too new
      • Re: sys-fs/fuse 09.04.2008 | 21:21
        Marwin   Návštevník
        ved prave ze to mi vypisalo ked som dal:
        # emerge sys-fs/fuse
        • Re: sys-fs/fuse 11.04.2008 | 20:04
          WlaSaTy   Návštevník
          ak to nechces riesit nejako urgentne, tak si pockaj kym vyjde novsi fuse. inak budes musiet zamaskovat novse verzie jadra ako vyzaduje ten fuse.

          ps nezabudni si skontrolovat aj kam ukazuje link /usr/src/linux.
    • Re: sys-fs/fuse 13.04.2008 | 14:06
      Marwin   Návštevník
      ok, problem vyrieseny v repozitari bola verzia 2.7.0 a z netu som stiahol a nainstaloval 2.7.3 a ta uz presla v poriadku
      • Re: sys-fs/fuse 13.04.2008 | 14:24
        Avatar Tomáš Srnka Barz čo, už asi všetko  Administrátor
        dufam, ze si si napisal ebuild na to
        Dlho som robil linuxos.sk, neskôr založil vpsFree.cz, posledných pár rokov ako tech. riaditeľ vo Websupporte
        • Re: sys-fs/fuse 13.04.2008 | 14:46
          WlaSaTy   Návštevník
          a prezije fuse aj upgrade kernelu? ale aspon sa chalan nauci :)
          • Re: sys-fs/fuse 13.04.2008 | 19:36
            Marwin   Návštevník
            ok, a uz som sa zasa stratil :), preco by nemal prezit upgrade?, alebo ako by som to mal spravne vyriesit? moc sa v tom nevyznam :(
            • Re: sys-fs/fuse 13.04.2008 | 20:33
              WlaSaTy   Návštevník
              fuse je rozhranie do jadra. a ak vymenis jadro, budes tam mat to rozhranie? pokial na to odpovies, tak budes mat pred ocami aj spravne riesenie.
              • Re: sys-fs/fuse 14.04.2008 | 13:49
                Marwin   Návštevník
                no takze asi nebudem ze? :) ale ako sa teda da spravit aby to tam ostalo? takze ak som to spravne pochopil, ked to iba tak nainstalujem tak mi to po upgrade jadra zase prestane fungovat, ale co mam spravit, ked to nemozem nainstalovat a emerge obsahuje iba versiu 2.7.0, ktora nejde skompilovat?
                • Re: sys-fs/fuse 14.04.2008 | 18:25
                  WlaSaTy   Návštevník
                  aha, no tak to bude s tebou tazsie. problem je v tom ze ak skompilujes jadro (ci uz nove alebo s novymi nastaveniami), tak budes musiet prekompilovat vsetky ovladace ktore niesu sucastou daneho jadra. tymto trpia napriklad ovladace binarne na grafiku (ktore s IMHO len linkuju), fuse, ntfs3g, x11-drm, mozno aj hal, ndiswrapper a tie ftakovinky co riesia kryptovanie na diskoch (myslim ze to bol truecrypt a spol, IMHO na linuxe je to zbutocne koli divice mapperovi).

                  takze je na tebe ako sa k tomu postavis. bud budes tieto baliky znovu kompilovat kazdu chvilu alebo budes robit upgrade jadra len ked to bude potrebne a nie kedy ti to poukne emerge.