Nejde zvuk na formáte mp4

Sekcia: Aplikácie & Desktop 07.07.2008 | 20:33
Avatar matusroman Mandriva 2008  Používateľ
Ahojte potrebujem radu. Nedarí sa mi rozbehnúť zvuk na filmoch s koncovkou mp4. Obraz ide bez problémov, ale zvuk nespustí. Skúšal som v VLC, Kaffeine, KMPlayer, SMPlayer, ale výsledok rovnaký, zvuk nespustí. Všetky ostatné formáty mi bežia. Prešiel som už aj nejaké fóra a stiahol napríklad ffmpeg podľa rady čo písali, ale nič sa nezmenilo. Viete mi niekto poradiť ?

Mandriva 2008
    • Re: Nejde zvuk na formáte mp4 07.07.2008 | 23:24
      WlaSaTy   Návštevník
      a co je tam za zvuk?

      mplayer -identify -frames 1 film.mp4

      je dost mozne ze mas slabu zvukovku co odmieta pracovat s ac3 a prehras to cez mplayer -ao sdl

      • Re: Nejde zvuk na formáte mp4 08.07.2008 | 11:28
        Avatar matusroman Mandriva 2008  Používateľ
        Toto mi vypísalo po zadaní príkazu :

        [root@localhost Video]# mplayer -identify -frames jb.mp4
        MPlayer 1.0-1.rc2.10mdv2008.0-4.2.2 (C) 2000-2007 MPlayer Team
        CPU: Intel(R) Celeron(R) M processor 1.50GHz (Family: 6, Model: 13, Stepping: 8)
        CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
        Compiled with runtime CPU detection.
        The frames option must be an integer: jb.mp4
        Error parsing option on the command line: -frames
        [root@localhost Video]#

        Po zadaní mplayer -ao sdl jb.mp4 ide obraz, ale zvuk rovnako nie.

        Žiaľ nejde zvuk ani po nainštalovaní xine-faad.
        • Re: Nejde zvuk na formáte mp4 08.07.2008 | 11:30
          Avatar Branislav Poldauf Ubuntu LTS, Debian stable  Používateľ
          a pokusal si sa zmenit nastavenia xine ?? mne to pomohle aby kaffeine korektne prehraval vsetko co chcem
          Linux: the operating system with a CLUE... Command Line User Environment
          • Re: Nejde zvuk na formáte mp4 08.07.2008 | 19:30
            Avatar matusroman Mandriva 2008  Používateľ
            Robil som rôzne pokusy a nastavenia, ale bez výsledku, čo pomohlo konkrétne tebe ?
        • Re: Nejde zvuk na formáte mp4 09.07.2008 | 00:22
          WlaSaTy   Návštevník
          The frames option must be an integer: jb.mp4

          nechybalo ti tam cislo, pocet obrazkov ktore samaju zovrazit pri identify, teda "jedna"? asi nie.
          • Re: Nejde zvuk na formáte mp4 09.07.2008 | 19:15
            Avatar matusroman Mandriva 2008  Používateľ
            Toto je celý komplet výpis po zadaní príkazu :

            [root@localhost Video]# mplayer -identify -frames 1 jb.mp4
            MPlayer 1.0-1.rc2.10mdv2008.0-4.2.2 (C) 2000-2007 MPlayer Team
            CPU: Intel(R) Celeron(R) M processor 1.50GHz (Family: 6, Model: 13, Stepping: 8)
            CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
            Compiled with runtime CPU detection.
            mplayer: could not connect to socket
            mplayer: No such file or directory
            Failed to open LIRC support. You will not be able to use your remote control.

            Playing jb.mp4.
            ISO: File Type Major Brand: ISO/IEC 14496-1 (MPEG-4 system) v1
            Quicktime/MOV file format detected.
            ID_SUBTITLE_ID=0
            [mov] Subtitle stream found, -sid 0
            ID_SUBTITLE_ID=1
            [mov] Subtitle stream found, -sid 1
            ID_VIDEO_ID=2
            [mov] Video stream found, -vid 2
            ID_AUDIO_ID=3
            [mov] Audio stream found, -aid 3
            ID_SUBTITLE_ID=4
            [mov] Subtitle stream found, -sid 4
            VIDEO: [mp4v] 688x384 0bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
            ID_FILENAME=jb.mp4
            ID_DEMUXER=mov
            ID_VIDEO_FORMAT=mp4v
            ID_VIDEO_BITRATE=0
            ID_VIDEO_WIDTH=688
            ID_VIDEO_HEIGHT=384
            ID_VIDEO_FPS=25.000
            ID_VIDEO_ASPECT=0.0000
            ID_AUDIO_FORMAT=mp4a
            ID_AUDIO_BITRATE=79968
            ID_AUDIO_RATE=44100
            ID_AUDIO_NCH=2
            ID_LENGTH=4478.04
            xscreensaver_disable: Could not find XScreenSaver window.
            Pre `/apps/gnome-screensaver/idle_activation_enabled' nie je nastavená hodnota
            ==========================================================================
            Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
            Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
            ==========================================================================
            ID_VIDEO_CODEC=ffodivx
            ==========================================================================
            Trying to force audio codec driver family libmad...
            Requested audio codec family [faad] (afm=faad) not available.
            Enable it at compilation.
            Cannot find codec for audio format 0x6134706D.
            Read DOCS/HTML/en/codecs.html!
            Audio: no sound
            Starting playback...
            VDec: vo config request - 688 x 384 (preferred colorspace: Planar YV12)
            VDec: using Planar YV12 as output csp (no 0)
            Movie-Aspect is 1.79:1 - prescaling to correct movie aspect.
            ID_VIDEO_ASPECT=1.7917
            VO: [xv] 688x384 => 688x384 Planar YV12 [zoom]
            V: 1.1 28/ 28 13% 1% 0.0% 0 0

            Exiting... (End of file)
            [root@localhost Video]#
            • Re: Nejde zvuk na formáte mp4 09.07.2008 | 20:27
              WlaSaTy   Návštevník
              Requested audio codec family [faad] (afm=faad) not available.
              Enable it at compilation.

              Martin mal dobry odhad. Nainstaluj libfaad pre gxine a spusti to cez gxine. Tvoja verzia mplayeru nema prilinkovanu danu kniznicu a je dost mozne ze tu verziu nezahrnuli do standardnych repozitarov pre danu distribuciu.

              PS.: nejedna sa o mp4, ale o Quicktime/MOV file format. preto som sa ja divil ze neprehras klasicky mpeg stvrtej generacie.
              • Re: Nejde zvuk na formáte mp4 09.07.2008 | 21:10
                Avatar matusroman Mandriva 2008  Používateľ
                Súhlasím, že to bude tým, že tam nemám ten codecc, ale už som nainštaloval všetky súbory čo mali dačo spoločné s názvom libfaad a stále nič, možno som sa netrafil na ten správny libfaad. Tak hľadám ďalej...
    • Re: Nejde zvuk na formáte mp4 08.07.2008 | 01:00
      Martin   Návštevník
      Stiahni si kodek xine-faad a nainštaluj si ho, ak ho ešte nemáš, potom by to malo frčať, ale len v Xine a v Kaffeine (ktorý používa Xine).
      • Re: Nejde zvuk na formáte mp4 09.07.2008 | 23:04
        Avatar matusroman Mandriva 2008  Používateľ
        No tak na asi 20 ty pokus sa mi to podarilo. Inštaláciou tothto balíčka xine-faad-1.1.12-1plf2008.0.i586.rpm

        Ďakujem Vám všetkým za pomoc.
        • Re: Nejde zvuk na formáte mp4 10.07.2008 | 00:35
          Martin   Návštevník
          A ešte si v Asociáciách súborov nastav predvoľbu otvárať mp4-ky pomocou Kaffeine a budeš mať všetko ako má byť.
          • Re: Nejde zvuk na formáte mp4 10.07.2008 | 09:56
            Avatar matusroman Mandriva 2008  Používateľ
            No to ani nemusím lebo všetko je asociované pod kaffeine. Už som chcel niečo zmeniť pod vlc, ale nebralo to do úvahy zmeny asociacie. Tak potom som odinštaloval kaffeine. Po odinštalovaní mi dalo možnosť asociovať súbory pod iný program. No a potom som zase nainštaloval kaffeine a od ftedy si otvára súbory ako ho napadne. Už sa mi stalo aj to, že mi rovnaký film otvorilo raz v kaffeine a pri druhom spustení zase vo vlc :) Tak teraz otváram cez opačnú klávesu myšky a výberom podľa potreby. Inak povedané, zmieril som sa s tým.
            • Re: Nejde zvuk na formáte mp4 10.07.2008 | 20:52
              WlaSaTy   Návštevník
              grep video /etc/mime.types
              grep video /etc/mailcap

              aspon myslim, ja nemam kde.