/home

Sekcia: Aplikácie & Desktop 30.03.2009 | 14:42
Avatar new Linux Mint 6  Používateľ
Mam taký zvláštny problém a to je že mi zmizlo v priečinku /home/user/ všetko neni tam ani Desktop a tak ked ulozim nieco na plochu tak sa objavi aj tam akoby /home/user bolo priamo /home/desktop. Neviem kde to prestavit a problem mam odkedy som si zhodil raz Xka. Nechem ukladat velke subory na ploche ale priamo v priecinku a napadlo ma vytvorit priecino hned v /home ako
/home/videos
/home/desktop

Ale to je hlupost a hlavne koli pravam...
    • Re: /home 30.03.2009 | 16:31
      Peter S.   Návštevník
      nemal si do /home/user/ pripojenú osobitnú partíciu? Môže byť, že ju momentálne pripojenú nemáš?
      predtým aj potom pracuješ prihlasený pod rovnakým užívateľom?
      • Re: /home 30.03.2009 | 17:20
        Avatar new Linux Mint 6  Používateľ
        Nie nemal mam vsetko na jednej a pracujem pod tym istym menom, ako root ma svoju vlastnu /home ale nepracujem ako root inac toto je vec ktoru dost neovladam i ked nepouzivam linux prvy den proste /home/user/ videos documents atd zmizla uz je len /home/user a ked aj vytvorim priecinok home/user/desktop tak sa mi len zobrazi na ploche ale neukladaju sa tam veci z plochy ale iba ako do priecinku nechapem ...
        • Re: /home 30.03.2009 | 17:31
          Peter S.   Návštevník
          aby sme neplietli pojmy, domovský adresár pre root je /root, žiadne "/home"
          daj si vypísať:
          cat /etc/passwd
          nájdi si svojho užívateľa a predposledný údaj v riadku je jeho home adresár, mal by to byť /home/user (resp. skutočné meno užívateľa). Over si aj domáci adresár roota...

          inak dosť nejasne ten svoj problém popisuješ

          otvor si konzolu ako root spusti mc a pozri sa do toho /home, ako to tam vyzerá....
          • Re: /home 30.03.2009 | 18:09
            Avatar new Linux Mint 6  Používateľ
            OK
            cat /etc/passwd :

            ....
            litong:x:1000:1000:litong,,,:/home/litong:/bin/bash

            Ked pustim MC a prepnem sa do priecinka tak mi tam ukazuje nainstalovane aplikacie /adobe,/skype..... ako ked dam CTRL -H
            A mam len priecinok /home/litong a to je vse ked sa tam prepnem cd /home/litong a dam dir tak mi to zobrazi veci na ploche cez nautilus tak iste.

            -litong@litong-laptop /root $ dir
            -Desktop
            -litong@litong-laptop /root $ cd Desktop
            -litong@litong-laptop /root/Desktop $ dir
            -litong@litong-laptop /root/Desktop $


            -litong@litong-laptop ~ $ cd /home/litong
            -litong@litong-laptop ~ $ dir
            -litong-laptop ~ $

            ---- neni tu polozka Desktop na ktoru ked kliknem tak sa zobrazia veci na ploche.


            • Re: /home 30.03.2009 | 18:20
              Peter S.   Návštevník
              hm, v prvom rade zabudni na dir, to je len alias, používaj ls a ešte lepšie "ls -a" -to ti vypíše aj skryté súbory a adresáre

              zabudnime na root, ako root by si nemal spúšťať Xka.
              Teda ako užívateľ litong, vidíš na ploche nejaké súbory? (okrem pár ikoniek, ktoré nie sú súbormi v ~/Desktop)
              je možné pravým tlačitkom v gnome zistiť ktorý adresár sa zobrazuje na ploche?
              čo takto adresár ~/Desktop pridať (normalne ho vytvoriť), a reštartovať X-ka....
              prípadne pridaj do neho cez nautilus nejaký súbor, reštartuj Xka a uvidíš či ho uvidíš na ploche...

              Este jedna nepočitáčova rada, skús používať viac čiarok a bodiek, na správnych miestach, samozrejme. Zlepší to chápateľnosť tvojho textu...
              • Re: /home 30.03.2009 | 19:06
                Avatar new Linux Mint 6  Používateľ
                Na ploche mam subory, ktore som stiahol alebo tam dal a priecinok System a Home, Ked kliknem na Home tak mi zobrazi tie iste subory, co mam na ploche (bez System a Home) a ked vytvorim priecinok Desktop a vlozim donho nieco tak sa nezobrazi na ploche, ale je v priecinku Desktop na ploche. Ked : mkdir /home/litong/Desktop tak sa mi len vytvori priecinok na ploche s menom Desktop ako obycajny priecinok. A ked kliknem na plochu a dam vytvorit priecinok tak sa vytvori aj v adresari /home/litong.

                sorry za pisanie:D
                • Re: /home 30.03.2009 | 20:01
                  Peter S.   Návštevník
                  Tak co je vlastne problem? Na ploche sa ti zobrazuje /home/litting/, ak chces prestav si to na /home/littong/Desktop/....
                  • Re: /home 30.03.2009 | 20:11
                    Avatar new Linux Mint 6  Používateľ
                    No dobre ale potom to cele posuniem a kazda polozka bude v /home ako user nie? Videa etc, ked premenujem litong na desktop? Nikde sa to neda nastavit?
                    • Re: /home 30.03.2009 | 20:25
                      Avatar new Linux Mint 6  Používateľ
                      Chcem to dat do povodneho stavu proste cd /home/litong/desktop neexistuje aj ked kliknem priamo z gnomackeho menu to znamena ze sa to musi dat nejako prestavit nejaky config subor, alebo nieco take predsa musi byt aby sa plocha-mountla na urcity priecinok.
    • Re: /home 30.03.2009 | 20:52
      Avatar qw11 ubuntu 16.04 64bit Asus X751LB  Používateľ
      Prepacte ale necital som to tu cele tak ak sa tento postup uz preberal tak ma nebite. :-)
      Alt+F2 gconf-editor
      apps, nautilus, preferences
      vpravo polozka
      desktop_is_home_dir, zrusit zafajknutie

      popis
      Ak je nastavené na true, Nautilus bude používať domovský priečinok používateľa ako pracovnú plochu. Ak je to false, použije sa ~/Desktop ako pracovná plocha.
      • Re: /home 30.03.2009 | 21:03
        Avatar new Linux Mint 6  Používateľ
        Uz som to vygooglil konecne :D ano to bolo nastavene dobre ale toto nie :

        sudo gedit ~/.config/user-dirs.dirs

        # This file is written by xdg-user-dirs-update
        # If you want to change or add directories, just edit the line you're
        # interested in. All local changes will be retained on the next run
        # Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
        # homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
        # absolute path. No other format is supported.
        #
        XDG_DESKTOP_DIR="$HOME/" - a sem dopisat /Desktop
        XDG_DOWNLOAD_DIR="$HOME/"
        XDG_DOCUMENTS_DIR="$HOME/"
        XDG_MUSIC_DIR="$HOME/"
        XDG_PICTURES_DIR="$HOME/"
        XDG_PROJECTS_DIR="$HOME/"
        XDG_VIDEOS_DIR="$HOME/"

        ulozit a do terminalu :

        xdg-user-dirs-update

        a logout-login a je to, fuh skaredy google a este ja skaredsi, ze som mu to nevedel vysvetlit ze co chcem :D

        http://ubuntuforums.org/showthread.php?t=554132
        http://ubuntuforums.org/showthread.php?t=581498