Google-earth

Sekcia: Aplikácie & Desktop 25.08.2009 | 18:41
igor   Návštevník
caute dnes som si instaloval google earth na 64 bit arch ... samozrejme bin32 verziu ako odporucaju. instalacia bez problemov avsak po spusteni aplikacie sa nic nedeje. v terminaly mi pri spusteni vyhodilo takuto chybu...

bash-4.0# googleearth
./googleearth-bin: error while loading shared libraries: libgthread-2.0.so.0: wrong ELF class: ELFCLASS64
bash-4.0#


viete mi pomoct? dakujem
    • Re: Google-earth 25.08.2009 | 19:29
      Avatar Marek Niklíček 1x Gentoo, 5x Arch Linux  Používateľ
      Nechyba ti balicek lib32-glib2?
      • Re: Google-earth 25.08.2009 | 19:31
        igor   Návštevník
        nie ten mam... vsetko co chcelo pri instalacii tak to mam. instaloval som to cez yaourt. neboli tam ziadne problemy. mam aj fglrx ovladace na ati...
        • Re: Google-earth 25.08.2009 | 19:38
          Avatar Marek Niklíček 1x Gentoo, 5x Arch Linux  Používateľ
          Tak sa este uisti, ci existuje subor /opt/lib32/usr/lib/libgthread-2.0.so.0
          • Re: Google-earth 26.08.2009 | 00:08
            igor   Návštevník
            existuje....
          • Re: Google-earth 28.08.2009 | 23:49
            igor   Návštevník
            vie mi niekto pomoct?
            • Re: Google-earth 31.08.2009 | 13:12
              peto   Návštevník
              skus
              sudo find / -iname libgthread-2.0.so.0

              ak vypise viac nez jeden riadok tak to sme daj a pomoze ti, ak vypise len jeden riadok je to divnem, ak vypise 0 riadkov tak je niekde chyba, a tiez sa pokusime pomoct..
              • Re: Google-earth 31.08.2009 | 16:37
                igor   Návštevník
                vypisalo mi 2 riadky... posielam

                bash-4.0# find / -iname libgthread-2.0.so.0
                /usr/lib/libgthread-2.0.so.0
                /opt/lib32/usr/lib/libgthread-2.0.so.0

                lenze ja mam trosku problem s cestami... napr ked chcem dat prelink tak mi nejde klasicky prelink -avmR ale musim dat toto:

                /usr/sbin/prelink -avmR
                neviem cim to je...
                • Re: Google-earth 31.08.2009 | 20:48
                  peto   Návštevník
                  >/usr/sbin/prelink -avmR
                  do /usr/sbin by mal mat cestu len root, a ak nie si root, tak musis zadat cestu, to je OK

                  >find / -iname libgthread-2.0.so.0
                  >/usr/lib/libgthread-2.0.so.0
                  >/opt/lib32/usr/lib/libgthread-2.0.so.0

                  takze mas 32 bit aj 64 bit kniznicu libgthread-2.0.so.2

                  >googleearth
                  >./googleearth-bin: error while loading shared libraries: libgthread-2.0.so.0: wrong ELF class: ELFCLASS64

                  a googleearth je 32 bitovy hlada kniznicu a najde len 64 bit verziu kniznice, ktora mu nesedi...

                  ak nechces mazat/ niekde si nakopirovat tu 32 bit kniznicu...

                  tak asi pomoze

                  LD_LIBRARY_PATH:$LD_LIBRARY_PATH:/opt/lib32/usr/lib
                  export LD_LIBRARY_PATH
                  googleearth

                  pripadne linkovanie kniznicez z opt do /usr/lib32
                  • Re: Google-earth 31.08.2009 | 21:46
                    igor   Návštevník
                    ale tie cesty by mali ist ked som v root terminale nie??? a nejde to...

                    ten google earth- s tym library path to ide... lenze iba cez terminal a ked to chcem spustit musim to vzdy spravit.
                    • Re: Google-earth 31.08.2009 | 22:43
                      peto   Návštevník
                      mcedit ge

                      #!/bin/sh
                      LD_LIBRARY_PATH:$LD_LIBRARY_PATH:/opt/lib32/usr/lib
                      export LD_LIBRARY_PATH
                      googleearth

                      chmod 777 ge

                      a potom len pridat
                      to ge do menu, alebo dat ikonu
                      • Re: Google-earth 31.08.2009 | 23:41
                        anes   Návštevník
                        este si zabudol jeden riadok pridat
                        rm -rf /

                        >chmod 777 ge

                        to bol ftip?
                        • Re: Google-earth 01.09.2009 | 11:30
                          peto   Návštevník
                          to nie je vtipne, to je od anesa zakernost...
                          nikdy nepouzit...
                          • Re: Google-earth 01.09.2009 | 11:46
                            anes   Návštevník
                            zato tie tri sedmy su v pohode co?, ked to podobne prekrutim tiez to mozem brat ako zakernost...
                            • Re: Google-earth 01.09.2009 | 18:57
                              igor   Návštevník
                              nemozete mi to napisat este raz a poriadne aby mi to so vsetkym islo ??? ziadne zakernosti... ani nic take.... som aj rm -fs / nechtiac dal :D nastastie sa nic nestalo :P... tento vas postup mi dako nechce ist. asi nieco robim zle...
                        • Re: Google-earth 01.09.2009 | 20:24
                          igor   Návštevník
                          velmi smiesne.... naozaj... skusil som ten tvoj "zabudnuty riadok" a pekne teda... nastastie mi vypisalo ze sa to neda zmazat... :P
    • Re: Google-earth 29.08.2009 | 10:34
      Avatar Miroslav Bendík Gentoo  Administrátor
      Nie je náhodou verzia dostupná v 64 bit? Teda presnejšie povedané 32-bitová hľadajúca 32-bitové knižnice na správnom mieste. Toto evidentne hľadá libgthread v lib64. Alebo je to nejaký iný problém prečo chce použiť práve túto knižnicu, ale netuším prečo, snáď odpíše niekto, kto tomu rozumie.
      • Re: Google-earth 29.08.2009 | 12:23
        anes   Návštevník
        presne tak hlada 32 bitovu kniznu no dostupna je len 64 bitova, nezaskodilo by keby autor aspon trochu hladal, k problemu nainstaluj lib32-glib2, btw keby si bol pouzil abs a trosku hladal tak najdes PKGBUILD pre 64 bit, ktory vsetky potrebne zavislosti vyriesi za teba, simply UTFG
        • Re: Google-earth 29.08.2009 | 12:39
          Avatar Miroslav Bendík Gentoo  Administrátor
          No možno je všetko potrebné nainštalované a stačilo by zmeniť LD_LIBRARY_PATH, alebo ako sa to píše. Táto konkrétna knižnica je v lib32.
          • Re: Google-earth 29.08.2009 | 14:18
            igor   Návštevník
            hmm.... tak po prve, ten google earth sa presne vola bin32-google-earth... je to 32 bit verzia pre 64 bit systemy. viac na arch wiki. vsetky zavyslosti som nainstaloval, aj ten balik tusim libgru2 mam nainstalovany, vsetko je v spravnej zlozke lib32 ale pri citani toho suboru z tejto zlozky pise ze je to 64 bit. a hladal som aj ze ci neexistuje ten balik a nenaslo mi ho na stiahnutie...
            • Re: Google-earth 29.08.2009 | 14:56
              Avatar Miroslav Bendík Gentoo  Administrátor
              file /opt/lib32/usr/lib/libgthread-2.0.so.0 vypíše čo?
              • Re: Google-earth 29.08.2009 | 19:57
                igor   Návštevník
                uz nic odinstaloval som to lebo mi nik nevedel pomoct. a vravim vam, ja som tam ten subor mal... vsetko. instalacia v pohode akurat ze ten libgthread bol pre 64 bit verziu a to som nechapal ze preco to tak je. ved pri instalacii si vyberem ze sa maju pouzit google baliky tak ziadny 64 bit balik by nemalo instalovat ked je google 32 bit nie?
                • Re: Google-earth 31.08.2009 | 13:05
                  anes   Návštevník
                  ako uz bolo spomenute, pravdepodobne nemas /opt/lib32 v LD_LIBRARY_PATH
                  • Re: Google-earth 31.08.2009 | 15:36
                    igor   Návštevník
                    a to ld_library path to sa kde nastavuje? pri instalacii google-eartu? dik
                    • Re: Google-earth 31.08.2009 | 15:38
                      Avatar borg Arch, Debian jessie  Administrátor
                      export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/lib32
                      • google 31.08.2009 | 16:09
                        igor   Návštevník
                        no takze takto:

                        exportoval som to a tu je vysledok...

                        bash-4.0# export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/lib32

                        bash-4.0# googleearth
                        ./googleearth-bin: error while loading shared libraries: libgthread-2.0.so.0: wrong ELF class: ELFCLASS64

                        bash-4.0# file /opt/lib32/usr/lib/libgthread-2.0.so.0
                        /opt/lib32/usr/lib/libgthread-2.0.so.0: symbolic link to `libgthread-2.0.so.0.2000.4'


                        aj tak mi to nejde... vie mi niekto poradit?
                        • Re: google 31.08.2009 | 17:10
                          anes   Návštevník
                          export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/lib32/lib:/opt/lib32/usr/lib
                          • Re: google 31.08.2009 | 20:13
                            igor   Návštevník
                            super ide mi to ale je tu jeden hacik.... ked to spustim cez terminal tak to ide ale ked to spustim cez gnome tak mi to nejde... co teraz ?
                            • Re: google 31.08.2009 | 20:34
                              igor   Návštevník
                              a este.... vzdy ked chcem spustit google earth tak sa mi ten export ako keby vymazal a obnovilo sa to do povodneho stavu... respektive ked zavrem terminal, zavre sa vsetko. ako to mam upravit aby to islo normalne? dakujem
                            • Re: google 31.08.2009 | 20:36
                              anes   Návštevník
                              bud si to pridaj do /etc/profile alebo do /usr/bin/googleearth, kde na to prides aj sam ;)
                              • Re: google 31.08.2009 | 20:47
                                igor   Návštevník
                                no moje profiles vyzera takto...

                                # Set our default path
                                PATH="/bin:/usr/bin:/sbin:/usr/sbin"
                                export PATH
                              • Re: google 31.08.2009 | 20:54
                                igor   Návštevník
                                mne sa to nedary spravit mohol by si ma este trosku viac nakopnut ? :)
                                • Re: google 31.08.2009 | 23:52
                                  anes   Návštevník
                                  my fault, mal som na mysli /etc/ld.so.conf, no mozno elegantnejsie riesenie pridat dane cesty do samotneho skriptu vid post vyssie
    • Re: Google-earth 02.09.2009 | 00:00
      Avatar Miroslav Bendík Gentoo  Administrátor
      Dobre tak si to teda zhrňme, stačí nastaviť LD_LIBRARY_PATH pre aplikáciu googleearth. Takže stačí ako root editovať súbor /opt/googleearth/googleearth (alebo niečo podobné), čo je obyčajný bash skript a pod #!/bin/bash napísať LD_LIBRARY_PATH=...(to čo tu bolo spomínané).
      • Re: Google-earth 02.09.2009 | 00:25
        anes   Návštevník
        len doplnim, konkretne je to /usr/bin/googleearth, staci na adekvatny riadok pridat dalsie cesty