virtualhost

Sekcia: Konfigurácia 19.09.2009 | 11:50
Avatar zr3zo Arch Linux  Používateľ
Ahojte
snazim sa si na localnom serveri nakonfigurovat moj prvy virtualhost. Len vzdy ked zadam tu adresu(www.test.sk), ktoru som nastavil tak ma presmeruje do documentroot /srv/http. teda do toho co je nastaveny ako hlavny pre localhost.
<VirtualHost *:80>
ServerAdmin michal@test.sk
DocumentRoot "/home/michal/public_html/www.test.sk"
ServerName www.test.sk
ErrorLog "/home/michal/public_html/www.test.sk"
CustomLog "/home/michal/public_html/www.test.sk" common
</VirtualHost>

vedel by mi niekto s tym poradit?
vopred dik
zrezo@jabbim.sk
    • Re: virtualhost 19.09.2009 | 14:34
      Avatar DjBass Debian  Používateľ
      Vytvor si v /home/michal/public_html/www.test.sk/ zložky web a logs. Do web nahraj web, ktorý chceš, aby sa ti zobrazoval a do logs sa ti budú ukladať logy...

      NameVirtualHost test.sk:80
      <VirtualHost test.sk:80 >
      ServerAdmin michal@test.sk
      ServerName www.test.sk
      ServerAlias test.sk
      DirectoryIndex index.html index.php
      DocumentRoot /home/michal/public_html/www.test.sk/www/
      ErrorLog /home/michal/public_html/www.test.sk/logs/
      CustomLog /home/michal/public_html/www.test.sk/logs/ combined
      </VirtualHost>
      • Re: virtualhost 19.09.2009 | 17:24
        Avatar zr3zo Arch Linux  Používateľ
        akosi to stale skoci do hlavneho documentroot co je nastaveny na localhost teda do /srv/http
        zrezo@jabbim.sk
        • Re: virtualhost 19.09.2009 | 21:06
          Avatar DjBass Debian  Používateľ
          Ten súbor si vytvoril v /etc/apache2/sites-available/ a potom na neho vytvoril odkaz v /etc/apache2/sites-enabled/ ??
          • Re: virtualhost 19.09.2009 | 22:20
            Avatar Milan Dvorský debian,mint kde,android  Administrátor
            najprv to musi ist do sites-enabled/000-default , odtial si to berie aj sites-available ... po dalsie, NameVirtualHost test.sk:80 musis mat nastaveny aj na www.test.sk:80
      • Re: virtualhost 19.09.2009 | 22:44
        Avatar Lukáš Staňa Arch, CentOS, Debian  Používateľ
        Hovoríš, aby si urobil adresár web a v konfigu sa odkazuješ na www :)

        Správna konfigurácia je:
        NameVirtualHost *:80
        <VirtualHost *:80 >
        ServerAdmin michal@test.sk
        ServerName test.sk
        ServerAlias www.test.sk
        DirectoryIndex index.html index.php
        DocumentRoot /home/michal/public_html/www.test.sk/web/
        ErrorLog /home/michal/public_html/www.test.sk/logs/www.test.sk-error.log
        CustomLog /home/michal/public_html/www.test.sk/logs/www.test.sk-access.log combined
        </VirtualHost>

        Podstatné sú tieto veci:
        1. Konfigurák musí byť v /etc/apache2/sites-available a musí na neho viesť symlink v /etc/apache2/sites-enabled
        2. Musíš mať správny DNS záznam pre test.sk ... Možno postačí aj v /etc/hosts, ak ti to beží v nejakom home-made testovacom labe alebo na localhoste. Pretože NameVirtualHost je založený na tom, čo ti pošle prehliadač v HTTP hlavičke Host
        3. Odporúčam nastaviť na adresár /home/michal/public_html/www.test.sk/ vlastníka a skupinu www-data
        Tu to naozaj nemá ani kultúru ani úroveň
        • Re: virtualhost 19.09.2009 | 22:45
          Avatar Lukáš Staňa Arch, CentOS, Debian  Používateľ
          4. A samozrejme reloadnuť/reštartovať Apache :)
          Tu to naozaj nemá ani kultúru ani úroveň
          • Re: virtualhost 20.09.2009 | 00:22
            Avatar zr3zo Arch Linux  Používateľ
            zaznam mám v /etc/httpd/conf/extra/httpd-vhosts.conf ,ktorý je vlastne linknuty do /etc/httpd/conf/http.conf, adresare /etc/apache2/sites-available/ a /etc/apache2/sites-enabled/ ani nemam :-)

            zaznam v hosts vytvoreny mam a aj funguje, len po zadani www.test.sk ma presmeruje do zleho priecinku

            som si isty, ze mam cosi zle nstavene len neviem co :-P
            zrezo@jabbim.sk