nejde ati grafika na ubuntu 9.04

Sekcia: Aplikácie & Desktop 03.11.2009 | 13:42
krcho   Návštevník
Ahojte, prave som nainstaloval ubuntu 9.04. po instalacii mi system nabieha ale potom vyhodi hlasku ze musi prihlasit do zachraneho modu lebo mam zle nastavenu grafiku, bno ked si vypisem grafiku, vsetko mi ide v pohode...v zachrannom mode nejde rozlisenie. mam ati radeon 9200, vobec si neviem rady. v ubuntu 8.10 mi to slo vsetko v pohode. ak nainstalujem 9.10 i tam to ide len ta sa mi zda pomala, preto by som chcel nahodit 9.04. uz raz som ju na pc mal no to uz bolo davnejsie. doteraz som mal debian ale i tam mi zacala blbnut grafika. momentalne nemam cas a chut sa hrat s vyladovanim debianu preto som si chcel nahodit ubuntu a hla mame tu chybu. neviete mi pomoct? ak idem cez aptitude remove xserver-xorg-fglrx tak mi vypise ze vsetko prebehlo v poriadku no stale to je nainstalovane. nevie mi niekto pomoct? alebo mi poradte ako vyladit debian aby mi tam slapala ati radeonka 9200 lebo mi zacal ist hrozne pomaly a mam podozrenie ze prave kvoli grafike, lebo okna sa mi strasne pomaly vykreslovali
    • Re: nejde ati grafika na ubuntu 9.04 03.11.2009 | 14:50
      Avatar Tomáš Hanzel Vždy tá pravá  Používateľ
      no ked si vypisem grafiku, vsetko mi ide v pohode.
      Na to si ako prišiel?

      Podla tvojho popisu "problému" by som povedal, že máš zapnuté efekty bez potrebnej grafickej akcelerácie (radeonhd, oficialny ati driver).

      Pozrel by som sa po oficiálnych stránkach ATI.amd.com, vyhľadal driver pre Linux, stiahol potrebné balíčky pre úspešnú kompiláciu modulu fxlrx a po reštarte by si mal mať problém vyriešený.

      Ale aby som nemúdroval, pozri si z výpisu lsmod natiahnutie modulu fglrx, aby sme nerobili to isté dva krát.
      lsmod │grep fglrx k tomu výpis o FPS vďaka cube.

      Potom sa možno posunieme ďalej.
      Close the Windows Open The Source
      • Re: nejde ati grafika na ubuntu 9.04 04.11.2009 | 21:23
        krcho   Návštevník
        no po zadani

        glxinfo | grep direct

        mam vypis

        direct rendering: Yes

        potom ked nahodim

        glxgears

        tak mi normalne nahodi tie ozubenekol ale vypis mam takyto

        XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":1.0"
        after 353 requests (38 known processed) with 0 events remaining.

        kto mi moze pomoct???