Nefunguje wifi - Broadcom

Sekcia: Aplikácie & Desktop 17.01.2010 | 01:31
Avatar Dare_devil Debian, OpenSuse  Používateľ
Dobry. Po tyzdnovej namahe sa obraciam na vas s prosbou o pomoc..

Moja wifi ( 04:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01) ) nechce nastartovat.. Skusal som uz ndiswrapper - vtedy bolo sice wlan0 vytvorene ale nedalo sa zapnut, nepodporovalo skenovanie.. b43 a b43-fwcutter..

Momentalne mam podla Arch wiki zavedeny b43 no vzdy ked dam ifconfig wlan0 up, zacne pc ( aj v tty1 .. ) brutalne sekat, proste sa neda takmer ani pisat.. ked nasledne wlan0 downem a pozriem sa na dmesg, na jeho konci je toto:

eth0: no IPv6 routers present
b43 ssb0:0: firmware: requesting b43/ucode15.fw
b43 ssb0:0: firmware: requesting b43/lp0initvals15.fw
b43 ssb0:0: firmware: requesting b43/lp0bsinitvals15.fw
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
b43-phy0: Controller RESET (DMA error) ...
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Controller restarted
ADDRCONF(NETDEV_UP): wlan0: link is not ready
b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
b43-phy0: Controller RESET (DMA error) ...
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Controller restarted
b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000,R 0x00000000, 0x00000000, 0x00000000
b43-phy0: Controller RESET (DMA error) ...
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)


Neviete co s tym? Ja uz som zufaly a wifi potrebujem.

Niekedy sa stavalo aj to, ze jednoducho som sa na wifi napojil - na 5 minut, a potom mi vsetko zacalo strasne sekat od zatazenia CPU, tak som downol wlan0 a mal to iste vypisane co som tu postol.. Pritom som nic nerobil,bol na pidgine a uzival si tu chvilku kym mi wifi sla..

Dakujem za akukolvek pomoc.
There is no flag large enough to cover the shame of killing innocent people
    • Re: Nefunguje wifi - Broadcom 17.01.2010 | 11:55
      Avatar Branislav Poldauf Ubuntu LTS, Debian stable  Používateľ
      netusim ci to ma suvis ale mne stary desktop zacal podobne lagovat ked som donho zapojil sietovy kabel
      ale tty1 vypisovala nejake cuden cisla (strasne rychlo sa pripocitavali)

      zistil som ze doska bola poskodena a ked som tam dal dalsiu lan kartu do pci slotu tak ani netukla (ani windows ani linux)

      ALE raz za pol roka sa to rozbehlo a niekolko dni to slo a potom znovu
      musel som pouzivat USB modem na internet (hrozne len spomenut)

      z toho vyplyva → nebude to HW chyba ??
      Linux: the operating system with a CLUE... Command Line User Environment
      • Re: Nefunguje wifi - Broadcom 17.01.2010 | 13:39
        Avatar Dare_devil Debian, OpenSuse  Používateľ
        HW Chyba to podla mna nemoze byt. NTB mam od oktobra.. Pouzival som na nom sabayon, ubuntu, fedoru a aj arch. Vzdy ta wifi karta sla a nebol vobec problem rozbehat ju. :(
        There is no flag large enough to cover the shame of killing innocent people
        • Re: Nefunguje wifi - Broadcom 17.01.2010 | 19:33
          Avatar Oliver Roch Ubuntu, Debian, Elive, XP  Používateľ
          Mne na ubuntu tiez sla wifi cez ndiswrapper a ked som hodil debian tak nesla a musel som to urobit inak.
    • Re: Nefunguje wifi - Broadcom 17.01.2010 | 20:12
      l_barbarossa   Návštevník
      ERROR: Fatal DMA error - ak je hw v poriadku, este stale moze byt v hw konflikte, neviem ...

      nie su na broadcomy uz nejake dalsie ovladace (ine nez bcm43 a b43)?
      • Re: Nefunguje wifi - Broadcom 17.01.2010 | 20:38
        Avatar Dare_devil Debian, OpenSuse  Používateľ
        ndiswrapper jedine :( a s tym to nejako neslo :( Ale nechapem to ze v novembri mi na tom istom notebooku s tym istym distrom -archom este wifi sla.. Sla mi este aj pred par dnami, s fedorou
        There is no flag large enough to cover the shame of killing innocent people
        • Re: Nefunguje wifi - Broadcom 17.01.2010 | 22:54
          WlaSaTy   Návštevník
          Chlapi, a co firmware. Nemohla to byt ina verzia ?
          • Re: Nefunguje wifi - Broadcom 17.01.2010 | 23:04
            l_barbarossa   Návštevník
            mohla, ale predpokladam, ze pouzil tu istu, co pred casom, ked mu to este islo v pohode
            • Re: Nefunguje wifi - Broadcom 17.01.2010 | 23:52
              WlaSaTy   Návštevník
              Mohol by, ale mozne je aj to ze ten co ma na disku sa poskodil.
              • Re: Nefunguje wifi - Broadcom 18.01.2010 | 17:55
                l_barbarossa   Návštevník
                :-))
      • Re: Nefunguje wifi - Broadcom 17.01.2010 | 22:43
        Avatar Dušan Ďurech Debian Lenny 5.0  Používateľ
        >nie su na broadcomy uz nejake dalsie ovladace (ine nez bcm43 a b43)?

        Ano su. Existuju oficialne ovladace od Broadcomu: http://www.broadcom.com/support/802.11/linux_sta.php
        • Re: Nefunguje wifi - Broadcom 17.01.2010 | 23:06
          l_barbarossa   Návštevník
          +1
        • Re: Nefunguje wifi - Broadcom 18.01.2010 | 00:29
          Avatar Dare_devil Debian, OpenSuse  Používateľ
          WTF? To iste som podla arch wiki ( hned prva cast , get the driver na http://wiki.archlinux.org/index.php/Broadcom_BCM4312 ) robil...

          Teraz som to rozbalil prekompiloval, modprobol wl , zapol wicd deamon a client a ide to :(

          Nechapem kde bol problem.. Asi niekde medzi stolickou a klavesnicou. Tak prepacte.

          Vdaka velmi pekne za pomoc.
          Temu povazujem za vyriesenu.
          There is no flag large enough to cover the shame of killing innocent people
          • Re: Nefunguje wifi - Broadcom 18.01.2010 | 04:36
            Avatar Dare_devil Debian, OpenSuse  Používateľ
            NIE !!!!!

            po restarte notebooku ( pri novom starte v nom nebol eth. kabel, inak ziadna ina zmena ) som skusil spustit wicd deamon a client, upol wlan0 a ten isty error..

            krista boha co s tym??
            There is no flag large enough to cover the shame of killing innocent people
            • Re: Nefunguje wifi - Broadcom 18.01.2010 | 12:12
              Avatar ninu Slackware, Android  Používateľ
              teraz strelim do prazdna, ale minule som na nejakom fore cital o problemoch s wifinami a u jedneho sa to "vyriesilo" tak, ze vypinal/restartoval notebook so zapnutou wifinou.
              Skus zapnut wifi (myslim len tlacitkom ak mas hardwareove zapinanie) a restartovat ... za pokus to stoji ...
              Slackware
              • Re: Nefunguje wifi - Broadcom 18.01.2010 | 16:56
                Avatar Dare_devil Debian, OpenSuse  Používateľ
                To tlacitko mam stale zapnute :// Nemoze byt chyba v nastaveni mojho rc.conf ?

                Mam tam ohladom networkingu toto :

                #Static IP example
                #eth0="dhcp"
                eth0="dhcp"
                INTERFACES=(eth0)

                # Routes to start at boot-up (in this order)
                # Declare each route then list in ROUTES
                # - prefix an entry in ROUTES with a ! to disable it
                #
                gateway="default gw 192.168.0.1"
                ROUTES=(!gateway)

                There is no flag large enough to cover the shame of killing innocent people
            • Re: Nefunguje wifi - Broadcom 18.01.2010 | 16:49
              l_barbarossa   Návštevník
              pomocou lsmod si zisti, ci nemas sucasne natiahnuty konkurencny driver (b43) a ci mas natiahnuty zelany driver (wl).

              ak plati prvy pripad, tak treba zakazat b43 pri starte (zisti siv ktorom konfiguraku na archu sa to robi, v mdv to je bud /etc/modprobe.conf alebo /etc/modprobe.d/*blacklist*)
              • Re: Nefunguje wifi - Broadcom 18.01.2010 | 17:32
                Avatar Dare_devil Debian, OpenSuse  Používateľ
                Tak uz sa mi to podarilo, no wifi mi nevystupovalo ako wlan0 ale eth0...

                Podla wiki som vytvoril /etc/udev/rules.d/10-network.rules kde som definoval:
                SUBSYSTEM=="net" ATTR{address}=="00:26:82:17:75:f4", NAME="wlan0"
                SUBSYSTEM=="net" ATTR{address}=="00:26:22:06:59:36", NAME="eth0"
                

                Pre ziskanie MAC adresy wlan0 som musel modprobnut b43 a prikazom "udevadm info -a -p /sys/class/net/wlan0 | grep address" to zistit. Do /etc/rc.conf som pridal interface wlan0 a nastavil ho na dhcp.

                Nasledne vsak po reboote ziaden interface wlan0 neexistuje ( b43 a ostatne su zakazane , povoleny je iba wl )

                There is no flag large enough to cover the shame of killing innocent people
                • Re: Nefunguje wifi - Broadcom 18.01.2010 | 17:42
                  Avatar Dare_devil Debian, OpenSuse  Používateľ
                  Hmmm, tak uz to vyzera konecne ze to ide..

                  #!/bin/bash

                  rmmod b43 ssb wl lib80211_crypt_tkip lib80211

                  modprobe lib80211_crypt_tkip
                  modprobe wl

                  depmod -a

                  Momentalne pisem z wifi. Tak snad mi to vydri. Vdaka!
                  There is no flag large enough to cover the shame of killing innocent people