Boze, zlutuj sa!

Sekcia: Aplikácie & Desktop 08.04.2010 | 19:40
Avatar jarmo21   Používateľ
LINUX Mint Helena 8 - stale tomu nechapem!!!! Pomoc!!! Chcem ist do winxp

Myslim, ze tu je vsetko potrebne:

ls -l /dev/disk/by-uuid
celkom 0
lrwxrwxrwx 1 root root 10 2010-04-08 17:08 a5897f50-65f1-4bb4-b3d2-d8fd72074593 -> ../../sdb1
lrwxrwxrwx 1 root root 10 2010-04-08 17:08 DC58250F5824E9CA -> ../../sda6
lrwxrwxrwx 1 root root 10 2010-04-08 17:08 F20C14BF0C1480B1 -> ../../sda1
lrwxrwxrwx 1 root root 10 2010-04-08 17:08 10904ADE904ACA44 -> ../../sda7
lrwxrwxrwx 1 root root 10 2010-04-08 17:08 42F0FFA0F0FF987D -> ../../sda5
lrwxrwxrwx 1 root root 10 2010-04-08 17:08 6319d1e1-574c-4166-a186-e4d31b349542 -> ../../sdb6
lrwxrwxrwx 1 root root 10 2010-04-08 17:08 7fee17bb-93f5-46ce-8ff4-b3200667977c -> ../../sdb5

sudo blkid
[sudo] password for jarmo:
/dev/sda1: UUID="F20C14BF0C1480B1" LABEL="XP" TYPE="ntfs"
/dev/sda5: UUID="42F0FFA0F0FF987D" LABEL="GAMES" TYPE="ntfs"
/dev/sda6: UUID="DC58250F5824E9CA" LABEL="STORAGE" TYPE="ntfs"
/dev/sda7: UUID="10904ADE904ACA44" LABEL="DOWNLOADS" TYPE="ntfs"
/dev/sdb1: UUID="a5897f50-65f1-4bb4-b3d2-d8fd72074593" TYPE="ext4"
/dev/sdb5: UUID="7fee17bb-93f5-46ce-8ff4-b3200667977c" TYPE="ext4"
/dev/sdb6: UUID="6319d1e1-574c-4166-a186-e4d31b349542" TYPE="swap"

Mam 2 disky, ako ste si vsimli a
grub by mal byt v Mbr hd0, ale napise len statring GRUb a uz ide linux.
Tu je menu.lst

# sample /boot/grub/menu.lst entry for memtest86
#
# This example assumes the contents of /boot is on the root partition.
# If your /boot is on its own partition, remove /boot from the 'kernel' line.

title memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin

title memtest86+ (serial console 115200)
root (hd0,0)
kernel /boot/memtest86+.bin console=ttyS0,115200n8


Uz som tam skusal vselico co som len nasiel, aby ste si nemysleli, ze cakam len na hotovu odpoved, iba tusim nieco, ale stale mi chyba cosi. Vopred dakujem!


    • Re: Boze, zlutuj sa! 08.04.2010 | 20:09
      Avatar dodoedo Fedora Linux  Používateľ
      Ahoj.

      Najprv pomaly ...

      Nemôžeš si v Grub vybrať boot do WinXP ?
      G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
    • Re: Boze, zlutuj sa! 08.04.2010 | 20:19
      Avatar usamec   Používateľ
      boze zlutuj sa nad nami inteligentnymi bytostami a daj nam silnu neprerazit tych, co ani rozumny nadpis topicu nevedia napisat...

      btw vycuc z mojho grub.conf:

      title Other
      rootnoverify (hd0,1)
      chainloader +1

      pricom ale winparticiu mam na sda2
      • Re: Boze, zlutuj sa! 08.04.2010 | 23:29
        Avatar marian25 PCLinuxOS, Minime...LINUX  Používateľ
        Takže v prípade nášho zúfalca by to malo byť:


        title Zmiluj sa nad Win XP
        rootnoverify (hd0,0)
        chainloader +1
      • Re: Boze, zlutuj sa! 11.04.2010 | 22:15
        jarmo21   Návštevník
        Tak kde si USAMEC! Inteligent s nekonecnym IQ, co sme pre neho vsetci pri nizko! Teraz rad a bud chytri!!
        • Re: Boze, zlutuj sa! 12.04.2010 | 10:58
          Avatar Michal Nánási Ubuntu 11.04  Používateľ
          A cudujes sa mu? Ak napises zly topic, tak sebe znizujes sancu, ze ti niekto pomoze, lebo nie je jasne, co chces. Naopak sebe zvysujes sancu ze ti niekto vynada, lebo nie si schopny napisat rozumny nadpis. Navyse robis potom bordel v databaze.
          Hi! I'm a .signature virus! Copy me into your ~/.signature to help me spread!
        • Re: Kľud 12.04.2010 | 13:05
          Avatar dodoedo Fedora Linux  Používateľ
          Kľud.

          Nič sa nestalo, došlo k nedorozumeniu, pretože tak, či tak. Grub 2, ktorý používa Tvoj Linux sa edituje trochu ináč, ako ten pôvodný GRUB.

          Už sa Ti zobrazuje to Grub2- menu ?
          :-)
          G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
          • Re: Kľud 12.04.2010 | 16:35
            jarmo21   Návštevník
            Nie, je to stale bez zmeny. Myslim, ze kde si bude nejaky hacik. Isto to bude jednoducha vec...
            • Re: Kľud 12.04.2010 | 19:39
              Avatar dodoedo Fedora Linux  Používateľ
              Ahoj.

              Daj sem teda kompletný výpis obsahu tvojho súboru:
              /etc/default/grub

              otvor si ho cez:
              sudo gedit /etc/default/grub 

              a prekopíruj obsah sem.
              :-)
              G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
              • Re: Kľud 12.04.2010 | 21:00
                jarmo21   Návštevník
                # If you change this file, run 'update-grub' afterwards to update
                # /boot/grub/grub.cfg.

                GRUB_DEFAULT=0
                GRUB_HIDDEN_TIMEOUT=0
                GRUB_HIDDEN_TIMEOUT_QUIET=false
                GRUB_TIMEOUT="15"
                GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
                GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
                GRUB_CMDLINE_LINUX=""

                # Uncomment to disable graphical terminal (grub-pc only)
                #GRUB_TERMINAL=console

                # The resolution used on graphical terminal
                # note that you can use only modes which your graphic card supports via VBE
                # you can see them in real GRUB with the command `vbeinfo'
                #GRUB_GFXMODE=800x600

                # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
                #GRUB_DISABLE_LINUX_UUID=true

                # Uncomment to disable generation of recovery mode menu entrys
                #GRUB_DISABLE_LINUX_RECOVERY="true"

                Toto som sa mi zda zmenil -->GRUB_HIDDEN_TIMEOUT_QUIET=false , lebo som si myslel, ze to pomoze. Bolo tam "true". A este rozlisenie z 640 na 800
                • Re: Kľud 12.04.2010 | 21:46
                  Avatar dodoedo Fedora Linux  Používateľ
                  Ahoj.

                  Naša záhada je vyriešená.

                  Musíš predsa zmeniť hodnotu
                  GRUB_HIDDEN_TIMEOUT=0

                  na hodnotu

                  GRUB_HIDDEN_TIMEOUT=10

                  uložiť zmenu súboru a zavrieť a nikdy nezabudni ! potom spustiť príkaz:
                  sudo update-grub 

                  G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
                  • Re: Kľud 13.04.2010 | 16:51
                    jarmo21   Návštevník
                    No, tak som to vcera zmenil, spustil update a nic. Tak som sa na to vykaslal a dnes som zapol pc a nabehlo menu. Hned som to restartol (este v menu) a bolo tam znova. Potom som isiel do linuxu a hovorim si, ze to este restartnem, ci bude znova. No a tak som restartol a menu sa uz neobjavilo. Tak som pc vypnul a znova zapol a zase nic. Potom som to skusal este dva-tri razy, ale stale nic. Nechapem, ved uz to tam bolo a mal som na vyber 4 moznosti linuxu, a to podla jadra a este memtest86... ale win tam nebol, takze ked vyriesime menu, tak budeme este musiet ten win!
                    • Re: Kľud 13.04.2010 | 17:45
                      jarmo21   Návštevník
                      Tak a teraz to mam! Precital som si "Databaza znalosti" nieco o tom Grube 2 a urobil som nejake dodatocne zmeny. Teraz mi to funguje tak, ze musim stlacat Shift a menu sa zobrazi. No, ale v tom navode je napisane, ze treba, aby bol detekovany aj iny OS, inak sa menu nebude zobrazovat, takze bude tam hacik. Ako to je s mojim podelenim som uz napisal hore, takze teraz ako? A kam to vsetko napisat, ked menu.lst je k nicomu? A grub.cfg je akysi komplikovany..
                      • Re: Kľud 13.04.2010 | 19:42
                        Avatar dodoedo Fedora Linux  Používateľ
                        Skontroluj si, cez príkaz:
                        sudo gedit /etc/grub.d/40_custom

                        či máš naozaj tento text ohľadom WinXP na konci súboru :

                        echo "Adding Windows OS to Grub 2 menu"
                        cat << EOF
                        menuentry "Microsoft Windows XP/Vista/Windows7" {
                        set root=(hd0,1)
                        makeactive
                        chainloader +1
                        }
                        EOF


                        Ak to máš v poriadku, potom ten otvorený súbor ulož a HLAVNE:
                        spusti príkaz:
                        sudo update-grub 

                        Tento príkaz musiš spustiť vždy potom, keď manuálne urobíš akúkoľvek zmenu v GRUB 2 !

                        Reštartuj PC.
                        G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
                      • Re: Kľud 13.04.2010 | 21:50
                        WlaSaTy   Návštevník
                        :No, ale v tom navode je napisane, ze treba, aby bol detekovany aj iny OS, inak sa menu nebude zobrazovat, takze bude tam hacik

                        To je tam naozaj? Tak to by ma zaujímalo že kto to kam písal.

                        Mne totižto grub vypisuje menu a pritom s ním štartujem len single boot linux. Ale to bude tým, že pri štarte nepoužívam utajený časový limit, ale časový limit.
                        • Re: Kľud 13.04.2010 | 23:07
                          Avatar dodoedo Fedora Linux  Používateľ
                          sudo fdisk -l

                          čo ti vypíše?
                          G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
                          • Re: Kľud 13.04.2010 | 23:17
                            WlaSaTy   Návštevník
                            Mne vypíše to, čo má vypísať. Jednu oblasť pre ext4 a jednu pre swap. Rôzne jadrá mám v /boot ktorý je u mňa súčasťou /dev/ROOT priamo.

                            Nechcel si sa opýtať niekoho iného?
                            • Re: Kľud 13.04.2010 | 23:22
                              Avatar dodoedo Fedora Linux  Používateľ
                              Samozrejme.
                              Už sa v tom prestávam orientovať.
                              :-)
                              G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
                          • Re: Kľud 13.04.2010 | 23:47
                            jarmo21   Návštevník
                            jarmo@Honda ~ $ sudo fdisk -l
                            [sudo] password for jarmo:

                            Disk /dev/sda: 250.1 GB, 250059350016 bytes
                            255 heads, 63 sectors/track, 30401 cylinders
                            Units = cylinders of 16065 * 512 = 8225280 bytes
                            Disk identifier: 0x00000001

                            Device Boot Start End Blocks Id System
                            /dev/sda1 * 1 2550 20482843+ 7 HPFS/NTFS
                            /dev/sda2 2551 30401 223713157+ f W95 Ext'd (LBA)
                            /dev/sda5 2551 11474 71681998+ 7 HPFS/NTFS
                            /dev/sda6 11475 20398 71681998+ 7 HPFS/NTFS
                            /dev/sda7 20399 30401 80349066 7 HPFS/NTFS

                            Disk /dev/sdb: 250.1 GB, 250059350016 bytes
                            255 heads, 63 sectors/track, 30401 cylinders
                            Units = cylinders of 16065 * 512 = 8225280 bytes
                            Disk identifier: 0x00010013

                            Device Boot Start End Blocks Id System
                            /dev/sdb1 1 3040 24418768+ 83 Linux
                            /dev/sdb2 3041 6022 23952915 f W95 Ext'd (LBA)
                            /dev/sdb5 3041 5776 21976857 83 Linux
                            /dev/sdb6 5777 6022 1975963+ 82 Linux swap / Solaris


                            A tu je ten fdisk
                        • Re: Kľud 13.04.2010 | 23:20
                          Avatar dodoedo Fedora Linux  Používateľ
                          sudo grub -mkconfig
                          G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
                      • Re: Kľud 13.04.2010 | 23:27
                        Avatar dodoedo Fedora Linux  Používateľ
                        Ahoj, jarmo21.
                        Ako sa mu (PC) bude páčiť príkaz:
                        sudo grub -mkconfig
                        G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
                        • Re: Kľud 13.04.2010 | 23:45
                          jarmo21   Návštevník
                          jarmo@Honda ~ $ sudo grub -mkconfig
                          grub: invalid option -- 'm'
                          Try ``grub --help'' for more information.


                          Napisalo iba toto.
                          • Re: Kľud 14.04.2010 | 00:32
                            Avatar dodoedo Fedora Linux  Používateľ
                            G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
                            • Re: Kľud 14.04.2010 | 16:49
                              jarmo21   Návštevník
                              Vsetko som upravil podla navodu, ale windows sa v grub. cfg neobjavil. Samozrejme som dal update. Kde je teda chyba?
                              Zle som to zapisal? Restart som tym padom neskusal.
                              • Re: Kľud 14.04.2010 | 19:29
                                Avatar dodoedo Fedora Linux  Používateľ
                                Neviem, vyskúšaj reštart PC
                                :-(
                                G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
    • Re: Boze, zlutuj sa! 09.04.2010 | 16:59
      jarmo21   Návštevník
      # sample /boot/grub/menu.lst entry for memtest86
      #
      # This example assumes the contents of /boot is on the root partition.
      # If your /boot is on its own partition, remove /boot from the 'kernel' line.

      title memtest86+
      root (hd0,0)
      kernel /boot/memtest86+.bin

      title memtest86+ (serial console 115200)
      root (hd0,0)
      kernel /boot/memtest86+.bin console=ttyS0,115200n8

      title Zmiluj sa nad Win XP
      rootnoverify (hd0,0)
      chainloader +1

      Tak to som to dal a nic. GRUB loading. --> a potom uz iba linux.

      Chlapci zlati, ja si myslim, ze problem bude v tom, ze mne nedava ani tabulku na vyber OS, ako kedysi ked som mal ubuntu 7.10. Grub som instaloval cez terminal uz predtym, lebo som pobehal pomaly vsetky linuxove fora.
      • Re: Boze, zlutuj sa! 12.04.2010 | 19:26
        Avatar Filip Horňák ArchLinux  Používateľ
        Skus dopisat niekde na zaciatok menu.lst
        TIMOUT 10
    • Re: Boze, zlutuj sa! 09.04.2010 | 17:02
      jarmo21   Návštevník
      dodoedo ahoj

      Presne tak, nemam na vyber nic. Cosi pamatam, ako som uz spominal, tak kedysi ked som mal ubuntu, tak tam mi dalo na vyber "ubuntu 7.10 "a este to iste "ubuntu 7.10 " a nieco za tym "safemode" alebo neviem. Ale teraz len "GRUB loading" a uz bezi linux
      • Re: Boze, zlutuj sa! 09.04.2010 | 17:09
        Avatar dodoedo Fedora Linux  Používateľ
        A keď, hneď po zapnutí PC, rýchlo za sebou stláčaš klávesu SHIFT, tak ani potom Ti Grub nezobrazi na výber boot-menu?
        G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
        • Re: Boze, zlutuj sa! 09.04.2010 | 18:56
          jarmo21   Návštevník
          Pri stlacani Shiftu sa nic nedeje, ale predtym raz hodilo menu, ale nechapem preco znova po restarte uz nie. Tak som cital ten manual (eng som sa neucil) a ten hovori o grub.cfg. Pozrel som ho, ale je tam vela veci. Urobil som to podla toho manualu, no nic sa nedeje, ked z editujem ten subor 40custom a dam ten prikaz aj s tym echo ... atd.
          Iba som sa docital, ze tam kde mam xp je hd(0,1) ako sda1. Co teraz?
          • Re: Boze, zlutuj sa! 09.04.2010 | 20:00
            Avatar milboy Ubuntu so znakom ElementaryOS  Používateľ
            Skús si odtialto stiahnuť iso super grub, napal na cd, nabootuj z neho a spusti si čo chceš... Tu je aj fórum, kde nájdeš aj daľšie odpovede na tvoje otázky.
            skusam vsetko....už stovka distribúcií za tie roky a vedomosti žiadne.. Prečo linux?
          • Re: Boze, zlutuj sa! 09.04.2010 | 20:05
            Avatar dodoedo Fedora Linux  Používateľ
            Skontroluj si, či máš naozaj na konci súboru cez príkaz:
            sudo gedit /etc/grub.d/40_custom
            ten WinXP, t.j.:

            echo "Adding Windows OS to Grub 2 menu"
            cat << EOF
            menuentry "Microsoft Windows XP/Vista/Windows7" {
            set root=(hd0,1)
            makeactive
            chainloader +1
            }
            EOF


            Ak to máš v poriadku, potom ten otvorený súbor ulož a HLAVNE:
            spusti príkaz:
            sudo update-grub 
            Tento príkaz musiš spustiť vždy potom, keď manuálne urobíš akúkoľvek zmenu v GRUB 2 !

            Reštaruj PC.
            G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
            • Re: Boze, zlutuj sa! 09.04.2010 | 21:07
              jarmo21   Návštevník
              #!/bin/sh
              exec tail -n +3 $0
              # This file provides an easy way to add custom menu entries. Simply type the
              # menu entries you want to add after this comment. Be careful not to change
              # the 'exec tail' line above.

              echo "Adding Windows OS to Grub 2 menu"
              cat << EOF
              menuentry "Microsoft Windows XP/Vista/Windows7" {
              set root=(hd0,1)
              makeactive
              chainloader +1
              }
              EOF


              Takto ? Tak som to tam dal, ulozil, zavrel, spustil terminal a dal prikaz na update.

              Searching for GRUB installation directory ... found: /boot/grub
              Searching for default file ... found: /boot/grub/default
              Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
              Searching for splash image ... none found, skipping ...
              Found kernel: /boot/vmlinuz-2.6.31-14-generic
              Found GRUB 2: /boot/grub/core.img
              Found kernel: /boot/memtest86+.bin
              Updating /boot/grub/menu.lst ... done

              Restartoval a nic.
              • Re: Boze, zlutuj sa! 09.04.2010 | 21:12
                Avatar dodoedo Fedora Linux  Používateľ
                Stláčať SHIFT !!!
                G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
              • Re: Boze, zlutuj sa! 09.04.2010 | 21:20
                Avatar dodoedo Fedora Linux  Používateľ
                Q : Ako zmeniť default timeout pre grub menu?

                A :

                1. Spusti príkaz : sudo gedit /etc/default/grub
                2. V súbore vyhľadaj položku pre 'GRUB_TIMEOUT=10'.
                3. Ponechaj alebo zmeň '10' za hocijakú inú hodnotu timeout v sekundách. Napríklad chceš 5 seckônd tak potom 'GRUB_TIMEOUT=5'.
                4. Ulož a zavri súbor a spusti príkaz : sudo update-grub

                Reštartuj PC

                G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
                • Re: Boze, zlutuj sa! 09.04.2010 | 22:20
                  jarmo21   Návštevník
                  # If you change this file, run 'update-grub' afterwards to update
                  # /boot/grub/grub.cfg.

                  GRUB_DEFAULT=0
                  GRUB_HIDDEN_TIMEOUT=0
                  GRUB_HIDDEN_TIMEOUT_QUIET=true
                  GRUB_TIMEOUT="10"
                  GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
                  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
                  GRUB_CMDLINE_LINUX=""

                  # Uncomment to disable graphical terminal (grub-pc only)
                  #GRUB_TERMINAL=console

                  # The resolution used on graphical terminal
                  # note that you can use only modes which your graphic card supports via VBE
                  # you can see them in real GRUB with the command `vbeinfo'
                  #GRUB_GFXMODE=640x480

                  # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
                  #GRUB_DISABLE_LINUX_UUID=true

                  # Uncomment to disable generation of recovery mode menu entrys
                  #GRUB_DISABLE_LINUX_RECOVERY="true"

                  Tak so ho otvoril a ono to tam uz bolo napisane. A ten Shift absolutne nereaguje a stlacal som obidva az kym nebol linux uplne nastartovany! Niekde inde bude chyba. Inac ked som tam mal raz to menu tak bola ver. Grubu 1.97 beta 4.
                  • Re: Boze, zlutuj sa! 09.04.2010 | 22:24
                    Avatar dodoedo Fedora Linux  Používateľ
                    Pomaly a kľudne .

                    Opíš, čo si všetko vykonal s Tvojím PC, keď Ti prestalo dávať výberové GRUB Menu.
                    :-)
                    G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
                    • Re: Boze, zlutuj sa! 09.04.2010 | 23:22
                      jarmo21   Návštevník
                      To menu sa mi stalo len dneska, prvy krat ako mam linux, ale neviem co sa stalo, nic som nezmenil a restartol som ho a hned na to, uz zase po starom. Takze, vsetko co som doteraz spravil, neurobilo ziadne zmeny.
                  • Re: sudo update-grub 09.04.2010 | 22:44
                    Avatar dodoedo Fedora Linux  Používateľ
                    Spustil si tento príkaz?
                    sudo update-grub
                    A reštartoval si PC ?
                    G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
            • Re: Boze, zlutuj sa! 13.04.2010 | 21:31
              jarmo21   Návštevník
              Bohuzial, toto vsetko som urobil, ale ziadnu ponuku na xp, mi nedalo. Je tam v ponuke jadro linuxu + recovery mode a 2x memtest86+. Cosi este nie je v poriadku!? Mohla by to byt adresa disku, to hd(0,1)? Ale to by mi v menu aj tak ukazalo, ci nie? A ako to myslis na konci suboru? Ved staci, aby za tymi vetami hore, uz neboli ziadne prikazy!? Takto to mam:


              #!/bin/sh
              exec tail -n +3 $0
              # This file provides an easy way to add custom menu entries. Simply type the
              # menu entries you want to add after this comment. Be careful not to change
              # the 'exec tail' line above.

              echo "Adding Windows OS to Grub 2 menu"
              cat << EOF
              menuentry "Microsoft Windows XP/Vista/Windows7" {
              set root=(hd0,1)
              makeactive
              chainloader +1
              }
              EOF
      • GRUB 2 09.04.2010 | 17:14
        Avatar dodoedo Fedora Linux  Používateľ
        BTW, nezabúdaj, že Tvoj Linux už používa novší GRUB 2.
        Pozri si napr. http://www.linuxmint.com/wiki/index.php/Grub_2
        Tam si pozri hlavne Otázku:

        Q : How to add windows entry to Grub 2 ?

        :-)
        G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
    • Re: Boze, zlutuj sa! 14.04.2010 | 19:45
      Avatar dodoedo Fedora Linux  Používateľ
      Znova skontroluj:

      Skontroluj si, cez príkaz:
      sudo gedit /etc/grub.d/40_custom
      

      či máš naozaj tento text ohľadom WinXP :

      #!/bin/sh exec tail -n +3 $0 (-)
      # This file is an example on how to add custom entries
      menuentry "Windows XP" {
      insmod chain
      insmod ntfs
      search --fs-uuid --set f20c14bf0c1480b1
      chainloader +1
      }

      Ak to máš v poriadku, potom ten otvorený súbor ulož a HLAVNE:
      spusti príkaz:
      sudo update-grub 

      G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
    • Re: Som rád ... 14.04.2010 | 19:48
      Avatar dodoedo Fedora Linux  Používateľ
      Ahojte.

      Chcem len konštatovať, že som rád, že moja linuxová distribúcia používa chválabohu IBA obyčajný GRUB !
      ;-)
      G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
    • Re: Boze, zlutuj sa! 14.04.2010 | 20:21
      Avatar Branislav Poldauf Ubuntu LTS, Debian stable  Používateľ
      Mna napadlo ci by nepomohlo klikatko ?? skus si nainstalovat program startup-manager nasledne ho pustit a vnom nastavit spravanie grubu,
      ja som to pouzil v debiane po instalacii na stroj kde uz bol win7 a ubuntu, a po instalacii debainu bola v grube len moznost bootovat debian, po spusteni startup-managera mi grub ponukol aj ubuntu aj win7
      Linux: the operating system with a CLUE... Command Line User Environment
      • Re: Boze, zlutuj sa! 14.04.2010 | 23:06
        jarmo21   Návštevník
        Nejde to, to iste ako v Grub menu.
    • Re: Boze, zlutuj sa! 14.04.2010 | 23:28
      Avatar dodoedo Fedora Linux  Používateľ
      Ahoj jarmo21.

      Spýtam sa Ťa jednú zákernú a slizkú otázku, ktorá je tu medzi nami od čias narušených Win registrov a porušených MBR na disku.
      Bolo by veľkou pohromou pre Teba spustiť z už bežiaceho Linuxu Mint v Termináli:
      sudo grub-install
      ??

      Predtým si o tom ale pozri niektoré veci tunaky: http://members.iinet.net/~herman546/p20/GRUB2%20Bash%20Commands.html#grub-install
      Nemáš čo stratiť, podobne ako robotnícka trieda v kapitalizme a preto podľa Marxa-Engelsa je najrevolučnejšia a bla,bla, bla... a môžeš sa stať revolucionárom. Maximálne v prípade neúspechu budeš musieť preinštalovať si Linux Mint nanovo.
      G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
      • Re: Boze, zlutuj sa! 15.04.2010 | 17:33
        jarmo21   Návštevník
        Ked som dal prikaz sudo grub-install -v tak mi napisalo ze mam ver. 0.97! Je mozne, aby som mal dve verzie Grubu? Stary aj novy? Tak som nainstaloval novy a uz mi pise ver. 1.97-beta4. Potom som dal prikaz sudo grub-mkconfig a zacal ako keby vytvarat grub.cfg a na konci napisal chybu:

        ...
        ### BEGIN /etc/grub.d/30_os-prober ###
        ERROR: isw device for volume "Jarmo" broken on /dev/sda in RAID set "isw_bjjfbebgai_Jarmo"
        ERROR: isw: wrong # of devices in RAID set "isw_bjjfbebgai_Jarmo" [1/2] on /dev/sda
        ### END /etc/grub.d/30_os-prober ###

        ### BEGIN /etc/grub.d/40_custom ###
        /etc/grub.d/40_custom: 2: Syntax error: "(" unexpected


        Predtym som mal tie disky v RAIDE, no ale po skusany roznych distribucii linuxu, tak mi jeden uplne rozbil Raid a neslo mi nic. Ledva som zachranil data cez Live cd. Potom som v biose radica zrusil Raid, tak som myslel, ze je to vybavena vec?
        Moze by este tam nejaky problem?
        • Re: Boze, zlutuj sa! 15.04.2010 | 22:31
          Avatar dodoedo Fedora Linux  Používateľ
          Zazálohuj si niekde svoje pracovné súbory a fakticky, preinštaluj si Linux Mint.
          Držím palce.

          :-)
          G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."
          • Re: Boze, zlutuj sa! 21.04.2010 | 21:15
            juro   Návštevník
            skus dat do menu.slt

            ### END DEBIAN AUTOMAGIC KERNELS LIST

            # This is a divider, added to separate the menu items below from the Debian
            # ones.
            title Other operating systems:
            root


            # This entry automatically added by the Debian installer for a non-linux OS
            # on /dev/sda1
            title Microsoft Windows XP Professional
            rootnoverify (hd0,0)
            savedefault
            makeactive
            chainloader +1

            ...
    • Re: Boze, zlutuj sa! 22.04.2010 | 18:28
      Avatar sramo   Používateľ