Terminal

Sekcia: Aplikácie & Desktop 29.05.2010 | 18:26
OSiRiS   Návštevník
Zdravím, mám taký problém s terminálom, aj console, aj gnome-terminal, aj textový terminál, mi nereaguje na šípky, a namiesto ich využitia - teda história príkazov posúvanie kurzora mi na stdout kopíruje escape sekvencie
vyzerá to nejako takto $ ^[[D^[[C^[[A^[[B
neviete ako to fixnút ?
díky.
    • Re: Terminal 29.05.2010 | 19:19
      Avatar Stanislav Hoferek Greenie, Manjaro, Q4OS, Lubuntu  Používateľ
      skus napisat shift+z (to zlikviduje aktualny proces) a skus ci to potom bude fungovat OK
      • Re: Terminal 29.05.2010 | 19:58
        OSiRiS   Návštevník
        ok..vyskúšam..teraz som síce na windows, ale zistil som, že ak napíšem $ bash tak mi zrazu všetko ide..samozrejme, pri opätovnom spustení terminálu, to mám zase dodrbané
        • Re: Terminal 30.05.2010 | 03:21
          Avatar denwerko Ubuntu,Gentoo,Debian  Používateľ
          nespúštaš náhodou len ako terminál sh ? tipol by som že hej ? v gnome-terminal edit -> profile preferences -> title and command (tab)

          tam zaškrtni run a custom command, hod do toho bash...

          ako sa nastuje default terminál pre systém, to poradí možno google
          • Re: Terminal 30.05.2010 | 05:47
            Avatar m4jkl   Používateľ
            v /etc/passwd ma kazdy uzavatel nastavenu cestu k default shellu
    • Re: Terminal 30.05.2010 | 13:57
      WlaSaTy   Návštevník
      v minulom tisícročí sa to riešilo príkazom set -o emacs
      otázkou je čo je to za distribúciu keď tam nemáš štandardne zapnutý bash z tohoto milénia.
      • Re: Terminal 04.06.2010 | 04:21
        OSiRiS   Návštevník
        denwerko : ďakujem, problem solved...
        wlasaty: mám ubuntu 10.04 tak nabudúce bez tých poznámok :)
        • Re: Terminal 04.06.2010 | 14:07
          Avatar denwerko Ubuntu,Gentoo,Debian  Používateľ
          nz, ale predsa si skontroluj ten /etc/passwd ako povedal m4jkl... v 10.04 by to nemalo robiť v default inštalácii