Problem so zvukom

Sekcia: Hardware a Drivery 26.08.2010 | 00:36
Avatar David Ubuntu 10.4  Používateľ
Ahojte. dnes som si nainstaloval greenie. je super,paci sa mi. doteraz som siel na windowse. Vsetko mi ide okrem ZVUKU!!! Mam Sony Vaio VPCEB1E1E. co mam spravit aby som to spojazdnil? dakujem za radu, nechce sa mi prejst naspat na windows.


http://www.upnito.sk/imggal.php?viewGallery=57aa363af6e44c63be5d13424747bf5a

co mam kde nastavit? lebo hocico som tam pretukal , nemam nic stlmene a stale mi nejde ten zvuk. a ked pripojim sluchatka, tak zvuk ide ale strasne potichu. a zvuk mam uplne na 100%.


pri internal audio mam dole ak myslis ten profil: tak off a potom 3x analog stereo xxx. a 2x analog surround .... a pri manhattan hdmi mam off a len digital stereo xxx. to je vsetko.
tu je screen z vstupu aj vystupu:

http://www.upnito.sk/imggal.php?viewGallery=26fa4ffcbfb8cb4d178c64aef5cf13c4


pls pomozte!

Dakujem!
presiel som na Linux, mam ho par dni tak majte so mnou strpenie. Dakujem :)
    • Re: Problem so zvukom 27.08.2010 | 00:58
      Avatar bedňa antiX, Devuan, LegacyIce  Administrátor
      UTFG toto sa preberalo už moc krát.
      Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
      • Re: Problem so zvukom 27.08.2010 | 02:12
        Avatar David Ubuntu 10.4  Používateľ
        hmm. hladal som ale asi nie dobre. ak sa to tu preberalo tak mi hodis pls link tej temy? zatial som uplny noob z linuxu tak pls pomozte. dakujem velmi pekne :)
        presiel som na Linux, mam ho par dni tak majte so mnou strpenie. Dakujem :)
        • Re: Problem so zvukom 27.08.2010 | 09:36
          Avatar bedňa antiX, Devuan, LegacyIce  Administrátor
          Je to bug v Ubuntu. Otvor terminál a napíš lspci. Výstup hoď sem, z terminálu sa kopíruje ctr+shift+c. Hoď sem ešte aj výstup čo vypíše aplay -l. Pokiaľ je to bug čo je nahlásený na launchpade, viem ako na to :)
          Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
          • Re: Problem so zvukom 27.08.2010 | 12:24
            psenko   Návštevník
            lspci:
            00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
            00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
            00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
            00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
            00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
            00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
            00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
            00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
            00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 05)
            00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
            00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
            00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
            00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
            00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
            01:00.0 VGA compatible controller: ATI Technologies Inc Manhattan [Mobility Radeon HD 5000 Series]
            01:00.1 Audio device: ATI Technologies Inc Manhattan HDMI Audio [Mobility Radeon HD 5000 Series]
            02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
            03:00.0 SD Host controller: Ricoh Co Ltd Device e822
            03:00.1 System peripheral: Ricoh Co Ltd Device e230
            03:00.4 SD Host controller: Ricoh Co Ltd Device e822
            04:00.0 Ethernet controller: Marvell Technology Group Ltd. Device 4381 (rev 11)
            3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
            3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
            3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
            3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
            3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
            3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

            aplay -I:
            **** Zoznam PLAYBACK Hardwarových Zariadení ****
            karta 0: Intel [HDA Intel], zariadenie 0: ALC269 Analog [ALC269 Analog]
            Podzariadenia: 1/1
            Subzariadenie #0: subdevice #0
            karta 1: Generic [HD-Audio Generic], zariadenie 3: ATI HDMI [ATI HDMI]
            Podzariadenia: 1/1
            Subzariadenie #0: subdevice #0
            • Re: Problem so zvukom 27.08.2010 | 12:56
              Avatar bedňa antiX, Devuan, LegacyIce  Administrátor
              Na koniec súboru /etc/modprobe.d/alsa-base pridaj tieto tri riadky:
              alias snd-card-0 snd-hda-intel
              options snd-card-0 index=0
              options snd-hda-intel model=vaio

              Potom reštartuj ALSU
              sudo /etc/init.d/alsa-utils restart

              Pokiaľ to nezaberie, treba nainštalovať najnovšiu ALSU a postup opakovať.
              Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
              • Re: Problem so zvukom 27.08.2010 | 13:09
                Avatar David Ubuntu 10.4  Používateľ
                no trochu som mimo, kde na koniec suboru a co je alsa? trochu blbe otazky ale pre mna uzitocne :)
                presiel som na Linux, mam ho par dni tak majte so mnou strpenie. Dakujem :)
                • Re: Problem so zvukom 27.08.2010 | 13:17
                  Avatar bedňa antiX, Devuan, LegacyIce  Administrátor
                  ALSA je zvukový systém v Linuxe. Súbor otvoriš tak že naštartuješ terminal, tam napíšeš gksudo gedit /etc/modprobe.d/alsa-base
                  Prejdeš na koniec súboru a dopíšeš tam tieto tri riadky:
                  alias snd-card-0 snd-hda-intel
                  options snd-card-0 index=0
                  options snd-hda-intel model=vaio
                  Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
                  • Re: Problem so zvukom 27.08.2010 | 13:27
                    Avatar David Ubuntu 10.4  Používateľ
                    dakujem za vysvetlenie, tu je screen: http://www.upnito.sk/imggal.php?viewGallery=e7658b61a3c5559fbdaf346102a5de56
                    otvoril som terminal spustil alsu prekopiroval som tam tie tri riadky a dal ulozit. terminal vypisal to co je v screene. btw:ked som alsu otvoril tak som tam nic nemal napisane
                    presiel som na Linux, mam ho par dni tak majte so mnou strpenie. Dakujem :)
                    • Re: Problem so zvukom 27.08.2010 | 13:57
                      Avatar bedňa antiX, Devuan, LegacyIce  Administrátor
                      Tá chyba je asi spôsobená tým, že si okopíroval aj konce riadkov. Treba to kopírovať len po posledný znak, riadok po riadku. To že je ten súbor prázdny sa mi nezdá. Skús v terminály napísať:
                      cd /etc/modprobe.d/
                      ls -l
                      (sú to malé Lká)
                      Pozri či vypíše súbor alsa-base.conf
                      Lebo je v tom hokej, v jednej verzii je to alsa-base.conf v ďaľšej alsa-base, tiež v tom nemám úplne jasno :) Škoda že niesom pri Ubuntu.
                      Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
                      • Re: Problem so zvukom 27.08.2010 | 14:14
                        Avatar David Ubuntu 10.4  Používateľ
                        david@david-laptop:~$ cd /etc/modprobe.d/
                        david@david-laptop:/etc/modprobe.d$ ls -l
                        celkom 36
                        -rw-r--r-- 1 root root 91 2010-08-27 11:14 alsa-base
                        -rw-r--r-- 1 root root 2386 2010-01-29 01:01 alsa-base.conf
                        -rw-r--r-- 1 root root 325 2010-04-14 06:36 blacklist-ath_pci.conf
                        -rw-r--r-- 1 root root 1603 2010-04-14 06:36 blacklist.conf
                        -rw-r--r-- 1 root root 213 2010-04-14 06:36 blacklist-firewire.conf
                        -rw-r--r-- 1 root root 660 2010-04-14 06:36 blacklist-framebuffer.conf
                        -rw-r--r-- 1 root root 156 2010-01-29 01:01 blacklist-modem.conf
                        lrwxrwxrwx 1 root root 41 2010-08-26 17:49 blacklist-oss.conf -> /lib/linux-sound-base/noOSS.modprobe.conf
                        -rw-r--r-- 1 root root 1077 2010-04-14 06:36 blacklist-watchdog.conf
                        lrwxrwxrwx 1 root root 31 2010-08-26 18:17 fglrx.conf -> /etc/alternatives/fglrx_modconf
                        -rw-r--r-- 1 root root 16 2010-01-06 09:13 libpisock9.conf

                        david@david-laptop:~$ alsa-base.conf
                        alsa-base.conf: command not found


                        presiel som na Linux, mam ho par dni tak majte so mnou strpenie. Dakujem :)
                        • Re: Problem so zvukom 27.08.2010 | 14:54
                          Avatar bedňa antiX, Devuan, LegacyIce  Administrátor
                          Takže upravujem postup na:
                          Súbor otvoriš tak že naštartuješ terminal, tam napíšeš:
                          gksudo gedit /etc/modprobe.d/alsa-base.conf
                          Prejdeš na koniec súboru a dopíšeš tam tieto tri riadky:
                          alias snd-card-0 snd-hda-intel
                          options snd-card-0 index=0
                          options snd-hda-intel model=vaio
                          Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
                          • Re: Problem so zvukom 27.08.2010 | 15:07
                            Avatar David Ubuntu 10.4  Používateľ
                            http://www.upnito.sk/imggal.php?viewGallery=5a4e233e52a44a2b4737d056225ff2ea
                            dobre som to tam dopisal? a dal som ulozit a konzola vypisala vid screen, zvuk stale nejde. mna porazi :( asi aj teba.
                            presiel som na Linux, mam ho par dni tak majte so mnou strpenie. Dakujem :)
                            • Re: Problem so zvukom 27.08.2010 | 15:18
                              Avatar bedňa antiX, Devuan, LegacyIce  Administrátor
                              Podľa mňa je problém len v koncoch riadkov, skopíroval si tam aj "prázdne znaky". Zruš odskoky medzi riadkami (aby všetky tri riadky boly v jednom a znovu ich rozdel ENTERom). Druhá možnosť je skopírovať to odtiaľto, ale nie všetky riadky naraz. Riadok po riadku a dávaj pozor, aby si neskopíroval a "neviditeľný" koniec riadku :) Neviem či ma chápeš :) Kľudne sa pýtaj ďalej, ale pri PC budem až tak za 3hodiny.
                              Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
                              • Re: Problem so zvukom 28.08.2010 | 02:50
                                Avatar David Ubuntu 10.4  Používateľ
                                som to rucne prepisal na posledne 3riadky a stale nic. konzola mi to iste vypise ked dam ulozit. vid screen vyssie. netreba nejaky reset zvukovky a odznovu instal? alebo ja neviem. umrem uz. chcem si film pustit..vrrr
                                presiel som na Linux, mam ho par dni tak majte so mnou strpenie. Dakujem :)
                                • Re: Problem so zvukom 28.08.2010 | 18:36
                                  Avatar bedňa antiX, Devuan, LegacyIce  Administrátor
                                  To si dostal aj mňa do úzkych :) Takže aby sme vyriešili problém so zvokom, ideme vyriešiť problém s jazykmi :) Nakopni terminál a napíš:
                                  sudo apt-get install language-pack-en language-pack-sk language-support-en language-support-sk language-support-writing-en language-support-writing-sk Keď to skončí, tak v menu "Systém -> Správa -> Jazyková podpora", po spustení si systém zistí či všetko s jazykmi bolo nainštalované, ak nie bude chceť doinštalovať.
                                  A pretože na launchpade sú nahlásené podobné chyby, daj pre istotu :) ešte: apt-get update Keď to nezabere, otoč sa na lampáreň, alebo Wlasatého :D
                                  Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org