Podivné "vypínanie" PC

Sekcia: Hardware a Drivery 07.08.2014 | 09:39
pablo   Návštevník

Ahojte všetci linuxáci. 

Stalo sa mi niečo, čo považujem za dosť divné (v poslednej dobe sa mi s mojimi PC vlastne dejú samé divné veci...) - keď mi na desktope odišiel zdroj (450 W), nahradil som ho novým (550 W) a od toho času sa mi nedá normálne vypnúť mašina, ani hardwarovo ani softwarovo. 

Keď dám vypnúť (a je jedno, či vypínačom na krabici alebo funkciou "Vypnúť PC"), vypne sa s tým, že o 2 sekundy sa znovu sám zapne. Ešte som si všimol, že pri tom zostáva svietiť NUMLOCK - to by nemal. 

Na tej mašine mám duálny OS (mám tam aj WinXP, lebo neviem rozchodiť v linuxe TV-kartu a skener - pár rokov som tam mal Win7, ale ma po čase napálil veľmi dlhým a čoraz dlhším nábehom - nepomáhal ani reinstall, tak som sa vrátil ku WinXP...), vyskúšal som to aj s WinXP - pri vypínaní robí to isté... 

Skúšal som v biose všelijaké zmeny (zapnúť ACPI, vypnúť ACPI, nastavenie S3, a podobne) - nič sa nemenilo... 

Teraz som si spomenul na jednu divnú vec - keď som prvýkrát po úspešnej výmene zdroja zapol mašinu, požadovala nastavenie v biose - tak som skontroloval zmeny a bolo tam zmenené: čas posunutý o 2 hodiny dozadu, režim FAN CPU bol STANDARD namiesto SILENT, zapnuté FULL LOGO pri štarte, zapnutý rýchly vstup na internet - nepoužívam ho nikdy, zapnutý port WIREFIRE - ani ho nemám fyzicky nainštalovaný, bootovanie z diskety namiesto HDD - KTO TO DNES POUŽÍVA? a podobné veci - všetko som uviedol do stavu, ako to používam ja... 

Od príkazu REBOOT sa to divné vypínanie líši tým, že počas reštartu neostáva svietiť NUMLOCK, kým počas tzv. vypínania NUMLOCK svieti. 

Ešte divnejšie sa to správa, keď dám funkciu USPAŤ - mašina zostane bežať s vypnutým monitorom a nedá sa už uviesť do normálneho chodu, len pársekundovým podržaním vypínacieho tlačítka mašinu vypnúť a potom znovu zapnúť... 

Všimol som si, že dnešné ATX zdroje nemajú jeden pin na 24-pinovej ATX zásuvke vôbec zapojený, na mojom starom zdroji (v čase odchodu mal 7 rokov) tam bol biely káblik a bolo tam vyvedené napätie mínus 5 V... 

Môže za takéto správanie ten nový zdroj? Taký istý ako som mal sa už nedá zohnať - iba podobný - bez toho bieleho kábliku (EUROCASE, tak ako bol ten starý zdroj)...

    • RE: Podivné "vypínanie" PC 07.08.2014 | 14:10
      Avatar bedňa antiX, Devuan, LegacyIce  Administrátor

      Skúšal si ho vypnúť príkazom? Pokiaľ máš Ubuntu tak sudo poweroff pokiaľ nejakú Lennartovinu tak systemctl poweroff, môže sa stať že WM neposiela správny príkaz, ale pošle napríklad HALT.

      Sused mal podobný problém a pomôhlo vypnutie Wake On Lan (WOL). Mne ale podobné problémy spôsoboval práve zdroj. Ideálne je si od niekoho požičať iný na skúšku.

      Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
      • RE: Podivné "vypínanie" PC 07.08.2014 | 16:34
        Avatar pablo   Návštevník

        Zbytočné je skúšať to s iným zdrojom - už som to urobil predtým, ako som išiel zháňať nový - bolo to bez problémov (lenže - bol to približne rovnako starý zdroj - mal zapojený aj pin 20 - to je ten biely vývod -5 V)...

        Vypnutie Wake On Lan - to bolo jedno z prvých nastavení v biose, ktoré som robil po zistení že sa podivne vypína... Pre istotu som zrušil aj Wake On pre PCI a PCIE zariadenia a aj pre klávesnicu - nepomohlo.

        Jednoznačne mi to vychádza, že mám MB vykopávku, ktorá už úplne nepodporuje tie "vylepšené" ATX zdroje...

        Starý repasovaný zdroj nemienim použiť pre moju mašinu - takže mi asi neostáva iné, len počas tých 2 sekúnd, čo mám PC vypnutý, vypnúť vypínačom zdroj a potom ho znova zapnúť, aby sa dala aspoň mašinka normálne zapnúť a po uplynutí záruky na zdroj to vidím ako zásah do zdroja s pridaním kábliku -5 V...

        • RE: Podivné "vypínanie" PC 07.08.2014 | 18:36
          Avatar bedňa antiX, Devuan, LegacyIce  Administrátor

          Takže vieš že je to v zdroji a pýtaš sa na závadu? Neviem aký je problém kúpiť zdroj z druhej ruky, možno by som taký našiel aj doma.

          Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
          • RE: Podivné "vypínanie" PC 08.08.2014 | 00:28
            Avatar pablo   Návštevník

            To mi je teraz už úplne jasné, že je to tým chýbajúcim káblikom v zdroji v spojení so staršou matičnou doskou, predtým mi to však ani zďaleka neprišlo na um, Ty si mi vlastne dal odpoveď v svojom prvom príspevku v tejto téme...

            Už nemienim kupovať ďalší zdroj, keďže viem, že sa vlastne úplne rovnaké, ako sa robili pred 7 rokmi, už vôbec nerobia. A starý krám je zbytočné dávať - vydrží len krátko, nakoľko v takýchto veciach väčšinou starnú elektrolytické kondenzátory a tie spôsobia jeho koniec (občas síce prehorí aj nejaký odpor).

            Ten zdroj čo som kúpil funguje perfektne ticho, takže chýba tam len ten jeden káblik (ten však chýba už vo všetkých zdrojoch vyrábaných od istého roku - netrúfam si tipovať od ktorého roku)...

            Môžeš tému uzavrieť...

    • RE: Podivné "vypínanie" PC 07.08.2014 | 16:36
      Avatar pablo   Návštevník

      Ten príkaz z konzoly robí "to isté v modrom"...

    • Konečne vyriešené! 27.09.2014 | 12:09
      Avatar pablo   Návštevník

      Ahojte všetci.

      Ten problém s vypínaním PC som definitívne vyriešil včera.

      Dal som sa pomýliť tým, že po odídení zdroja mi s náhradným požičaným zdrojom mašinka normálne išla, aj sa dala vypnúť...

      Lenže, keď som kúpil nový zdroj, tak som si neodpustil "generálne čistenie PC od prachu" a zrejme som pri tom nechtiac spôsobil čiastočný reset biosu (to som ani nevedel že je to možné) - vyplýva to z úvodného príspevku.

      A práve to bol ten zásadný problém, že sa jednalo len o čiastočný a nie úplný reset...

      S odstupom času (stále mi to nedalo pokoj a vadilo mi, že musím nútene vypínať PC vypínačom na zdroji) som znovu vyskúšal ten istý zdroj, ktorým som si overil funkčnosť mašiny po odchode zdroja a napriek tomu, že bol na ňom osadený aj pin 20 (- 5 V), sa to správalo rovnako - 2 až 3 sekundy po vypnutí sa samé zaplo...

      Takže chyba nebola v zdroji ale v PC...

      Znovu som rozobral mašinu a teraz som aj vybral matičnú dosku, aby som sa pohodlne dostal ku jumprom na reset biosu (keď ostala doska v kasni, nešiel som sa tam dostať) a po vybratí baterky (ani ku nej nie je bohvieaký prístup, keď je doska v kasni) som resetol bios...

      Až teraz to funguje aj s mojím novým zdrojom!

      • RE: Konečne vyriešené! 27.09.2014 | 14:15
        Avatar bedňa antiX, Devuan, LegacyIce  Administrátor

        To sme radi že ti to fachá.

        Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org