Nastavenie defaultnej klávesnice v Mate

Sekcia: Konfigurácia 19.12.2015 | 13:42
Avatar Livan Arch LXQT, Ubuntu  Používateľ

Zdravím, v Mate verzii Manjara som si nainštaloval 3 klávesnice (sk, en, cz). Problém je, že v klikátku (nastavenia klávesnice) si neviem nastaviť aby bola sk klávesnica defaultná - vždy je defaultná en. Prešiel som celé klikátko, je tam spústa nastavení vlastností klávesnice ale toto som nenašiel, aj poradie klávesníc som zmenil tak, aby sk bola prvá ale stále pri spustení mám default en. Netuší niekto, kde sa toto v Mate nastavuje?

    • RE: Nastavenie defaultnej klávesnice v Mate 19.12.2015 | 15:50
      Avatar bedňa antiX, Devuan, LegacyIce  Administrátor

      Ovládacie centrum -> Klávesnica -> Rozloženie

      Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
      • RE: Nastavenie defaultnej klávesnice v Mate 19.12.2015 | 16:01
        Avatar Livan Arch LXQT, Ubuntu  Používateľ

        V rozloženie sa to nedá nastaviť, skúšal som. Môžeš nastaviť poradie ako chceš, aj tak je default en. Ale riešenie som nakoniec našiel, viď príspevok nižšie. Treba editovať priamo konfiguračný súbor.

    • RE: Nastavenie defaultnej klávesnice v Mate 19.12.2015 | 15:56
      Avatar Livan Arch LXQT, Ubuntu  Používateľ

      Heuréka, už som na to prišiel. Treba zeditovať konfiguračný súbor etc/X11/xorg.conf.d/00-keyboard.conf

      Section "InputClass"
       Identifier "system-keyboard"
       MatchIsKeyboard "on"
       Option "XkbLayout" "sk"
       Option "XkbModel" "pc105"
       Option "XkbVariant" ""
       Option "XkbOptions" "terminate:ctrl_alt_bksp"
      EndSection

      treba zmeniť ako superužívateľ

      Option "XkbLayout" "en"   na   Option "XkbLayout" "sk"

      • RE: Nastavenie defaultnej klávesnice v Mate 19.12.2015 | 16:25
        Avatar vxmery Mint 17.3  Používateľ

        V Cinnamone sa to dá naklikať:

        Systemové nastavenia/Klávesnica/Rozloženia a šipkou posunieš defaultnú klávesnicu nahor.

        Asi tu chodí nejaký predvianočný čert čo blbne s klávesnicami :)

        • RE: Nastavenie defaultnej klávesnice v Mate 19.12.2015 | 16:30
          Avatar Livan Arch LXQT, Ubuntu  Používateľ

          Ako som už napísal, v prípade Mate presunutie sk klávesnice nahor v Rozložení nezmenilo jej status, default ostala en, aj keď bola druhá v poradí.

          • RE: Nastavenie defaultnej klávesnice v Mate 19.12.2015 | 17:21
            Avatar vxmery Mint 17.3  Používateľ

            Žeby bug? Skús reportovať.

            A za mňa máš 1* že si to vyriešil