Po rozchodeni wlan som stratil ethernet pripojenie

Sekcia: Ostatné 23.11 | 19:03
Avatar symbio   Používateľ

Mam problem s pripojenim na web z notebooku ASUS M509D s novou instalaciou Manjaro 22.0.0. Dlho som sa pokusal rozchodit wifi pripojenie a ked mi odrazu zacalo fungovat, stratil som ethernetove pripojenie.

[symbio@manjaro ~]$ inxi -N
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8821ce

[symbio@manjaro ~]$ rfkill
ID TYPE      DEVICE              SOFT      HARD
 0 wlan      asus-wlan      unblocked unblocked
 1 bluetooth asus-bluetooth   blocked unblocked
 2 wlan      phy0           unblocked unblocked

[symbio@manjaro ~]$ lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Root Complex
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 IOMMU
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:01.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
00:01.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus A
00:08.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus B
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 61)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 5
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 6
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 7
01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
02:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller 980
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso/Raven 2 [Radeon Vega Series / Radeon Vega Mobile Series] (rev c2)
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
03:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) Platform Security Processor
03:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
03:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
03:00.5 Multimedia controller: Advanced Micro Devices, Inc. [AMD] ACP/ACP3X/ACP6x Audio Coprocessor
03:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h/19h HD Audio Controller
03:00.7 Non-VGA unclassified device: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/Renoir Non-Sensor Fusion Hub KMDF driver
04:00.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 61)
[symbio@manjaro ~]$ 


Ako si naspat spojazdnim ethernet?

Neskúsený používateľ Manjaro XFCE
    • RE: Po rozchodeni wlan som stratil ethernet pripojenie 23.11 | 22:13
      Avatar Livan Manjaro s XFCE  Používateľ

      Zrejme nemáš dobre nastavené pripojenia, ja to mám takto... Na spodnej lište klikni pravým tlačidlo myši na ikonku pripojenia, musí byť zatrhnuté Povoliť sieť, bezdrôtové pripojenia a povoliť oznámenia. Potom kliknúť na Upraviť pripojenia. Objaví sa okno so sieťovými pripojeniami. Klikni na názov drôtového pripojenia a potom dole na ozubené koliesko Upraviť vybrané pripojenie.Na záložke Všeobecné - zatrhnúť Pripojiť automaticky s prioritou -999. Zatrhnúť Všeci užívatelia sa môžu pripojiť. Následne na karte Ethernet zaškrtnúť Prebudenie pomocou LAN - predvolené. Skontroluj a vyskúšaj, či to máš takto nastavené a či to bude takto fungovať.

      • RE: Po rozchodeni wlan som stratil ethernet pripojenie 23.11 | 22:17
        Avatar Livan Manjaro s XFCE  Používateľ

        Ak potom priorita -999 nebude fungovať, skús nastaviť 1 alebo 2 a uvidíš.

        • RE: Po rozchodeni wlan som stratil ethernet pripojenie 23.11 | 22:21
          Avatar Livan Manjaro s XFCE  Používateľ

          Presnejšie ja mám nastavenú prioritu na wifi 0, čo je zrejme najvyššia priorita, ty sa s tými prioritami skús pohrať a nastav 0 na drôt a 1 na wifi. Teda s tými prioritami neviem, ako to presne je. Otestuj to.

          • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 07:10
            Avatar symbio   Používateľ

            Ďakujem za podrobný návod Livan. Po nainštalovaní Speedyfy mi však pevné pripojenie nechodilo . Ani ho nevidím v zozname pripojení. A ešte jedna vec mi nie je jasná. Tie posledne odpovede sa mi na notebooku nechcú zobraziť,ani po opatovnom reštartovaníntb ntb. V mobile ich však vidím.

            Neskúsený používateľ Manjaro XFCE
    • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 06:37
      Avatar Miroslav Bendík Gentoo  Administrátor

      Medzi zariadeniami nie je ethernet. Za bežných okolností by tam malo byť niečo také:

      lspci|grep -i ethernet
      02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0e)
      05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
      • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 07:03
        Avatar Livan Manjaro s XFCE  Používateľ

        To je vlastne pravda, to som si v zápale boja nevšimol. Takže buď je pokazený port alebo chýba ovladač, prípadne je iný problém s ethernetom.

        • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 07:17
          Avatar symbio   Používateľ

          K tomu pokazenému portu poviem iba toľko, že pokiaľ som nerozchodil wifi, ethernet fungoval mi normálne. Takže si myslím, že problém bude v nejakych nastaveniach môjho manjara

          Neskúsený používateľ Manjaro XFCE
          • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 08:00
            Avatar Livan Manjaro s XFCE  Používateľ

            Takže začneme tým, čo vieme zistiť. Nabootuj livko s manjarom a v ňom zadaj tieto dva príkazy

            inxi -F

            rfkill list

            potom výsledok inxi týkajúca sa siete sem skopíruj a aj ten rfkill list a uvidíme. Potom na porovnanie aj v nainštalovanom PC. Tým zistíme rozdiel v tom, čo je funkčné v livku a čo nie v PC.

            • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 10:40
              Avatar symbio   Používateľ

              tu je vystup z live, ethernet v pohode

              [manjaro@manjaro ~]$ inxi -F
              System:
                Host: manjaro Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.14.2 
                Distro: Manjaro Linux 
              Machine:
                Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X509DA_M509DA 
                v: 1.0 serial: <superuser/root required> 
                Mobo: ASUSTeK model: X509DA v: 1.0 serial: <superuser/root required> 
                UEFI: American Megatrends v: X509DA.306 date: 10/11/2019 
              Battery:
                ID-1: BAT0 charge: 5.4 Wh condition: 25.9/32.0 Wh (81%) 
              CPU:
                Topology: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx 
                bits: 64 type: MT MCP L2 cache: 2048 KiB 
                Speed: 1222 MHz min/max: 1400/2100 MHz Core speeds (MHz): 1: 1222 2: 1223 
                3: 1222 4: 1222 5: 1393 6: 1295 7: 1222 8: 1222 
              Graphics:
                Device-1: AMD Picasso driver: amdgpu v: kernel 
                Device-2: IMC Networks USB2.0 Hub type: USB driver: uvcvideo 
                Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: modesetting 
                resolution: 1920x1080~60Hz 
                OpenGL: renderer: AMD RAVEN (DRM 3.38.0 5.8.6-1-MANJARO LLVM 10.0.1) 
                v: 4.6 Mesa 20.1.7 
              Audio:
                Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
                Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
                driver: snd_rn_pci_acp3x 
                Device-3: AMD Family 17h HD Audio driver: snd_hda_intel 
                Sound Server: ALSA v: k5.8.6-1-MANJARO 
              Network:
                Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
                driver: N/A 
                Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
                IF: enp3s0f3u2 state: up speed: 1000 Mbps duplex: full 
                mac: 00:e0:4c:3e:24:62 
              Drives:
                Local Storage: total: 484.44 GiB used: 67.2 MiB (0.0%) 
                ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ512HALU-00000 
                size: 476.94 GiB 
                ID-2: /dev/sda type: USB model: SMI USB size: 7.50 GiB 
              Partition:
                ID-1: / size: 4.36 GiB used: 67.2 MiB (1.5%) fs: overlay source: ERR-102 
              Swap:
                Alert: No Swap data was found. 
              Sensors:
                System Temperatures: cpu: 41.8 C mobo: N/A gpu: amdgpu temp: 41 C 
                Fan Speeds (RPM): cpu: 1700 
              Info:
                Processes: 247 Uptime: 2m Memory: 5.82 GiB used: 839.3 MiB (14.1%) 
                Shell: Bash inxi: 3.1.05 
              [manjaro@manjaro ~]$ rfkill list
              0: asus-wlan: Wireless LAN
              	Soft blocked: no
              	Hard blocked: no
              1: asus-bluetooth: Bluetooth
              	Soft blocked: yes
              	Hard blocked: no
              2: hci0: Bluetooth
              	Soft blocked: yes
              	Hard blocked: no
              [manjaro@manjaro ~]$ ^C
              [manjaro@manjaro ~]$ 
              
              
              Neskúsený používateľ Manjaro XFCE
              • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 15:23
                Avatar Miroslav Bendík Gentoo  Administrátor

                Aaaha, to je USB sieťovka. Ja som to akosi automaticky bral, že to je PCIE zariadenie.

            • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 10:46
              Avatar symbio   Používateľ

              a tu je z instalacie

              [symbio@manjaro ~]$ inxi -F
              System:
                Host: manjaro Kernel: 5.15.78-1-MANJARO arch: x86_64 bits: 64 Desktop: Xfce
                  v: 4.16.1 Distro: Manjaro Linux
              Machine:
                Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X509DA_M509DA
                  v: 1.0 serial: <superuser required>
                Mobo: ASUSTeK model: X509DA v: 1.0 serial: <superuser required>
                  UEFI: American Megatrends v: X509DA.306 date: 10/11/2019
              Battery:
                ID-1: BAT0 charge: 4.9 Wh (18.9%) condition: 25.9/32.0 Wh (80.9%) volts: 7.6
                  min: 7.6
              CPU:
                Info: quad core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
                  bits: 64 type: MT MCP cache: L2: 2 MiB
                Speed (MHz): avg: 1524 min/max: 1400/2100 cores: 1: 1703 2: 1231 3: 1267
                  4: 1244 5: 1397 6: 1397 7: 2183 8: 1777
              Graphics:
                Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
                  driver: amdgpu v: kernel
                Device-2: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
                Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: amdgpu
                  unloaded: modesetting dri: radeonsi gpu: amdgpu resolution: 1728x972~60Hz
                API: OpenGL Message: Unable to show GL data. Required tool glxinfo
                  missing.
              Audio:
                Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
                Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp3x
                Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
                Sound API: ALSA v: k5.15.78-1-MANJARO running: yes
                Sound Server-1: PulseAudio v: 16.1 running: yes
                Sound Server-2: PipeWire v: 0.3.59 running: yes
              Network:
                Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
                  driver: rtw_8821ce
                IF: wlp1s0 state: up mac: c0:e4:34:d7:c9:0d
                Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
                IF: enp3s0f3u2 state: up speed: 1000 Mbps duplex: full
                  mac: 00:e0:4c:3e:24:62
              Bluetooth:
                Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb
                Report: rfkill ID: hci0 state: up address: see --recommends
              Drives:
                Local Storage: total: 484.44 GiB used: 21.11 GiB (4.4%)
                ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ512HALU-00000
                  size: 476.94 GiB
                ID-2: /dev/sda type: USB vendor: SMI (STMicroelectronics) model: USB
                  size: 7.5 GiB
              Partition:
                ID-1: / size: 459.43 GiB used: 21.11 GiB (4.6%) fs: ext4 dev: /dev/nvme0n1p2
                ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
                  dev: /dev/nvme0n1p1
              Swap:
                ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
                  dev: /dev/nvme0n1p3
              Sensors:
                System Temperatures: cpu: 62.9 C mobo: N/A gpu: amdgpu temp: 62.0 C
                Fan Speeds (RPM): cpu: 2800
              Info:
                Processes: 282 Uptime: 0m Memory: 5.74 GiB used: 1.99 GiB (34.7%)
                Shell: Bash inxi: 3.3.23
              [symbio@manjaro ~]$ rfkill list
              0: asus-wlan: Wireless LAN
              	Soft blocked: no
              	Hard blocked: no
              1: asus-bluetooth: Bluetooth
              	Soft blocked: no
              	Hard blocked: no
              2: phy0: Wireless LAN
              	Soft blocked: no
              	Hard blocked: no
              3: hci0: Bluetooth
              	Soft blocked: no
              	Hard blocked: no
              [symbio@manjaro ~]$ 
              
              
              Neskúsený používateľ Manjaro XFCE
              • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 12:41
                Avatar Livan Manjaro s XFCE  Používateľ

                Podľa tých výpisov to vyzerá, že z livka ti nefungovalo wifi, nebol tam driver. Po inštalácii to vyzerá, že ide aj wifi aj ethernet, obive zariadenia majú nainštalovaný driver a ani jedno nie je blokované (obidve sú UP). Takže teraz treba akurát správne všetko nastaviť pre jednotlivé siete. Skús to podľa toho návodu čo som písal včera a potom sa pohraj jednak s prioritami a potom s povoleniami wifi na zaškrtávacom políčku pripojenia, pretože ak chceš pripojiť ethernet, možno bude treba zablokovať wifi, pretože si nie som istý, či za normálnych okolností môže byť súčasne pripojené wifi aj ethernet. Wifi sa deaktivuje tým zaškrtávatkom ktoré sa objaví keď pravým tlačidlom myši klikneš na ikonu sietí. Možno bude treba zmeniť aj priority jednotlivých druhov pripojení tak, že ethernetu dáš prioritu 0 alebo 1 a wifi zasa 1 alebo 2, pričom priorita musí byť rôzna pre rôzne pripojenia. Priorita wifi by mala byť nižšia, ako ethernetu, teda mala by mať vyššie číslo.

                • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 14:40
                  Avatar symbio   Používateľ

                  Oznamujem dobre spravy. Ani neviem ako, ale ked som sa vratil domov, odrazu som videl aj ethernetove pripojenie v nastaveni pripojenia. Do teraz som videl iba wifi siete a odrazu tam bolo aj ethernet pripojenie. Stacilo sa iba pohrat s nastavenim priority pripojenia a bolo to OK. Velmi krasne dakujem Livanko

                  Neskúsený používateľ Manjaro XFCE
                  • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 14:45
                    Avatar Livan Manjaro s XFCE  Používateľ

                    Len pre zaujímavosť, ako si nastavil tie priority?

                    • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 19:56
                      Avatar symbio   Používateľ

                      Vyyzera to tak, ze som sa radoval predcasne.

                      Ethernet mi opatovne nechodi...

                      Najprv som sa hral s nastaveniami priorit, ale stale sa mi pripojilo wifi. Potom som wifi uplne vypol, a ethernet sa nepripojil.

                      Vobec netusim, co s tym je...

                      Neskúsený používateľ Manjaro XFCE
                      • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 21:18
                        Avatar Miroslav Bendík Gentoo  Administrátor

                        Čo je vo výpise lsusb?

                        • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 21:26
                          Avatar symbio   Používateľ
                          [symbio@manjaro ~]$ lsusb
                          Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
                          Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
                          Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
                          Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
                          [symbio@manjaro ~]$ 
                          
                          
                          Neskúsený používateľ Manjaro XFCE
                          • RE: Po rozchodeni wlan som stratil ethernet pripojenie 24.11 | 23:45
                            Avatar symbio   Používateľ

                            tu je snimka mojho ethernet pripojenia. Vtedy som sa pripojil hned dva krat. Prvy a posledny :)

                            Neskúsený používateľ Manjaro XFCE
                            • RE: Po rozchodeni wlan som stratil ethernet pripojenie 25.11 | 06:43
                              Avatar Livan Manjaro s XFCE  Používateľ

                              Tak ono je skôr zaujímavá ta stránka, ktorá sa objaví, keď klikneš na názov toho pripojenia a následne na to ozubené koleso dole. Treba to urobiť pre obidve pripojenia, wifi aj ethernet.

                              • RE: Po rozchodeni wlan som stratil ethernet pripojenie 25.11 | 06:58
                                Avatar symbio   Používateľ

                                Je velmi zvlastne najma to, ze ethernet mi odrazu isiel a neurobil som preto vobec nic.

                                Odrazu jednoducho bol v ponuke pripojrni aj ked tam predtym nebol....

                                Neskúsený používateľ Manjaro XFCE
                                • RE: Po rozchodeni wlan som stratil ethernet pripojenie 25.11 | 07:00
                                  Avatar symbio   Používateľ

                                  A rovnako z pripojeni bez mojho pricinenia aj zmizol

                                  Neskúsený používateľ Manjaro XFCE
                          • RE: Po rozchodeni wlan som stratil ethernet pripojenie 25.11 | 07:18
                            Avatar Miroslav Bendík Gentoo  Administrátor

                            To vyzerá na závažný problém s USB portom alebo USB sieťovkou. Minimálne medzi zariadeniami musí byť bez ohľadu na to, či má ovládač alebo nie.

                            • RE: Po rozchodeni wlan som stratil ethernet pripojenie 25.11 | 09:17
                              Avatar symbio   Používateľ

                              Mne to celé na tomto konkrétnom notebooku pred asi mesiacom chodilo vporiadku. Potom som si chcel nainštalovať Anarchlinux.

                              Pri jeho inštalácii som sformátoval disk, inštalácia sa však nepodarila, tak som si chcel spätne nainštalovať Manjaro.

                              Odvtedy sa s tým trápim...

                              Asi skúsim novú inštaláciu a keď sa problém zopakuje, ozvem sa

                              Neskúsený používateľ Manjaro XFCE
                              • RE: Po rozchodeni wlan som stratil ethernet pripojenie 25.11 | 11:23
                                Avatar Livan Manjaro s XFCE  Používateľ

                                Osobne si myslím, že to zbytočne silíš. Ja používam odjakživa pripojenie iba cez wifi a nemám s tým žiadne problémy, najmä ak máš doma dobrý wifi router. Dnes sa dá cez wifi prenášať dáta rovnakou alebo dokonca vyššou rýchlosťou než káblom. Pripojíš sa s tým doma aj inde. Káblové pripojenie je dobré iba ak chceš hrať hry cez internet. Ináč to nemá zmysel pripojovať cez ethernet.

                                • RE: Po rozchodeni wlan som stratil ethernet pripojenie 25.11 | 12:11
                                  Avatar Pavel Q4OS KDE  Administrátor

                                  Ja mám opačnú skúsenosť a za mňa kábel je kábel. Keď som sa pripájal k routeru od UPC cez wifinu, na 100 Mbite rýchlosť cez wifi cca 30-40 Mbit, po kábli plná rýchlosť.

                                  • RE: Po rozchodeni wlan som stratil ethernet pripojenie 25.11 | 17:27
                                    Avatar Livan Manjaro s XFCE  Používateľ

                                    Syn má pripojenie cez wifi a na 5 GHz mu wifina ide 350 Mbit. Tých 30 - 40 zodpovedá 2,4 GHz.

    • RE: Po rozchodeni wlan som stratil ethernet pripojenie 27.11 | 17:34
      Avatar symbio   Používateľ

      Uz som tu opat.
      Preinstaloval som cele manjaro a problem ostal rovnaky. Akonahle mi zacalo fungovat wifi, kabel sa stal nefunkcny. V rozpise pripojeni sa proipojenie ethernet ani nespomina..


        prikladam rozpis hardware z nainstalovanym RTL driverom, chodiacou wifi,ethernet vsak absentuje aj v zozname pripojeni
        [symbio@manjaro ~]$ inxi -F
        System:
          Host: manjaro Kernel: 5.15.78-1-MANJARO arch: x86_64 bits: 64 Desktop: Xfce
            v: 4.16.1 Distro: Manjaro Linux
        Machine:
          Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X509DA_M509DA
            v: 1.0 serial: <superuser required>
          Mobo: ASUSTeK model: X509DA v: 1.0 serial: <superuser required>
            UEFI: American Megatrends v: X509DA.306 date: 10/11/2019
        Battery:
          ID-1: BAT0 charge: 19.4 Wh (75.8%) condition: 25.6/32.0 Wh (79.9%)
            volts: 7.6 min: 7.6
        CPU:
          Info: quad core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
            bits: 64 type: MT MCP cache: L2: 2 MiB
          Speed (MHz): avg: 1229 min/max: 1400/2100 cores: 1: 1222 2: 1221 3: 1222
            4: 1222 5: 1266 6: 1221 7: 1225 8: 1236
        Graphics:
          Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
            driver: amdgpu v: kernel
          Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: amdgpu
            unloaded: modesetting dri: radeonsi gpu: amdgpu resolution: 1536x864~60Hz
          API: OpenGL Message: Unable to show GL data. Required tool glxinfo
            missing.
        Audio:
          Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
          Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp3x
          Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
          Sound API: ALSA v: k5.15.78-1-MANJARO running: yes
          Sound Server-1: PulseAudio v: 16.1 running: yes
          Sound Server-2: PipeWire v: 0.3.59 running: yes
        Network:
          Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
            driver: rtw_8821ce
          IF: wlp1s0 state: up mac: c0:e4:34:d7:c9:0d
        Drives:
          Local Storage: total: 476.94 GiB used: 11.4 GiB (2.4%)
          ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ512HALU-00000
            size: 476.94 GiB
        Partition:
          ID-1: / size: 459.43 GiB used: 11.4 GiB (2.5%) fs: ext4 dev: /dev/nvme0n1p2
          ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
            dev: /dev/nvme0n1p1
        Swap:
          ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
            dev: /dev/nvme0n1p3
        Sensors:
          System Temperatures: cpu: 40.4 C mobo: N/A gpu: amdgpu temp: 40.0 C
          Fan Speeds (RPM): cpu: 1800
        Info:
          Processes: 258 Uptime: 53m Memory: 5.74 GiB used: 1.96 GiB (34.1%)
          Shell: Bash inxi: 3.3.23
        [symbio@manjaro ~]$
      Neskúsený používateľ Manjaro XFCE
      • RE: Po rozchodeni wlan som stratil ethernet pripojenie 27.11 | 17:39
        Avatar Miroslav Bendík Gentoo  Administrátor

        Keď funguje ethernet, čo je v lsusb?

      • RE: Po rozchodeni wlan som stratil ethernet pripojenie 27.11 | 17:44
        Avatar Livan Manjaro s XFCE  Používateľ

        Začínám mať pocit, že problém vytvára ten spôsob, akým spojazdňuješ to wifi. Vyzerá to na to, že pri inštalácii wifi nejako odstraňuješ driver na ethernet. Ja totiž aj keď mám funkčné wifi, tak driver mám zachovaný iba je down a teoreticky by som ho vedel i aktivovať, ak by bolo treba. Viď.

        [ivan@dell ~]$ inxi -n
        Network:
          Device-1: Intel 82579LM Gigabit Network driver: e1000e
          IF: eno1 state: down mac: 84:8f:69:f0:8c:58
          Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
          IF: wlp2s0 state: up mac: 08:11:96:8f:52:74
        

        Popíš postup, ako to spojazdňuješ.

        • RE: Po rozchodeni wlan som stratil ethernet pripojenie 27.11 | 18:16
          Avatar Miroslav Bendík Gentoo  Administrátor

          Nie, zariadenie sa vážne nedá len tak odstrániť odstránením ovládača. Keďže je to USB, bude viditeľné bez ohľadu na to, či má driver, alebo nie.

      • RE: Po rozchodeni wlan som stratil ethernet pripojenie 27.11 | 18:46
        Avatar Pavel Q4OS KDE  Administrátor

        Tak v skratke, máš USB sieťovku a keď sa pripojiš k wifine tak ju nevidíš? Mňa napadla taká blbosť, čo tak vyskúšať softvérovo reštartovať usb? Mne blbla wifina a to mi pomohlo, aj keď len výstrel naslepo.

    • RE: Po rozchodeni wlan som stratil ethernet pripojenie 27.11 | 18:31
      Avatar Miroslav Bendík Gentoo  Administrátor

      Mimochodom namiesto tak zastaralého kernelu by som odporúčal niečo novšie. Modul rtw8821ce je v kerneli od verzie 5.9.

      • RE: Po rozchodeni wlan som stratil ethernet pripojenie 27.11 | 19:25
        Avatar symbio   Používateľ

        Pani velmi krasne dakujem za pomoc a rady.

        Nainstaloval som si skusobne Linux Mint a tam mi v pohode chodilo pripojenie k webu na striedacku. Potom som naspat zapol Manjaro a tam mi to uz chodi vdaka Bohu taktiez.

        Technika vie robit niekedy, ako sa jej paci.

        K tomu modulu o ktorom si pisal. Ja mam RTL8821ce

        Ked si nainstalujem vyssiu verziu kernelu, nainstaluju sa k nemu automaticky aj hlavicky?

        A nepotreboval som ani Speedify

        Este raz chcem vsetkym podakovat za pomoc

        Nech vas vsetkych Boh velmi pozehna za vsetko, co tu robite pre ludi, ktori chcu pracovat s Linuxom

        Neskúsený používateľ Manjaro XFCE
        • RE: Po rozchodeni wlan som stratil ethernet pripojenie 27.11 | 21:20
          Avatar Livan Manjaro s XFCE  Používateľ

          O akých hlavičkách v súvislosti s inštaláciou kernelu to hovoríš?

          • RE: Po rozchodeni wlan som stratil ethernet pripojenie 28.11 | 12:18
            Avatar symbio   Používateľ

            V anglictine to nazyvaju Kernl headers...

            Ked som dnes rano zapol ntb, opat nefungoval ethernet. Wifi siet sa jedina zjavila v sietovych pripojeniach. Nech som skusal, ako skusal, neuspel som.

            Potom som chcel spustit Mint, ale ani ten sa nechcel spustit. Musel som opravit jeho instalaciu (renstalovat), nainstalovat wifi driver a az potom poprepinat pripojenia. Ked som vytiahol kabel, automaticky sa preplo wifi a naopak. jednoducho to fungovalo!

            Vratil som sa naspat k Manjaru a aj tu mi to uz funguje... Ako som povedal, technika sa v mojom pripade sprava nevyspytatelne.:(

            Neskúsený používateľ Manjaro XFCE
            • RE: Po rozchodeni wlan som stratil ethernet pripojenie 28.11 | 12:52
              Avatar Livan Manjaro s XFCE  Používateľ

              Tie kernel headers Ťa vôbec nemusia zaujímať, pretože sa jedná o hlavičkové súbory zdrojových kódov v jazyku C, ktoré sú potrebné pri preklade kernelu a po preklade (čo je náš prípad, pretože sa kernel inštaluje už preložený) už nie sú potrebné.

              • RE: Po rozchodeni wlan som stratil ethernet pripojenie 28.11 | 14:05
                Avatar symbio   Používateľ

                Na tie hlavicky som sa pytal preto, lebo pri instalacii drivera vo forach na tie hlavicky dost upozornovali, ze musia byt v sulade s kernelom

                Neskúsený používateľ Manjaro XFCE
                • RE: Po rozchodeni wlan som stratil ethernet pripojenie 28.11 | 14:44
                  Avatar Livan Manjaro s XFCE  Používateľ

                  Pokiaľ inštaluješ tak, že kompiluješ zo zdrojákov, tak to dáva zmysel, inak nie. Kernel sa zvyčajne inštaluje už preložený. Bez hlavičiek by si to nedokázal preložiť, takže ano k prekladu hlavičky potrebuješ.

                • RE: Po rozchodeni wlan som stratil ethernet pripojenie 28.11 | 16:48
                  Avatar Miroslav Bendík Gentoo  Administrátor

                  Lenže od verzie 5.9 vyššie ak správne pozerám by mal byť driver už priamo v kerneli, takže nie je potrebné nič doinštalovať. Samozrejme ruku do dverí za to nedám.

                • RE: Po rozchodeni wlan som stratil ethernet pripojenie 28.11 | 21:00
                  Avatar symbio   Používateľ

                  Zase zvlastna udalost. Nechal som notebook zapnuty v plnom nasadeni (ziadny usporny rezim) a ked som sa teraz k nemu vratil, uz ethernet neexistuje. Jednoducho zmizol zo sietovych pripojeni...Uz som pripjeny iba cez wifi, co je pre mna dost obmedzujuce.... Router je totiz na opacnej strane domu a signal mam velmi slaby.. Aj preto som chcel mat hlavne pripojenie cez kabel.A wifi pripojenie mat v zalohe, ked budem v prostredi bez kabla.

                  Neskúsený používateľ Manjaro XFCE
                  • RE: Po rozchodeni wlan som stratil ethernet pripojenie 28.11 | 22:05
                    Avatar Livan Manjaro s XFCE  Používateľ

                    Len tak pre srandu skús vytiahnuť kábel a znova ho zastrčiť, či sa to nespamätá. Začína mi to vyzerať, ako nejaký hardvérový problém.

                    • RE: Po rozchodeni wlan som stratil ethernet pripojenie 29.11 | 21:06
                      Avatar symbio   Používateľ

                      Skusam rozne postupy, ale jediny, ktory mi funguje je prejst na Mint, tam to automaticky prepnut a vratit sa spat do Manjara. Ale Mint musim zakazdym preinstalpvat, lebo sa neda bez reinstalacie spustit.

                      Neskúsený používateľ Manjaro XFCE
                      • RE: Po rozchodeni wlan som stratil ethernet pripojenie 01.12 | 10:07
                        Avatar paldopice   Používateľ

                        Ty vole a co tak pozriet logy (journalctl|/var/log/syslos|dmesg -T)? Co tak pozriet, po vypadku ethernetu, ci sietovku vidno a ci ma IP adresu (ip a) a ci je vobec v zozname USB zariadeni (lsusb)...?

                        • RE: Po rozchodeni wlan som stratil ethernet pripojenie 01.12 | 13:07
                          Avatar Miroslav Bendík Gentoo  Administrátor

                          V zozname lsusb nie je. Zisťovanie IP bude teda zbytočné, ale v dmesg by sa mal objaviť záznam o odpojení a pri troche šťastia možno aj nejaké konkrétne chybové hlásenie.

                          Ozaj, čo ťa vedie k tej forme komunikácie (dúfam, že nevadí tykanie)? Mimo toho úvodného kopnutia si je komentár prínosný. Chápem, že niektoré veci ti pripadajú triviálne, aj mne pripadajú triviálne, ale chápem, že nie každý je odborník. Bez toho úvodu by mali ľudia podstatne lepší pocit z komentára tebe to ušetrí trochu času.

                          • RE: Po rozchodeni wlan som stratil ethernet pripojenie 01.12 | 14:19
                            Avatar paldopice   Používateľ

                            Ozaj, čo ťa vedie k tej forme komunikácie...

                            Myslim, ze po cca 40-tich totalne bludnych prispevkoch je to adekvatna reakcia. Ale vlastne mas pravdu, ake ine riesenie, ako je zmena distribucie, mozu odporucat "odbornici" na distribucnu turistiku...?

                            • RE: Po rozchodeni wlan som stratil ethernet pripojenie 01.12 | 15:02
                              Avatar Pavel Q4OS KDE  Administrátor

                              Tá nadradenosť, tak potom mu poraď keď si všade bol a všetko vieš a nemusíme písať bludy,,,

                              • RE: Po rozchodeni wlan som stratil ethernet pripojenie 03.12 | 22:14
                                Avatar paldopice   Používateľ

                                Ved som.

                            • RE: Po rozchodeni wlan som stratil ethernet pripojenie 04.12 | 09:18
                              Avatar Livan Manjaro s XFCE  Používateľ

                              Zdá sa, že i Ty tu píšeš bludy. Nevšimol som si, že by mu tu niekto odporúčal zmeniť distribúciu. Navyše, keďže sa "odborníci" neunúvali mu skúsiť pomôcť, pokúsili sme sa mu pomôcť my "neodborníci". Že sa nám to nepodarilo to vyriešiť je dané našou neskúsenosťou v tejto oblasti. Nemôže byť každý odborník na všetko, ja som napríklad chemik. Ale alespoň sme sa pokúsili pomôcť. Je smutné, že namiesto toho, aby si sa zapojil do riešenia problému, iba kritizuješ. To niečo o Tebe hovorí.

                              • RE: Po rozchodeni wlan som stratil ethernet pripojenie 04.12 | 19:11
                                Avatar Pavel Q4OS KDE  Administrátor

                                To sú tí internetoví hrdinovia dnešnej doby, skrývať sa za klávesnicou a všetko kritizovať. Nechcem byť zlý, chlap možno vie viac ako mnohí z nás, len ten prístup... Ja mať práva tak už ten nick neexistuje a je mi u prdeli nejaká rovnoprávnosť, nevieš sa správať, nazdar.

    • RE: Po rozchodeni wlan som stratil ethernet pripojenie 04.12 | 10:50
      Avatar distefano LinuxMint s XFCE  Používateľ

      Ale mne sa zda, ze Vas tu vsetkych symbio /pripadne paldo..../ len natahuje.

      • RE: Po rozchodeni wlan som stratil ethernet pripojenie 04.12 | 23:46
        Avatar menom   Používateľ

        Možno nenaťahuje, ale sa nevie tak presne vyjadriť, mne v popise problému chýba, že čo to vlastne má pichnuté v usb porte, je to dáka redukcia alebo hub z číny, keď lsusb ho neukazuje ?

        Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
          IF: enp3s0f3u2 state: up speed: 1000 Mbps duplex: full

        Mohlo by byť prínosom keby dal tie logy čo písal samalama, tipujem.