amarok qt kdelibs

Sekcia: Aplikácie & Desktop 29.03.2007 | 16:33
Avatar nighthawk Gentoo  Používateľ
Caute,
pc acer ferrari 4000, OS: gentoo. gnome ked chcem naistalovat amarok tak mi vyhodi hlasku ze nemoze nainstalovat kdelibs koli tomu, ze ma byt qt (>= Qt 3.3 and < 4.0) lenze mam nainstalovane qt 4.2, skusal som instalovat qt rucne, teda cez ./configure make a make install, instalacia prebehne v pohode ale chybovu hlasku ukazuje stale >= Qt 3.3 and < 4.0).
Daky napad?
vdaka
    • Re: amarok qt kdelibs 29.03.2007 | 16:41
      Avatar Ladislav Michnovic SuSE  Používateľ
      skus spustit ako root
      ldconfig
      Only man who sells empty boxes is the undertaker.
      • Re: amarok qt kdelibs 29.03.2007 | 16:50
        Avatar nighthawk Gentoo  Používateľ
        to som skusil spustit ale nepomohlo mi to
        • Re: amarok qt kdelibs 29.03.2007 | 17:08
          Avatar Igor Hlina Mac OS ML  Používateľ
          Asi musis mat paralelne nainstalovane aj QT v3 libky aby to bezalo. Skus dat emerge --search qt a potom z vysledkov uz budes vediet ako sa vola balicek QT3 kniznic. Neinstaluj ho hned ale zadaj emerge -pv nazov_ebuildu aby si mohol preskumat zavislosti. Mozes si potom hned prisposobit USE flagy, s akymi to nainstalujes (napr. inline zapisom USE="-doc java" emerge nazov_ebuildu).

          Prestuduj si man emerge a pozri si co znamenaju jednotlive stlpce pri emerge -pv.
          while (2*2 == 5) { echo "If you're reading this, something is definitely wrong"; }
        • Re: amarok qt kdelibs 29.03.2007 | 17:11
          Avatar Ladislav Michnovic SuSE  Používateľ
          ./configure --help
          a hladaj riadok ktorym parametrom zadavas cestu ku QT include suborom.
          Asi ich hlada v default ceste a tam mas tie 4.2. Zadaj mu rucne cestu k 3.x a on ich tam najde.
          Ak to nepomoze, tak vyhladaj si error hlasku v configure.log a pozri sa co presne zlyhalo a prilep to sem.
          Only man who sells empty boxes is the undertaker.
          • Re: amarok qt kdelibs 29.03.2007 | 18:28
            Avatar Miroslav Bendík Gentoo  Administrátor
            Detajlik
             >= Qt 3.3 and < 4.0
            To snad hovori za seba, qt 4.2 je => 4.0 teda nie je podporovane, amarok odjakziva bezal na qt3 preto ho (zatial) nemozno rozbehat na qt4 a nepomozu ani ziadne triky s configure.
            • Re: amarok qt kdelibs 29.03.2007 | 19:08
              Avatar nighthawk Gentoo  Používateľ
              to ze qt 4.2 je viac ako qt 4.0 to mi bolo jasne :) len ja hladam sposob ako tam dostanem qt z toho intervalu...
              vdaka za odpovede, ale zatial moj problem nevyriesili