Pomoc !!! libc6

Sekcia: Aplikácie & Desktop 03.04.2007 | 14:35
robo   Návštevník
Prosim Vas o pomoc. Mam ubuntu 6.10 a chcel som nainstalovat program audacity pri instalacii mi napisalo ze musim nainstalovat libc6 2.5.0 ked som to urobil zacalo mi vypisovat ze je system poskodeny mam to vyriesit prikazom sudo apt-get -f instal tam mi ponuklo ze odinstaluje skoro 350MB (to podla mna cely linux). Na internete som si stiahol naspat libc6 2.4.0 ale ked ho dam nainstalovat cez gdebi alebo konzolu napise mi ze mam uz novsiu verziu balicka.
Prosim poradte mi ako zachranit linux na PC (tak som si ho postupne pekne vyladil ze mi je ho skoda onho prist). Napriklad mi nefunguje deluge, gnukash a ine veci
    • Re: Pomoc !!! libc6 03.04.2007 | 14:43
      ---   Návštevník
      ako si instaloval audacity ? cez synaptic? Dufam ze nie stiahnutin jednotl. balikov. Zavislosti sa mali (museli) vyriesit same. Mas nastavene vsetky potrebne repozitare?
      Preco nejde deluge atd., ako sa to prejavuje ?daj vypis , spusti tie programy v konzole a skopiruj sem vypis.
      • Re: Pomoc !!! libc6 03.04.2007 | 19:56
        robo   Návštevník
        audacity som stiahol z ich web stranky ked som ho chcel nainstalovat cez gdebi napisalo mi ze musim nainstalovat libc6 2.5 tiez som ho stiahol z ich stranky. Libc6 2.5 som tiez spustil instalaciu cez gdebi kde na konci mi vypisalo ze nemohlo nainstalovat nejake zavislosti. No a vtedy mi to zacalo vsetky problemy. Teraz sa nemozem ani pripojit na linux grub to zvlada a le obrazovka ostava v pohotovostnom stave. Toto teraz pisem cez win. Tak to asi vyzera ze musim odznova nainstalovat linux.
        • Re: Pomoc !!! libc6 03.04.2007 | 20:04
          robo   Návštevník
          Nevie niekto kedy bude ubuntu 7.4 (nie testovacie) rad by som si dal uz nove ale neviem kolko mam cakat a na ich webe som sa otom nedocital (velmi slaba anglictina)
          • Re: Pomoc !!! libc6 05.04.2007 | 10:37
            Avatar georw Ubuntu 12.04  Používateľ
            Malo by byt 19. aprila. Ale radsej si pockaj mozno tyzden dlhsie, ja to tak spravim. Este sa stale objavuju nejake bugy a aj pre niektore programy v repozitaroch nie su dobre spravene balicky.
        • Re: Pomoc !!! libc6 03.04.2007 | 20:10
          ---   Návštevník
          len tak na okraj co je gdebi? skoro to vyzera ako nadavka.
          preco to neinstalujes cez synaptic alebo v konzole cez sudo apt-get install audacity ?
          mozes sa dostat pri tom starte do prikazoveho riadlu? Ak ano zrejme mas v /etc/X11 zalohu xorg.conf , mozno by stacilo ju obnovit.
          Inac co si robil ,ked si dosiel az k tomu ze to nechce nabehnut? Spomen si mozno to treba odinstalovat , zmenit naspat a to by slo aj v prikazovom riadku.
          Ak len zacinas s linuxom ,tak preinstalovanie je mozno lepsie ako sa s tym trapit, Musis sa aj na vlastnych chybach nieco naucit:-)
    • Re: Pomoc !!! libc6 03.04.2007 | 20:13
      Kukurica   Návštevník
      Preco baliky stahujes rovno z netu? Vsak na instalaciu programov mas apt-get. Mal si si v synapticu povlit vsetky repozitare a dat hladat balik audacity.
      • Re: Pomoc !!! libc6 03.04.2007 | 20:25
        robo   Návštevník
        No ja som chcel najnovse audacity a repozitaroch je starsie. Tak sa vola program ktory bol nainstalovany ktori instaluje .deb balicky (gdebi). A co som robil. Navrhlo mi potom aby som v conzole zadal sudo apt-get -f install to malo vyriesit problem ked som to zadal tak mi navrhlo odstranit nekompaktibilne balicky ktore som aj odstranil (to asi boli tie programy co nefunguju) Ja som Zaciatocnik mate pravdu tak asi 4 mesiace co som si nahodil Ubuntu.
        • Re: Pomoc !!! libc6 04.04.2007 | 23:35
          Avatar Igor Hlina Mac OS ML  Používateľ
          Ubuntu FF bude tento mesiac. BTW ak si vymenil libc6.so, rozhodil si samotne jadro systemu, tzv. GLIBC kniznice, oproti ktorym je kompilovany skoro vsetok SW (tusim iba samotne GLIBC nie je). Je to zrele na reinstall.
          while (2*2 == 5) { echo "If you're reading this, something is definitely wrong"; }
          • Re: Pomoc !!! libc6 05.04.2007 | 12:09
            karol   Návštevník
            Záloha celej systémovej partície je dobrá vec. Už mi to mnohokrát pri mojej šikovnosti ušetrilo novú inštaláciu. Napríklad program "Partimage", tú partíciu, ktorú zálohuješ treba mať umountnutú a je dobré, ked systém beží s live-CD
    • Re: Pomoc !!! libc6 05.04.2007 | 14:00
      Peter S.   Návštevník
      no je tu ešte jedna možnosť ako opraviť systém ktorý nie je bootovateľný - použiť chroot / live CD.
      1. Nabootuješ liveCD, môže byť aj inštalačné CD ubuntu, alebo live CD ubuntu,a prípadne aj iné live CD - podmienka je aby tam bol program chroot
      (v dalších krokoch predpokladám že si root)
      2. urobíš si nový adresár, napr. /mnt/ABCDE
      3. mountneš poškodený systém do toho adresára
      mount -t ext3 /dev/hdXY /mnt/ABCDE
      4. chrootneš sa tam
      chroot /mnt/ABCDE /usr/bin
      5. a už si v svojom poškodenom systéme, a tu si musíš nejako poradiť, napríklad odinštalovať ten libc6 ak si ho ešte neodinštaloval a skúsiť dať napríklad klasicky apt-get install ubuntu-desktop - verím, že by ti to malo obnoviť všetko, alebo proste robiť čo uznáš za vhodné
      6. Ak si myslíš, že si to opravil, daj exit a si naspäť v liveCD a skús reštartovať....
      • Re: Pomoc !!! libc6 05.04.2007 | 16:42
        robo   Návštevník
        Diki za rady, ale uz mam vsetko vymazane a zatial mam len nainstalovany win. pokial nevyjde ubuntu 7.4. (ked je to tohto mesiaca tak pockam nanho)