gentoo

Sekcia: Aplikácie & Desktop 04.07.2007 | 13:49
miso   Návštevník
emerge kdenetwork kdeadmin
Calculating dependencies... done!

!!! Error: the =kde-base/kwin-3.5* package conflicts with another package;
!!! the two packages cannot be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

tak toto v skratke znamena ze nemozem instalovat niektore programi ???
ako to mozem obist a ci je to bezpecne ??
    • Re: gentoo 04.07.2007 | 13:51
      Avatar duben Slackware  Používateľ
      Please use 'emerge --pretend' to determine blockers.

      http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
      • Re: gentoo 04.07.2007 | 14:11
        miso   Návštevník
        ale to vobec nefunguje :-)
        • Re: gentoo 04.07.2007 | 14:13
          Avatar Andrej "karči" Krajči Gentoo  Administrátor
          co nefunguje? ono ti ma vypisat veci ktore sa navzajom blockuju

          napr. ked si nainstalujes kdemeta a potom si chces dat kwin tak ti to vyhodi error ze sa blockuju :)
          "IB, thy name is homework." -- IB
          • Re: gentoo 04.07.2007 | 14:34
            miso   Návštevník
            ved jasne ale kde som daval aj instalaciu po jednotlivych balikoch tam mi zase vypisovalo
            checking for KDE... libraries /usr/kde/3.5/lib64, headers /usr/kde/3.5/include
            checking if UIC has KDE plugins available... no
            configure: error:
            you need to install kdelibs first.

            If you did install kdelibs, then the Qt version that is picked up by
            this configure is not the same version you used to compile kdelibs.
            The Qt Plugin installed by kdelibs is *ONLY* loadable if it is the
            _same Qt version_, compiled with the _same compiler_ and the same Qt
            configuration settings.


            !!! Please attach the following file when filing a report to bugs.gentoo.org:
            !!! /var/tmp/portage/kde-base/kopete-3.5.5-r2/work/kopete-3.5.5/config.log

            !!! ERROR: kde-base/kopete-3.5.5-r2 failed.
            Call stack:
            ebuild.sh, line 1621: Called dyn_compile
            ebuild.sh, line 973: Called qa_call 'src_compile'
            ebuild.sh, line 44: Called src_compile
            kopete-3.5.5-r2.ebuild, line 120: Called kde_src_compile
            kde.eclass, line 170: Called kde_src_compile 'all'
            kde.eclass, line 340: Called kde_src_compile 'myconf' 'configure' 'make'
            kde.eclass, line 322: Called econf '--disable-jingle' '--disable-sametime-plugin' '--without-xmms' '--without-external-libgadu' '--without-xscreensaver' '--disable-smsgsm' '--disable-testbed' '--with-x' '--enable-mitshm' '--without-xinerama' '--with-qt-dir=/usr/qt/3' '--enable-mt' '--with-qt-libraries=/usr/qt/3/lib64' '--disable-dependency-tracking' '--disable-debug' '--without-debug' '--disable-final' '--without-arts' '--prefix=/usr/kde/3.5' '--mandir=/usr/kde/3.5/share/man' '--infodir=/usr/kde/3.5/share/info' '--datadir=/usr/kde/3.5/share' '--sysconfdir=/usr/kde/3.5/etc' '--enable-libsuffix=64'
            ebuild.sh, line 578: Called die

            !!! econf failed
            !!! If you need support, post the topmost build error, and the call stack if relevant.
            !!! A complete build log is located at '/var/tmp/portage/kde-base/kopete-3.5.5-r2/temp/build.log'.

            a co poradis na toto
            • Re: gentoo 04.07.2007 | 14:44
              miso   Návštevník
              a hlavne cez toto sa nemozem prehrist :-(
            • Re: gentoo 04.07.2007 | 14:59
              miso   Návštevník
              super tak s tym asi nevie pohnut nik :-)
              • Re: gentoo 04.07.2007 | 15:30
                WlaSaTy   Návštevník
                no nevie, keďže máš gentoo tak asi budeš musieť začať čítať príručky. Najme k príkazom:

                emerge --sync
                emerge -Dvt --pretend world
                #kuk na výstup z pretend
                emerge -Dvt world
                #zapáliť čiernu sviečku odliatu na trojkráľový večer a 6 krát obehnúť 6 domov v 6tich mestách
                revdep-rebuild

                a môžeš začať. Takéto ftákoviny sa dejú ak človek príliš agresívne inštaluje knižnice do systému (tak ako to robíš teraz) a niekto prehodí knižnicu alebo balík do iného slotu poprípade ten balík úplne zruší. Nechci vedieť ako som dopadol ja pri migrácii medzi X6 a X7, celá grafika pošla v čorty.
                • Re: gentoo 04.07.2007 | 15:55
                  miso   Návštevník
                  dik pocitam a poskusam s tymi slotmy som nemal skusenosti tak este sa mam co ucit :-)
                • Re: gentoo 04.07.2007 | 20:39
                  miso   Návštevník
                  skusil som to podla teba a tu je vysledok checking for KDE... libraries /usr/kde/3.5/lib64, headers /usr/kde/3.5/include
                  checking if UIC has KDE plugins available... no
                  configure: error:
                  you need to install kdelibs first.

                  If you did install kdelibs, then the Qt version that is picked up by
                  this configure is not the same version you used to compile kdelibs.
                  The Qt Plugin installed by kdelibs is *ONLY* loadable if it is the
                  _same Qt version_, compiled with the _same compiler_ and the same Qt
                  configuration settings.


                  !!! Please attach the following file when filing a report to bugs.gentoo.org:
                  !!! /var/tmp/portage/kde-base/kopete-3.5.5-r2/work/kopete-3.5.5/config.log

                  !!! ERROR: kde-base/kopete-3.5.5-r2 failed.
                  Call stack:
                  ebuild.sh, line 1621: Called dyn_compile
                  ebuild.sh, line 973: Called qa_call 'src_compile'
                  ebuild.sh, line 44: Called src_compile
                  kopete-3.5.5-r2.ebuild, line 120: Called kde_src_compile
                  kde.eclass, line 170: Called kde_src_compile 'all'
                  kde.eclass, line 340: Called kde_src_compile 'myconf' 'configure' 'make'
                  kde.eclass, line 322: Called econf '--disable-jingle' '--disable-sametime-plugin' '--without-xmms' '--without-external-libgadu' '--without-xscreensaver' '--disable-smsgsm' '--disable-testbed' '--with-x' '--enable-mitshm' '--without-xinerama' '--with-qt-dir=/usr/qt/3' '--enable-mt' '--with-qt-libraries=/usr/qt/3/lib64' '--disable-dependency-tracking' '--disable-debug' '--without-debug' '--disable-final' '--without-arts' '--prefix=/usr/kde/3.5' '--mandir=/usr/kde/3.5/share/man' '--infodir=/usr/kde/3.5/share/info' '--datadir=/usr/kde/3.5/share' '--sysconfdir=/usr/kde/3.5/etc' '--enable-libsuffix=64'
                  ebuild.sh, line 578: Called die

                  !!! econf failed
                  !!! If you need support, post the topmost build error, and the call stack if relevant.
                  !!! A complete build log is located at '/var/tmp/portage/kde-base/kopete-3.5.5-r2/temp/build.log'.
                  Ale aj tak vda aspon si sa mi pokusil pomoct
                  • Re: gentoo 05.07.2007 | 00:00
                    Avatar Andrej "karči" Krajči Gentoo  Administrátor
                    reemerge kdelibs

                    emerge -av kdelibs

                    podla mna to je ten problem ... inak preco neinstalujes normalne kdecko? :)
                    "IB, thy name is homework." -- IB
                    • Re: gentoo 05.07.2007 | 00:16
                      miso   Návštevník
                      ja som instaloval kde start alebo nieco take zakladny balik a potom som chcel doinstalovat podla potreby ale zda sa ze som to mal hned nainstalovat cele