import gtk File "/var/lib..." /> import gtk File "/var/lib..." />

Manager

Sekcia: Aplikácie & Desktop 30.07.2007 | 17:26
Avatar Predrag Ubuntu 10.04  Používateľ
Zdar dnes som kompiloval nieake veci a stala sa mi taka vec ze ked som sa chcel pozriet na nieco do restricted manager tak som zadal heslo a dalej nic.v terminaly mi vypisalo toto

Traceback (most recent call last):
File "/usr/bin/restricted-manager", line 45, in <module>
import gtk
File "/var/lib/python-support/python2.5/gtk-2.0/gtk/__init__.py", line 43, in <module>
"PyGTK requires PyGObject 2.11.1 or higher, but %s was found" % (ver,))
ImportError: PyGTK requires PyGObject 2.11.1 or higher, but () was found

skusal som hladat nieco aj na nete ale nebolo tam nic konkretne
neviete co stym?thx
Fujitsu Siemens Amilo Pa 1510, Ati Radeon x 1100.
    • Re: Manager 30.07.2007 | 19:04
      WlaSaTy   Návštevník
      ImportError: PyGTK requires PyGObject 2.11.1 or higher, but () was found

      skús sa pozrieť či máš nainštalovaný PyGObject verzie 2.11.1 alebo vyššej. Ináč čo je to za distribúciu keď obsahuje nekonzistentné balíčky, alebo si to nebodaj inštaloval akosi inak?
      • Re: Manager 30.07.2007 | 21:01
        Avatar Predrag Ubuntu 10.04  Používateľ
        nie nie ja som si kompiloval nieake programi na pc.
        Fujitsu Siemens Amilo Pa 1510, Ati Radeon x 1100.
        • Re: Manager 30.07.2007 | 21:51
          Avatar Predrag Ubuntu 10.04  Používateľ
          mam nainstalovany najnovsi 2.12.0.ale aj tak to nejde.neviete este neico poradit?
          Fujitsu Siemens Amilo Pa 1510, Ati Radeon x 1100.
          • Re: Manager 30.07.2007 | 21:57
            Avatar Predrag Ubuntu 10.04  Používateľ
            teraz mi to vypisuje


            Traceback (most recent call last):
            File "/usr/bin/restricted-manager", line 45, in <module>
            import gtk
            File "/var/lib/python-support/python2.5/gtk-2.0/gtk/__init__.py", line 48, in <module>
            from gtk import _gtk
            ImportError: PyGObject version mismatch, 2.12.0 is required, found 2.11.1.
            Fujitsu Siemens Amilo Pa 1510, Ati Radeon x 1100.
            • Re: Manager 30.07.2007 | 22:09
              Avatar samox86 arch, debian  Administrátor
              sudo apt-get install python-gobject-dev

              ked dam "apt-cache showpkg python-gobject-dev"
              tak mi to vypise dostupnu verziu 2.12.3-0ubuntu3 - ta to mozno poriesi...
              lnx.sk - virtualne servery; Lnx@Lnx.sk
            • Re: Manager 30.07.2007 | 22:11
              WlaSaTy   Návštevník
              2.12.0 is required, found 2.11.1.

              áno, niečo si kompiloval. odporučil by som angličtinu pre samoukov, používať balíčkovací systém alebo aspoň gentoo aj s emerge ktoré dokáže ošetrovať aj reverzné závislosti a kompiluje to samo. Ručné vytvorenie niečoho na spôsob Linux From Scratch sa bez základnej znalosti angličtiny končí násilnou reinštaláciou.
              • Re: Manager 31.07.2007 | 00:53
                Avatar Predrag Ubuntu 10.04  Používateľ
                neboj sa ja si viem co to prelozit z anglictiny.niesom az taky zaciatocnik ako by sa ti mohlo zdat
                Fujitsu Siemens Amilo Pa 1510, Ati Radeon x 1100.
                • Re: Manager 31.07.2007 | 01:24
                  WlaSaTy   Návštevník
                  prečo by som sa zrovna ja mal báť, začiatky nehryzú.
                  • Re: Manager 01.08.2007 | 13:21
                    Avatar Predrag Ubuntu 10.04  Používateľ
                    to je jedno
                    Fujitsu Siemens Amilo Pa 1510, Ati Radeon x 1100.