sk klavesnica

Sekcia: Aplikácie & Desktop 26.10.2005 | 19:36
transport   Návštevník
chcem sa opytat, ako sa da prepnut do sk klavesnice? pouzivam fluxbox a tam nie nejaky prepinac ako v Kde, ci Gnome
    • Re: sk klavesnica 26.10.2005 | 15:04
      peter golis   Návštevník
      zavisi od nastavenia. standardne nastavenie je v /etc/X11 v subore xorg.conf alebo XFree86.conf alebo XFree86-4.conf, sekcia input, zariadenie klavesnica. ako si to kto nastavi, tak to ma. dost casto to nastavi instalacia. niekedy sa da pouzit aj program na prepnutie klavesnice. co takto opisat distribuciu a vybrat danu cast daneho konfiguraku?
    • Re: sk klavesnica 26.10.2005 | 15:13
      Avatar dusan Arch Linux + Openbox  Používateľ
      Prepinat medzi klavesnicami sa da aj prikazom: setxkbmap sk prepne na slovensku klavesnicu, setxkbmap us vrati spat na us klavesnicu atd.
      • Re: Re: sk klavesnica 26.10.2005 | 19:36
        transport   Návštevník
        Dusan, skvele, moc ti dakujem
    • Re: sk klavesnica 12.01.2007 | 13:05
      Avatar ondrejandrej Kubuntu 11.04  Používateľ
      Ja som si práve inštaloval Xubuntu 6.06 a tiež som nenašiel nič klikateľné na prepínanie klávesnice.

      Funguje mi príkaz setxkbmap, ale ako by som dosiahol, aby klávesová skratka Alt Shift prepla jazyk klávesnice? Som na to veľmi zvyknutý, fungovalo mi to v Debiane v Gnome a je to štandard aj po Windowsami.
      • Re: sk klavesnica 12.01.2007 | 13:41
        Avatar Milan Dvorský debian,mint kde,android  Administrátor
        klikatko sa vola kxkb, pokial ho nemas (v kubuntu je default - staci to aktivovat ako indikator vlajky v tray), je v takmer kazdom repozitari.
        • Re: sk klavesnica 15.01.2007 | 13:13
          Avatar rado_shadow Debian  Používateľ
          paaaana vsak take daco volaco som hladal :-) diiik
    • Re: sk klavesnica 12.01.2007 | 13:55
      Avatar ondrejandrej Kubuntu 11.04  Používateľ
      apt-get mi vyhlasuje, že "Balík kxkb sa nedá nájsť."

      Môžem to skúsiť ešte inak nainštalovať, ale bude mi to fungovať aj v xfce?

      Ja som si pridal na panel nejaký "Keyboard layout switcher", a ukazuje to zástavku, ale tá je stále americká aj keď si prepnem klávesnicu príkazom setxkbmap.
    • Re: sk klavesnica 12.01.2007 | 15:05
      Avatar titanik mint  Používateľ
      skus obidva shifty naraz alebo ctrl+alt+k
      • Re: sk klavesnica 12.01.2007 | 15:09
        Avatar ondrejandrej Kubuntu 11.04  Používateľ
        shifty ani ctrl alt k mi nefungujú.
    • Re: sk klavesnica 12.01.2007 | 15:07
      Avatar ondrejandrej Kubuntu 11.04  Používateľ
      klikol som a nič sa nedeje. Klikol som tým druhým a vybehla ponuka. Zvolil som "Vlastnosti" a je tam iba americké rozloženie. Mal by som pridať slovenské rozloženie, ale taký gombík tu nevidím.

      Ja by som chcel aby mi fungovala klávesová skratka na prepínanie rozloženia klávesnice.
      • Re: sk klavesnica 12.01.2007 | 15:19
        Avatar Peter Rozum Arch Linux  Používateľ
        nuz ja som si pre to upravil /etc/X11/xorg.conf v sekcii s kalevesnicou. prepina sa to stlacenim alt+shift a pri sk klavesnici svieti scroll.

        Section "InputDevice"
        Identifier "Keyboard1"
        Driver "kbd"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "us,sk"
        Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
        EndSection
        Everything is proceeding as I have foreseen.
        • Re: sk klavesnica 22.01.2007 | 12:57
          maslo   Návštevník
          fakt dobra rada nad zlato :) som isiel podla navodu a po reboot mi padla grafika :) ked som to ako root zmazal naspat sa obnovila bol problem ze mam ubuntu 6.10 alebo co ? dik
          • Re: sk klavesnica 22.01.2007 | 14:01
            Avatar ondrejandrej Kubuntu 11.04  Používateľ
            Asi si tam dal aj ten riadok
            Identifier "Keyboard1"

            to sa možno nezhoduje ten názov s klávesnicou na tvojom PC. Mal by si len pridať tie riadky, o ktoré ti ide

            Option "XkbLayout" "us,sk"
            Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
    • Re: sk klavesnica 12.01.2007 | 15:47
      Avatar ondrejandrej Kubuntu 11.04  Používateľ
      tak toto som si doplnil do xorg.conf a funguje to výborne. Normálne mi spadol kameň zo srdca, už som si myslel, že si budem musieť prevykať.

      Kontrolka na klávesnici mi svieti, keď mám sk rozloženie. Celkom dobrý nápad.

      Ešte skúsim tam napísať sk_qwerty, lebo som zvyknutý na qwerty klávesnicu.
      • Re: sk klavesnica 12.01.2007 | 18:04
        Avatar uid0 Debian  Používateľ
        radsej tam napis

        Option "XkbLayout" "us,sk"
        Option "XkbVariant" ",qwerty"
        Debian. apt-get into it…
      • Re: sk klavesnica 15.01.2007 | 12:28
        Avatar ondrejandrej Kubuntu 11.04  Používateľ
        Ďakujem, už to funguje úplne ideálne.

        Neviem, čo sa pokazilo, ale keď som mal chybu v súbore xorg.conf, nespustil sa xfce a potom sa nespustil po zapnutí PC ani keď už bol bez chyby.
        Teraz sa teda nespustí grafika po zapnutí PC a musím v textovom režime zadať príkaz startxfce4.

        Chcel by som, aby po zapnutí PC sa spustilo aj xfce, tak ako predtým. Ako to mám urobiť?
        • Re: sk klavesnica 15.01.2007 | 15:49
          Avatar uid0 Debian  Používateľ
          myslis graficky login?
          Debian. apt-get into it…
        • Re: sk klavesnica 15.01.2007 | 16:05
          Avatar ondrejandrej Kubuntu 11.04  Používateľ
          Asi áno. Po inštalácii xubuntu som nemusel nič stlačiť, len čakať po zapnutí PC a ukázal sa grafický prihlasovač. Teraz sa ukáže po zapnutí textový prihlasovač.
          • Re: sk klavesnica 15.01.2007 | 16:13
            Avatar uid0 Debian  Používateľ
            pozri do /etc/inittab aky je default runlevel, pripadne ho zmen na 4

            potom zadaj

            update-rc.d xdm start 99 4 .

            (ta bodka na konci je dolezita)
            ak to nevyjde, skus miesto xdm dat gdm
            Debian. apt-get into it…
        • Re: sk klavesnica 15.01.2007 | 16:06
          Avatar ondrejandrej Kubuntu 11.04  Používateľ
          Ako to, že sa tak vyznáš v ubuntu, keď v profile máš, že používaš Debian?
        • Re: sk klavesnica 15.01.2007 | 16:17
          Avatar ondrejandrej Kubuntu 11.04  Používateľ
          No to je jedno, teda ako obnovím štart grafiky pri štarte PC?
          A ja by som mal záujem aj o nejaké automatické prihlásenie, ako sa to robí? Keď som mal Debian, ten grafický prihlasovač sa dal nastaviť na aut. prihlásenie a v xubuntu sa to tak ľahko nedá.
          • Re: sk klavesnica 15.01.2007 | 16:24
            Avatar uid0 Debian  Používateľ
            uz som odpovedal

            http://www.linuxos.sk/?show=forum&id=2345#link_47158

            BTW "Odpovedat" sa vzdy nachadza pod prispevkom, nie nad nim. odpovedaj na spravnom mieste
            Debian. apt-get into it…
          • Re: sk klavesnica 15.01.2007 | 16:40
            Avatar ondrejandrej Kubuntu 11.04  Používateľ
            Aha, už vidím, asi som bol slepý.

            No odpovedám preto tak, lebo sa mi nepáči, keď sa tie príspevky stále posúvajú doprava.
          • Re: sk klavesnica 15.01.2007 | 17:11
            Avatar ondrejandrej Kubuntu 11.04  Používateľ
            tak teda default runlevel je 2

            toto vypľuli tie príkazy:

            andrej@kefpc:~$ update-rc.d xdm start 99 4 .
            update-rc.d: /etc/init.d/xdm: file does not exist

            andrej@kefpc:~$ update-rc.d gdm start 99 4 .
            System startup links for /etc/init.d/gdm already exist.
            • Re: sk klavesnica 15.01.2007 | 18:00
              Avatar uid0 Debian  Používateľ
              tak ho zmen na 4

              > No odpovedám preto tak, lebo sa mi nepáči, keď sa tie príspevky stále posúvajú doprava.

              a mne sa to nepaci a preto asi prestanem tuto otazku pozerat...
              Debian. apt-get into it…
          • Re: sk klavesnica 16.01.2007 | 11:19
            Avatar ondrejandrej Kubuntu 11.04  Používateľ
            V súbore /etc/inittab mám toto :

            # The default runlevel.
            id:2:initdefault:

            skúsil som to zmeniť takto:

            # The default runlevel.
            id:4:initdefault:

            a takto :

            # The default runlevel.
            id:2:initdefault:4

            Zakaždým som reštartoval PC a zistil som že to nepomohlo. Stále štartuje do textového režimu.