Ubuntu 16.04 LTS a problemy s grafickymi programami

Sekcia: Aplikácie & Desktop 04.10 | 20:33
Avatar kodym   Návštevník

Zdravim, som len obycajny uzivatel ubuntu a po upgrade ubuntu 16.04 lts z 14.04 lts sa mi nedaju spustit programy: darktable a digikam- po kliknuti na ikonku sa tvaria, ze sa idu otvorit a nic, Gwenview - otvori sa a po vybrati adresara okamzite padne.

Niekolkokrat som vsetky tri programy odinstaloval a priinstaloval cez centrum Ubuntu software a aj cez Synaptic -spravca balikov a nic, stale rovnaky vysledok. V predoslej verzii som mal problem po urcitom case s digikamom, ale darktable a gwenview isli bez problemov, no teraz mi to nejak nejde. Nie som ziaden odbornik na linux, tak prosim zachadzat so mnou ako so zaciatocnikom . Ubuntu pouzivam od 10.04.lts a nikdy som ako uzuivatel nemal az na ten digikam nijaky problem. Ak mi to dokazete polopate vysvetlit v com je problem, alebo kde ja robim problem, tak Vam moc dakujem a ospravedlnujem sa vopred za mozne blbe otazky.

    • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 04.10 | 21:18
      Avatar vxmery Mint 17.3  Používateľ

      Ahoj a vitaj na fóre, Ak nemáš vážne dôvody robiť v 16.04, vráť sa na 14.04. 16.04 je ešte dosť zabugovaná.

    • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 04.10 | 21:18
      Avatar bedňa antiX, Devuan, LegacyIce  Administrátor

      Spusti napríklad darktable z terminálu a pozri sa aké to hádže chybové hlášky.

      Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
    • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 05.10 | 15:18
      Avatar Branislav Poldauf Ubuntu LTS, Debian stable  Používateľ

      inak z mojich skusenosti upgrade medzi verziami ubuntu takmer vzdy priniesol nejake problemy alebo spomalenie (mne)

      teraz kym nepotrebujem nejaku konkretnu funkcnost z novej verzie tak zostávam pri podporovanej verzi (12.04 LTS ma podporu do konca roku 2017 ak sa nemylim a bezi mojim rodicom na domacom PC urcenom pre surfovanie od vydania) a na vyssiu prechdzam len ked skonci podpora (14.04 je podporovane do 2020)

      takze ak nezistic co je na chybe pomocou bedňovho návrhu, tak za pokus stoji vratenie sa k 14.04

      Linux: the operating system with a CLUE... Command Line User Environment
      • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 05.10 | 18:52
        Avatar WlaSaTy   Návštevník

        Ohľadom dĺžky podpory máš moc optimistické sny. A vrátenie sa na predchádzajúcu verziu znamená reinštaláciu OS. Teda, pokiaľ to neodporúčaš robiť jednoduchým prepisom zdrojov SW. Tak sa to nemá robiť, a presne to vždy spôsobuje veľa problémov. Podporovaný spôsob, pomocou príkazu do-release-upgrade alebo jeho grafickou obdobou mi zatiaľ vždy za skoro desať rokov zbehol bez problémov.

        A ohľadom riešenia pôvodného problému? Ja sa skôr prikláňam o dodanie výpisov zo spustenia tých programov z terminálu. Pozrieť do toho je menej pracné ako to jednoducho preinštalovať na jedno akú verziu.

        • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 06.10 | 09:20
          Avatar Branislav Poldauf Ubuntu LTS, Debian stable  Používateľ

          mozno som ja robil nieco zle ale pri upgrade na vysiu verziu cez GUI som skoro vzdy skoncil zufaly hladanim navodov ako opravit vsetko co prestalo fungovat k tej podpore som vychadzal z LTS dik za doplnenie presnych terminov

          Linux: the operating system with a CLUE... Command Line User Environment
    • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 05.10 | 19:37
      Avatar caopyp linux mint 18 mate-64-bit  Používateľ

      nie som odborník ale prikláňam sa k vxmery mal som ubuntu 16.04 mal som 2 grafiky a keď som upgreadol na najnovšiu jednu tak všetko v pohode a kde druhu tak mi začala blikať obrazovka (asi ešte neboli spolu zosynchronizované) preto som sa rozhodol prejsť na linux mint, ubuntu mam celkom rad začínal som a 10.04 bola fakt dobra hlavne v jednoduchosti je kasára.

    • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 05.10 | 21:11
      Avatar kodym   Návštevník

      Dakujem za odpovede. Skusil som vase navrhy s vypismi. Zial mne to nic nehovori , lepsie povedane neviem, co za undefined symbol tam je a ako ho odstranit.

      • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 05.10 | 21:20
        Avatar bedňa antiX, Devuan, LegacyIce  Administrátor

        Ja som lama, ale podľa tých hlášok mi to príde že je tam problém s QT/KDE knižnicami, toto je dosť hustý fail, asi by som dal downgrade ako tu už bolo odporúčané.

        Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
        • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 05.10 | 21:59
          Avatar WlaSaTy   Návštevník

          Pochybujem že sa mu podarilo niečo takéto nainštalovať bez ručne vypnutých závislostí. Ja by som odporučil reinstal a prestať používať force a nodeps.

          • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 05.10 | 22:25
            Avatar bedňa antiX, Devuan, LegacyIce  Administrátor

            Ono nejaký ten problém mohol spôsobiť aj upgrade na vyššiu verziu a zle napísané skripty ktoré neodstránili knižnice ktoré sú nekompatiblné s novším QT/KDE.

            Fresh install je samozrejme najjednduchšie riešenie.

            Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
            • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 06.10 | 07:49
              Avatar WlaSaTy   Návštevník

              A ty si myslíš, že také niečo by sa dostalo do oficiálnych repozitárov? Tsss. ...To nie je one man show autobuild s preklepmi v náväznostiach.

              • RE: Ubuntu 16.04 LTS a problemy s grafickymi programami 06.10 | 13:43
                Avatar WlaSaTy   Návštevník

                Tak som si obidva programy nahodil do virtuáliek, a je to presne ako som odhadoval. Inštalácia obidvoch grafických programov jak pre 32 tak aj pre 64bit desktopové prostredie má korektne definované náväznosti pre inštaláciu knižníc. Dotiahlo si to kopec balíčkov, a oba programy sa po nainštalovaní korektne naštartovali. Keďže sú tieto náväznosti korektné, tak to nemohlo robiť problémy ani pri upgrade distribúcie. A je krásne vidno, že tam má chalan rozbitý balíčkovací systém.

                Takže, reinštalácia. A následné inštalovanie len cez apt/synaptic bez príznakov force a podobných čo môžu a veľa krát aj poškodia lokálnu databázu inštalovaného SW. A tak isto by som odporučil aj bezhlavo si nepridávať repozitáre (PPA) tretích strán. Ubuntu totižto garantuje len svoje repozitáre, a PPA sú žiaľ len pieskoviská na hranie. Takže ak nejaký "správca" PPA pozabudne na novšie verzie, tak môže zablokovať upgrade svojím užívateľom.