problem with update

Sekcia: Aplikácie & Desktop 19.05.2011 | 18:01
logical   Návštevník
'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/sk.archive.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages, E:Zoznamy balíkov alebo stavový súbor sa nedajú spracovať alebo otvoriť.'

answer to logical421@gmail.com

thank you
    • Re: problem with update 19.05.2011 | 18:25
      WlaSaTy   Návštevník
      Vyber iné zrkadlo, asi ho práve synchronizujú. Alebo počkaj nejaký čas a skús znova.
      • Re: problem with update 19.05.2011 | 20:24
        logical   Návštevník
        problem pretvrvava aj napriek zmeny servera z sk. na hlavny server. Nefunguje ani spravcabalikov - synaptic ani aktualizacia.
        • Re: problem with update 19.05.2011 | 22:26
          Avatar Milan Dvorský debian,mint kde,android  Administrátor
          a co takto
          sudo apt-get -f install

          ?
        • Re: problem with update 19.05.2011 | 22:59
          WlaSaTy   Návštevník
          Tým skúsiť znova som myslel aj s spustením príkazu sudo apt-get update, ten urobí znovunačítanie informáciách o balíkoch.

          A pred tým skontroluj že či nemáš náhodou plný disk.
        • Re: problem with update 20.05.2011 | 11:10
          Avatar Stanislav Hoferek Greenie, Manjaro, Q4OS, Lubuntu  Používateľ
          celkom šikovný príkaz je aj toto, no s týmto pravdepodopne nepomôže:

          sudo dpkg --configure -a

          btw čo ak by sa sem poslal sources.list?
          • Re: problem with update 20.05.2011 | 11:21
            Avatar bedňa antiX, Devuan, LegacyIce  Administrátor
            Ono sa to spravidla používa takto:
            apt-get -f install
            dpkg --configure -a
            
            A dokáže to spraviť rozbité updaty dosť spolahlivo, teda aspoň mne to vždy zabralo.
            Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
          • sources list 22.05.2011 | 13:20
            logical   Návštevník
            # deb cdrom:[Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5)]/ karmic main restricted
            # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
            # newer versions of the distribution.

            deb http://archive.ubuntu.com/ubuntu natty main

            ## Major bug fix updates produced after the final release of the
            ## distribution.

            ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
            ## team. Also, please note that software in universe WILL NOT receive any
            ## review or updates from the Ubuntu security team.
            deb http://archive.ubuntu.com/ubuntu natty universe

            ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
            ## team, and may not be under a free licence. Please satisfy yourself as to
            ## your rights to use the software. Also, please note that software in
            ## multiverse WILL NOT receive any review or updates from the Ubuntu
            ## security team.
            deb http://archive.ubuntu.com/ubuntu natty multiverse

            ## Uncomment the following two lines to add software from the 'backports'
            ## repository.
            ## N.B. software from this repository may not have been tested as
            ## extensively as that contained in the main release, although it includes
            ## newer versions of some applications which may provide useful features.
            ## Also, please note that software in backports WILL NOT receive any review
            ## or updates from the Ubuntu security team.
            # deb http://sk.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
            # deb-src http://sk.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse

            ## Uncomment the following two lines to add software from Canonical's
            ## 'partner' repository.
            ## This software is not part of Ubuntu, but is offered by Canonical and the
            ## respective vendors as a service to Ubuntu users.
            # deb http://archive.canonical.com/ubuntu karmic partner
            # deb-src http://archive.canonical.com/ubuntu karmic partner

            deb http://archive.ubuntu.com/ubuntu natty-security main
            deb http://archive.ubuntu.com/ubuntu natty-security universe
            deb http://archive.ubuntu.com/ubuntu natty-security multiverse
            deb http://extras.ubuntu.com/ubuntu natty main #Third party developers repository
            deb http://archive.ubuntu.com/ubuntu natty-updates universe main multiverse
            • Re: sources list 22.05.2011 | 13:23
              Avatar Stanislav Hoferek Greenie, Manjaro, Q4OS, Lubuntu  Používateľ
              Karmic a Natty dokopy? Jasné, že to nefunguje. To je ako dávať benzín pre športové auto do škodovky zo 70. rokov...

              máš Karmic a chceš z neho urobiť Natty?
              • Re: sources list 22.05.2011 | 15:45
                Avatar Branislav Poldauf Ubuntu LTS, Debian stable  Používateľ
                ale sak tam ma len NATTY , karmic ma zakomentovany, ci #??#
                Linux: the operating system with a CLUE... Command Line User Environment
                • Re: sources list 22.05.2011 | 16:06
                  Avatar Stanislav Hoferek Greenie, Manjaro, Q4OS, Lubuntu  Používateľ
                  no áno ale ako sa tam ten karmic dostal? priletel tam? alebo nahodil karmic a po nejakých zázrakoch sa z toho stal natty?
            • vydanie 22.05.2011 | 13:25
              logical   Návštevník
              momentalne pouzivam ubuntu
              vydanie 11.04 (natty)
              Jadro Linux 2.6.38-8-generic-pae
              GNOME 2.32.1
              • Re: vydanie 22.05.2011 | 14:18
                Avatar Stanislav Hoferek Greenie, Manjaro, Q4OS, Lubuntu  Používateľ
                no a ako si sa dostal na natty? čo si mal predtým?
                • Re: vydanie 22.05.2011 | 19:09
                  logical   Návštevník
                  Predtym som mal 10.10 potom teraz 11.04 aktualizaciou -> prechod na vyssiu verziu
                  • Re: vydanie 22.05.2011 | 19:11
                    logical   Návštevník
                    na zaciatku som naistaloval 9.10 z LIVE_CD a postupnou aktualizaciou kazdy pol rok som zvysil verziu
                    • Re: vydanie 22.05.2011 | 19:49
                      Avatar Branislav Poldauf Ubuntu LTS, Debian stable  Používateľ
                      ze dost dobre,
                      mne ked sa s ubuntu podaril upgrade tak do mesiaca padol system alebo tak spomalil že som to nevydržal a preinštaloval:(
                      aj ked posledne ubuntu som mal 8.04 (vlastne teraz mam 11. ale len kym nevyjde fedora :))
                      Linux: the operating system with a CLUE... Command Line User Environment
                      • Re: vydanie 22.05.2011 | 22:00
                        WlaSaTy   Návštevník
                        A čo má spoločného upgrade s nečitateľným stavovým súborom ?
                        • Re: vydanie 22.05.2011 | 22:32
                          Avatar Branislav Poldauf Ubuntu LTS, Debian stable  Používateľ
                          to ja neviem ani som to neriesil
                          ja som odpovedal najprv na to ze "nema" karmic v repozitaroch
                          a potom na to že sa mu podaril 2x upgrade ubuntu (a že mne mne zvačša padne po prvom upgrade)
                          Linux: the operating system with a CLUE... Command Line User Environment
                          • Re: vydanie 23.05.2011 | 00:17
                            WlaSaTy   Návštevník
                            Buď má nahovno wifi poskytovateľa s prasácky zaveseným proxy servrom, alebo mal plný disk. Pri synchronizácii si zrovna ten súbor prepíše aktuálnou verziou. Takže, problém bol byrieśený.

                            Teda, pokiaľ sa len nesnaží o nadviazanie sociálneho kontaktu. Náhodne vygúglená chyba, tvrdenie že pretrváva aj po synchronizovaní repozitárov (a výbere iných).
                  • Re: vydanie 23.05.2011 | 12:54
                    Avatar samox86 arch, debian  Administrátor
                    pri update verzie by som postupoval takto:

                    1. apt-get update
                    2. apt-get upgrade
                    3. zaedituj repozitare (zmen na natty)
                    4. apt-get update
                    5. apt-get dist-upgrade
                    6. apt-get upgrade

                    v pripade ze to mas uz rozbite, zacni priamo na kroku 3.
                    ak to nepojde, zadefinuj repozitare Maverick (10.10) a chod pekne od zaciatku.

                    nikdy nekombinuj repozitare (vzdy tam maj len 1 zdroj)

                    apt-get install -f doinstaluje chybajuce zavislosti
                    lnx.sk - virtualne servery; Lnx@Lnx.sk
                    • Re: vydanie 23.05.2011 | 13:55
                      WlaSaTy   Návštevník
                      V tomto prípade by som si rád pozrel výsledok. Najmä opravu ktorú potom bude treba vyriešiť a či tá oprava bude trvať kradšie ako normálna podporovaná cesta na upgrade alebo čistý reinštall.

                      Upgrade sa robí nástrojom na to určeným. Takže: update-manager -d Je to najmä kôli konverziám konfigurákov a tvorbe nových konfigov. Ale, zaujímalo by ma že aká chyba sa tam vyskytla po štandardnom synchronizovaní balíkov. Ak vôbec.
                      • Re: vydanie 24.05.2011 | 14:43
                        logical   Návštevník
                        Prosim poslite subor /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages
                        ja ho mam chybny a pri aktualizaci vypise chybu tohto suboru. Dakujem.
                        • Re: vydanie 24.05.2011 | 15:28
                          WlaSaTy   Návštevník
                          Ahoj,
                          Súbory v /var/lib/apt/lists sa vytvárajú pri synchronizovaní balíkov. U Mňa je ten súbor prázdny.
                          $ sudo rm -rf /var/lib/apt/lists/*
                          password:
                          $ sudo apt-get update
                          Ign http://extras.ubuntu.com natty InRelease
                          ...
                          Ign http://archive.ubuntu.com natty/universe Translation-en
                          Fetched 8,161 kB in 26s (313 kB/s)
                          Reading package lists... Done
                          $ ls -l /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages
                          -rw-r--r-- 1 root root 0 2011-03-30 02:01 /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages
                          $ sudo apt-get dist-upgrade
                          Reading package lists... Done
                          Building dependency tree
                          Reading state information... Done
                          Calculating upgrade... Done
                          The following packages will be upgraded:
                            geoclue gnome-nettool im-switch language-selector language-selector-common language-selector-gnome libgeoclue0 xserver-common
                            xserver-xorg-core
                          9 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
                          Need to get 1,996 kB of archives.
                          After this operation, 12.3 kB of additional disk space will be used.
                          Do you want to continue [Y/n]?