problem s GNOME

Sekcia: Aplikácie & Desktop 25.01.2013 | 18:57
JohnyJo   Návštevník
Pozdravujem všetkých, mám taký problém, že keď inštalujem gnome-session, vypisuje mi to chybu 804 neviete čo to je?
    • Re: problem s GNOME 25.01.2013 | 19:29
      Avatar Stanislav Hoferek Greenie, Manjaro, Q4OS, Lubuntu  Používateľ
      napíš o tom viac, z tohto sa veľa nepohneme. aké distro? aké ďalšie balíky si tam z gnome pridal? a akú verziu gnome chceš? aké prostredie teraz máš?
      • Re: problem s GNOME 25.01.2013 | 19:37
        JohnyJo   Návštevník
        Chcem aby toto posluzilo aj ostatnym uzivatelom tak by som rad vedel ake vsetky balicky na GNOME potrebujem. Nainstaloval som gnome-session gdm xdaemon. Co este potrebujem? Distribecia Dragonfly BSD a chcel by som Gnome 2.3 . Potrebujem najst iny sposom ako kompilovanie(nechcem cakat 4 dni), postupoval som aj podla prirucky ale nejako si s tym neviem poradit.
        • Re: problem s GNOME 25.01.2013 | 19:40
          JohnyJo   Návštevník
          Na stranke FreeBSD som nasiel tento zoznam: ORBit2-2.14.19, atk-2.0.1, avahi-app-0.6.29_3, bash-4.2.37, bitstream-vera-1.10_5, cairo-1.10.2_4,2, compositeproto-0.4.2, consolekit-0.4.3, cups-client-1.5.2_2, damageproto-1.2.1, dbus-1.4.14_4, dbus-glib-0.94, dconf-0.5.1_4, dmidecode-2.11, docbook-1.4, docbook-4.1_4, docbook-4.2, docbook-4.3, docbook-4.4_2, docbook-4.5_2, docbook-5.0_1, docbook-sk-4.1.2_4, docbook-xml-4.2_1, docbook-xml-4.3, docbook-xml-4.4_1, docbook-xml-4.5, docbook-xsl-1.76.1, eggdbus-0.6_1, encodings-1.0.4,1, expat-2.0.1_2, fixesproto-5.0, flac-1.2.1_3, font-bh-ttf-1.0.3, font-misc-ethiopic-1.0.3, font-misc-meltho-1.0.3, font-util-1.2.0, fontconfig-2.9.0,1, freetype2-2.4.9_1, gamin-0.1.10_4, gconf2-2.32.0_3, gdbm-1.9.1, gdk-pixbuf-2.23.5_3, getopt-1.1.4_2, gettext-0.18.1.1, gio-fam-backend-2.28.8_1, glib-2.28.8_4, gmake-3.82_1, gnome-desktop-2.32.1_2, gnome-doc-utils-0.20.3, gnome-settings-daemon-2.32.1_4, gnome_subr-1.0, gnomehier-2.3_12, gobject-introspection-0.10.8_2, gstreamer-0.10.36, gstreamer-plugins-0.10.36_2,3, gstreamer-plugins-good-0.10.31,3, gtk-2.24.6_2, gtk-update-icon-cache-2.24.6_1, hal-0.5.14_20, hicolor-icon-theme-0.12, inputproto-2.0.2, intltool-0.41.1, iso-codes-3.37, iso8879-1986_3, jasper-1.900.1_10, jbigkit-1.6, jpeg-8_3, kbproto-1.0.5, libICE-1.0.7,1, libIDL-0.8.14_1, libSM-1.2.0,1, libX11-1.4.4,1, libXau-1.0.6, libXcomposite-0.4.3,1, libXcursor-1.1.12, libXdamage-1.1.3, libXdmcp-1.1.0, libXext-1.3.0_1,1, libXfixes-5.0, libXft-2.1.14, libXi-1.4.5,1, libXinerama-1.1.1,1, libXmu-1.1.0,1, libXp-1.0.1,1, libXpm-3.5.9, libXrandr-1.3.2, libXrender-0.9.6, libXt-1.1.1,1, libXtst-1.2.0, libXv-1.0.6,1, libXxf86dga-1.1.2, libXxf86misc-1.0.3, libXxf86vm-1.1.1, libcanberra-0.28_3, libdaemon-0.14, libexecinfo-1.1_3, libffi-3.0.9, libfontenc-1.1.0, libgcrypt-1.5.0_1, libgee-0.6.2.1, libglade2-2.6.4_5, libgnome-keyring-2.32.0_2, libgnomekbd-2.32.0_1, libgpg-error-1.10, libiconv-1.14, libltdl-2.4.2, libnotify-0.7.3_2, libogg-1.3.0,4, libpthread-stubs-0.3_3, libsamplerate-0.1.8_3, libsndfile-1.0.25_2, libtasn1-2.13, libvolume_id-0.81.1, libvorbis-1.3.3_1,3, libxcb-1.7, libxkbfile-1.0.7, libxklavier-5.0,1, libxml2-2.7.8_5, libxslt-1.1.26_3, mkfontdir-1.0.6, mkfontscale-1.0.9, nspr-4.9.3, nss-3.14, orc-0.4.16, p5-XML-Parser-2.41, pango-1.28.4_1, pciids-20120906, pcre-8.31_1, perl-5.14.2_2, pixman-0.24.2, pkgconf-0.8.9, png-1.5.12, policykit-0.9_6, polkit-0.99, printproto-1.0.5, pulseaudio-0.9.23_2, py27-cairo-1.8.10_1, py27-gobject-2.28.6_1, py27-gtk-2.24.0_1, py27-libxml2-2.7.8_2, python27-2.7.3_3, randrproto-1.3.2, rarian-0.8.1, recordproto-1.14.1, renderproto-0.11.1, shared-mime-info-1.0_1, speex-1.2.r1_4,1, sqlite3-3.7.14.1, startup-notification-0.12, tiff-4.0.2_1, upower-0.9.7, videoproto-2.3.1, xcb-util-0.3.8,1, xcb-util-renderutil-0.3.8, xdpyinfo-1.3.0, xextproto-7.2.0, xf86dgaproto-2.1, xf86miscproto-0.9.3, xf86vidmodeproto-2.3.1, xineramaproto-1.2.1, xkbcomp-1.2.3, xmlcatmgr-2.2, xmlcharent-0.3_2, xorg-fonts-truetype-7.5.1, xproto-7.0.22, xrdb-1.0.9 vážne je to to čo potrebujem?
        • Re: problem s GNOME 25.01.2013 | 19:45
          Avatar Stanislav Hoferek Greenie, Manjaro, Q4OS, Lubuntu  Používateľ
          gnome 2.3??? určite? na Mandrake 10.0, čo bolo dávno pradávno, bolo gnome 2.6...
          • Re: problem s GNOME 25.01.2013 | 19:49
            JohnyJo   Návštevník
            No ak vies o sposobe ako dostat novsi Gnome do DragonflyBSD, tak mi ho napis.
            • Re: problem s GNOME 25.01.2013 | 20:07
              Avatar Stanislav Hoferek Greenie, Manjaro, Q4OS, Lubuntu  Používateľ
              johny, gnome 2.3 tam fakt nepôjde. tam máš určite dáky preklep. chceš gnome 2.x alebo 3.x?

              niečo sa píše tu: http://www.dragonflybsd.org/docs/newhandbook/X/#index7h3
              • Re: problem s GNOME 25.01.2013 | 20:16
                JohnyJo   Návštevník
                Ked zadam:
                # pkg_radd gnome
                vypise mi audition package failed

                takze musim dat
                # pkg_radd gnome-session

                Ked kompilujem prikaom
                # cd /usr/pkgsrc/meta-pkgs/gnome
                # bmake install clean
                trva to strasne dloho

                Rad by som mal Gnome 3.x ale ako?

                • Re: problem s GNOME 25.01.2013 | 20:19
                  Avatar Stanislav Hoferek Greenie, Manjaro, Q4OS, Lubuntu  Používateľ
                  možno blbá a offtopic otázka, ale prečo práve dragonfly bsd?či vyžaduješ BSD systém?
                  • Re: problem s GNOME 26.01.2013 | 17:25
                    WlaSaTy   Návštevník
                    Jedná sa o jediné BSD ktoré beží vo virtualbox-e. To bude ten dôvod.

                    Ale, s5 k otázke. Tá chyba práce s binárnymi balíkmi mala aj nejaký text. Pravdepodobne sa v nej priamo píše, čo treba urobiť aby to prešlo.

                    Škoda, že infiormácia o vyskytnutí sa chyby je bez popisu tej chyby bezcenná.

                    A o kvalite príručky pre DFL sa nemá zmysel baviť. Jedná sa o jeden z najprehľadnejších manuálov, ale ten je tiež bez čitateľa bezcenný.
                    • Re: problem s GNOME 26.01.2013 | 18:49
                      JohnyJo   Návštevník
                      Ta prirucka je zastarala pouzivam DFLY BSD 3.0.3 a vela veci z toho co tam pisu uz neexistuje alebo nefunguje, cital som ju, skusal som typy co su v nej a nic.
                      • Re: problem s GNOME 26.01.2013 | 18:49
                        JohnyJo   Návštevník
                        oprava 3.0.1
                        • Re: problem s GNOME 26.01.2013 | 18:53
                          JohnyJo   Návštevník
                          Chyba je nasledovna:
                          Systém nemá k dspozici žadný soubor Xclient, takže
                          došlo ke spuštení záchranného sezení xterm. Okna
                          bodou aktivní je pokud nad nimi bude kurzor myši.
                          Tento režim lze spustit napsaním "exit" v okne.
                          • Re: problem s GNOME 26.01.2013 | 18:57
                            JohnyJo   Návštevník
                            Ked dam zachranne sedenie Gnome pise mi to toto:
                            gdm-binary(882): WARNING: session_child_run: gnome-session pro záchranné sezeni Gnome nebylo nalezeno; zkousi se xterm.
                      • Re: problem s GNOME 26.01.2013 | 19:03
                        WlaSaTy   Návštevník
                        Tá príručka nie je zastaraná. Keď si sa pýtal na tvoju prvú otázku na DFL s nastavením siete, tak si mal odpoveď priamo pod nosom. Bolo to popísané v príručke. Overil som si to, aj na BSD. A je to tak.

                        Neskôr som sa Ťa pýtal, či si ju prečítal. Vravel si, že áno. Ale, Tvoje opakované otázky len poukazujú na to, že si ju aj napriek Tvojim otázkam nečítal.

                        Pekný víkend, prajem.
                        • Re: problem s GNOME 26.01.2013 | 21:25
                          JohnyJo   Návštevník
                          Nečital som ju celu len casti, niesom az taky zbehli s BSD systemami. Skusal som aj toto:
                          # Xorg -config xorg.conf.new
                          pisu tam ze ak je obrazovka čierna a šedá a objavi sa X kurzor konfigurácia bola uspesna, mne to ukazuje len ciernu faru takze asi moja karta nepodporuje Xorg.
                          • Re: problem s GNOME 26.01.2013 | 21:32
                            Avatar default Debian  Používateľ
                            Ja keď ťa tak počúvam, tak ma, napadá ti iba povedať, že nauč sa najprv základné veci, nechápem, prečo si sa pustil takto zo začiatku hneď na koniec, budeš tu ten systém ťapkať 2 týždne a budeš rád, ak sa ti to nezosype. Radšej skús najprv archlinux, viem že to neni BSD, ale základ pre mnohé veci čo využiješ aj inde ti to dá, ak nebudeš len bezmyšlienkovito odpisovať príkazy z wiki.
                            R.K
                            • Re: problem s GNOME 26.01.2013 | 21:48
                              JohnyJo   Návštevník
                              Ok tak ja to teda skusim s tym Archlinuxom no a uvidime, a mimochodom ako zapnum zvuk vo firefoxe v DFLY uz som tam rozchodil xorg.
                              • Re: problem s GNOME 26.01.2013 | 22:23
                                WlaSaTy   Návštevník
                                Dám Ti sem link na presnú kapitolu z príručky alebo si to nájdeš aj sám?
                                • Re: problem s GNOME 03.02.2013 | 18:16
                                  Loko   Návštevník
                                  Halo potrebujem pomoc nechcem zbytocne zakladat novu temu tak to pisem sem lebo je to tak trochu o GNOME. Mam MINT 14 a cairo dock vsetko ide fajn ale vzdy ked vypnem pocitac a druhy den ho zapnem pri cairo docku je cierny obdlznik. To vyriesim compiz fusionom kde dam reload window manager. ale musim to spravit pri kazdom zapnuti pc. Neda sa to nastavit aby to robilo automaticky? Diky
                                  • Re: problem s GNOME 03.02.2013 | 18:21
                                    Avatar default Debian  Používateľ
                                    Aké tam máš prostredie? Mate?
                                    R.K
                                    • Re: problem s GNOME 03.02.2013 | 18:43
                                      Loko   Návštevník
                                      Ano, Mate 64bit
                                      • Re: problem s GNOME 03.02.2013 | 19:11
                                        Avatar default Debian  Používateľ
                                        Takže, ten compiz fusion sa ti spúšťa pri štarte? Ak hej, potom na napadá skontrolovať v tom compiz config manageri, v sekcii myslím window manager, či tam je compiz ako default window manager, lebo vyzerá to tak, že máš default stále metacity, alebo ako sa to teraz v tom Mate volá. A aj priamo cez tú ikonu - fusion icon, neviem či tam náhodou nieje voľba default window manager, čo tam máš zaskrtnuté? Malo by tam byť gtk-window-decorator.
                                        R.K
                                        • Re: problem s GNOME 03.02.2013 | 21:16
                                          Loko   Návštevník
                                          V compiz fusion je nastaveni ako default window manager compiz a ako window decorator: GTK window decorator a stale to ukazuje ten cierny obdlznik.
                                          • Re: problem s GNOME 03.02.2013 | 21:29
                                            Avatar default Debian  Používateľ
                                            Takže keď dáš reštart sám sa spustí fusion icon, s nastavením, ktoré si uviedol, ale napriek tomu sa to nastavenie neaplikuje, až keď dáš reload window manager? Mám pre teba také neoficiálne riešenie, používaš niektoré z tých efektov compizu, či ti iba o to aby si nemal čierny ten dock?
                                            R.K
                                            • Re: problem s GNOME 03.02.2013 | 21:46
                                              Loko   Návštevník
                                              Na prvú otázku je odpoved ano a na druhu ti odpoviem ze efekty kompizu ako su kocka alebo nieco take a pod nepouzivam ale dost mi prekaze ten cierny pas. Tak asi tak.
                                              • Re: problem s GNOME 03.02.2013 | 22:08
                                                Avatar default Debian  Používateľ
                                                V tom prípade, ti odporúčam 2 možnosti (súčasťou oboch je to, že prestaneš používať compiz) :

                                                1.) xcompmgr - je to kompizitný manager, zaistí to aby tam nebol ten čierny pás, môže sa kombinovať s ľubovolným window managerom takže napríklad aj s tým predvoleným čo bol v mate, jediná vec, ktorá by ťa mohla štvať, je že nieje 3D , čiže neposkytuje ti hardwarovo akcelerované prostredie, to znamená, ak sa ti o to nestará nejaká vec v grafickom driveri, tak ti napríklad nebude fungovať vertikálna sychronizácia, čo má za následok trhanie okien , a podobné ... , možno to robiť nebude, je na tebe či to odtestuješ, ale v prípade, že by ti trhali okná a ďalšie veci, tak je tu riešenie číslo 2:

                                                2.) Mutter window manager, máš ho priamo v repozitári, pod názvom mutter, ale ja som spravil vlastnú verziu: link , v tej verzii som v podstate odstránil efekty, ktoré ten bežný mutter má, pretože sa mi zdajú otravné a spomalujú podľa mňa iba chod toho window manageru, preto ti odporúčam tú svoju verziu, jediná vec sa mi zdá , čo ti bude treba dodatočne je libclutter-1.0-0 to máš v repozitároch, takže neni problém, keď ho nainštaluješ stačí zadať mutter --replace do terminálu napríklad, a môžeš si ho odtestovať ak sa ti to bude páčiť proste ten príkaz pridaj do aplikácií spúšťaných pri štarte, a nakoniec výhoda mutteru oproti xcopmgr je , že ti poskytuje tú hardwarovú akceráciu tak ako compiz, za dosť užitočné považujem "aero snap" ak nevieš čo to je: že vezmeš okno a dáš ho na stranu a ono sa veľkosťou prispôsobí polovici obrazovky, to sa dá zapnúť keby si to chcel, to compiz tak úplne nevie.

                                                Ja mutter uprednostňujem pred compizom, preto, lebo je menej náročný, viac výkonný, a má pre mňa lepšiu funkcionalitu.
                                                R.K
                                                • Re: problem s GNOME 04.02.2013 | 17:16
                                                  Loko   Návštevník
                                                  Diky velmi si mi pomohol