Non-PAE kompatibilné distro

Sekcia: Aplikácie & Desktop 04.02.2014 | 17:52
Avatar Ľubomír Štulajter Ubuntu 14.04 X64  Používateľ

Po instalacii updatov mi prestalo chodit Lubuntu 10.04 na jednom starom notebooku (Intel Pentium M 1.6, 768 MB RAM, grafika ATI Mobility Radeon 9700. WiFi Intel PRO/Wireless 2200 BG), tak rozmyslam, ze by som tam skusil nieco ine.

Vie mi niekto poradit non-PAE kompatibilne distro novsie ako Lubuntu 10.04? Ked som to pred rokom instaloval, nic novsie som do toho stroja nedostal - riesil som to tu. Alebo je najlepsim riesenim zostat pri tom Lubuntu?

    • RE: Non-PAE kompatibilné distro 04.02.2014 | 18:32
      Avatar bedňa antiX, Devuan, LegacyIce  Administrátor

      Čo to znamená prestalo chodiť? Kernel panic? Keď sa ti nainštalovalo novšie jadro, tak to staré by malo ostať na výber v Grube. Aplikoval si len záplaty pre 10.04, alebo si prechádzal na 12.04?

      Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
      • RE: Non-PAE kompatibilné distro 04.02.2014 | 18:46
        Avatar Ľubomír Štulajter Ubuntu 14.04 X64  Používateľ

        Iba 10.04. Ale medzitým to vyriešil syn... vytiahnutím kábla zo zásuvky. :-) Po opätovnom pripojení krásne nabootuje.

        Takže akútne to momentálne nie je, ale ak mi vieš niečo schopné poradiť, niekedy to vyskúšam. Tá 10.04-rka predsa len už má svoje roky...

        • RE: Non-PAE kompatibilné distro 04.02.2014 | 19:27
          Avatar bedňa antiX, Devuan, LegacyIce  Administrátor

          To má šťastné ruky, páč poznám ľudí čo nič nerobili a počítač sám od seba nejde. Ono to fakt tak funguje, niekomu niečo nejde, prídem zapnem a ono to ide :)

          Ja by som prešiel na 12.04, malej som to upgradoval, má tam tiež ATI, ale takú lepšejšiu a prežili sme to v zdravý. Inak Pentium M je myslím si v jadre stále podporovaný, pri najhoršom by sme si skompilovali vlastný Kernel.

          Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
    • RE: Non-PAE kompatibilné distro 04.02.2014 | 19:38
      Avatar WlaSaTy   Návštevník

      CPU bez PAE boli o približnej frekvencii 150MHz, pri frekvencii 1.6GHz sa PAE nemusíš zaoberať. Ohľadne výberu distribúcie by si mohol povedať čo je tam za grafickú kartu a koľko RAM sa tam zmestí. Ja bežím napríklad Ubuntu 14.04 na CPU 1GHz s 1G RAM, ale s lxde desktopom kôli absencii rozšíreného 3d pre ťažkotonážne desktopy.

      • RE: Non-PAE kompatibilné distro 04.02.2014 | 20:49
        Avatar Ľubomír Štulajter Ubuntu 14.04 X64  Používateľ

        Grafika a RAM sú hneď v prvom príspevku. To PAE som si nevymyslel, to mi písalo, keď som tam chcel nainštalovať novšie verzie Lubuntu.

        • RE: Non-PAE kompatibilné distro 04.02.2014 | 21:09
          Avatar WlaSaTy   Návštevník

          Vidím, že si uviedol aj či má tábgrafika zdieľanú pamäť, len som si to nevšimol. Asi to bolo písané drobným písmom ako dodatok k zmluve. Zdieľaná pamäť pre grafickú kartu totižto ešte ukrajuje z RAM. Ale na RAM som sa nepýtal koľko jej tam máš, ale koľko sa jej tam zmestí. To je taký drobný rozdiel keďže 512+256 je občas málo ak človek zapne internetový prehliadač a zabudne zakázať flash.

          Ohľadne toho PAE by som si rád pozrel tú chybu keďže som si istý že tú inštrukčnú sadu máš. Potvrdiť si to môžeš aj sám ak si pozrieš výpis z /proc/cpuinfo .

          • RE: Non-PAE kompatibilné distro 04.02.2014 | 21:36
            Avatar Ľubomír Štulajter Ubuntu 14.04 X64  Používateľ

            Sorry, neriešil som, koľko tam vojde, keďže nemienim do toho (okrem času) investovať ani cent. Jedine že by som takú RAMku našiel v ďalšom stroji určenom na zošrotovanie (čo mal byť pôvodne aj osud tohto).

            Takže maximum sú 2 GB RAM. Info o grafike - priznávam - neviem, kde pod Linuxom zistím.

            /proc/cpuinfo:

            processor : 0
            vendor_id : GenuineIntel
            cpu family : 6
            model : 13
            model name : Intel(R) Pentium(R) M processor 1.60GHz
            stepping : 6
            cpu MHz : 1600.000
            cache size : 2048 KB
            fdiv_bug : no
            hlt_bug : no
            f00f_bug : no
            coma_bug : no
            fpu : yes
            fpu_exception : yes
            cpuid level : 2
            wp : yes
            flags : fpu vme de pse tsc msr mce cx8 mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss tm pbe up bts est tm2
            bogomips : 3197.85
            clflush size : 64
            cache_alignment : 64
            address sizes : 32 bits physical, 32 bits virtual
            power management:

      • RE: Non-PAE kompatibilné distro 04.02.2014 | 21:01
        Avatar Ľubomír Štulajter Ubuntu 14.04 X64  Používateľ

        Inak, čo sa týka toho PAE pri procesoroch Pentium M, asi si budeš musieť aktualizovať znalosti, očividne nie som jediný, kto to rieši: http://zo0ok.com/techfindings/archives/1098. Alebo Google: https://www.google.sk/search?q=intel+pentium+m+non-pae

        • RE: Non-PAE kompatibilné distro 04.02.2014 | 21:36
          Avatar WlaSaTy   Návštevník

          Tie znalosti si rád doplním, ale zatiaľ som nemal odkiaľ. Informácia z Wiki s poznámkou "citation needed" je pre mňa bezcenná ako Ficov rozpočtový plán na šetrenie ktorý vytvorilo novovzniknuté ministerstvo.

          Ale tými linkami si si odpovedal aj sám, balík FAKE PAE podhodí do /proc/cpuinfo informáciu o PAE aby bolo možné spustiť upgrade z bežiaceho systému. Len mám taký technický dojem, že to bude chcieť mať vlastné jadro preložené bez PAE. Nespomínam si ako agresívne bolo nastavenie PAE pri preklade jadra keďže posledný x86/64 počítač čo som mal k dispozícii bez PAE mal 120MHz.

          Ale, to je jedno. Distribúcií ktoré nepotrebujú PAE ubúda podobným tempom ako distribúcií čo dokážu bežať na 486ke.

          • RE: Non-PAE kompatibilné distro 05.02.2014 | 14:16
            Avatar WlaSaTy   Návštevník

            Teda, aby som to doplnil. Tie procesory z ktorých máš aj Ty jeden k dispozícii len nereportovali PAE ale boli schopné bežať jadrá s zapnutou podporou PAE. Na tom linku je pekne popísaný aj návod na inštaláciu z CD alebo upgrade aj s odporúčaniami ktoré distribúcie by s tým mali bežať. Napríklad Xubuntu do jari 2015 alebo Bodhi do 2017. Rozbor iných typov distribúcií sa mi nechcelo robiť. Akurát podotknem že pre Gentoo je to jasné, len by som radšej niekde vyskladnil nejaké RAMky schopné bežať v tom stroji. Bez nich to bude nič moc.

    • RE: Non-PAE kompatibilné distro 05.02.2014 | 07:48
      Avatar janek-m Kubuntu 14.04, Kubuntu 16.04  Používateľ

      Ak sa nemýlim, tak Lubuntu 12.04 a Xubuntu 12.04.1 sú posledné verzie Ubuntu s non-PAE jadrom. Ešte možným riešením je aj Bodhi Linux 2.4.0 nonpae (tiež založené na 12.04)

      • RE: Non-PAE kompatibilné distro 05.02.2014 | 10:39
        Avatar Ľubomír Štulajter Ubuntu 14.04 X64  Používateľ

        Nepamatam si uz detaily, ale viem, ze novsie (ako 10.04) verzie Lubuntu sa mi tam nainstalovat nepodarilo. Neskusal som sice vsetky, ale 12.04-rka urcite nesla. A mini ISO mi ani nenabootovalo. Mozno niekedy, ked budem mat viac casu, skusim to fake PAE. Ale skor asi vyskusam nieco nove, vdaka za tip.

        • RE: Non-PAE kompatibilné distro 05.02.2014 | 12:00
          Avatar bedňa antiX, Devuan, LegacyIce  Administrátor

          Keď už testuješ, tak si stiahni Tiny Core Linux, ma to 12MB, stiahneš to za pár sekúnd, na USB je to za pár sekúnd a za pár sekúnd bootuješ :) Je to skôr prdel, ale aspoň uvidíš, kde sa dá až Linux enviroment očesať.

          Táto správa neobsahuje vírus, pretože nepoužívam MS Windows. http://kernelultras.org
          • RE: Non-PAE kompatibilné distro 06.02.2014 | 02:07
            Avatar Ľubomír Štulajter Ubuntu 14.04 X64  Používateľ

            Zase až tak sa do toho testovania nepúšťam, času je málo, skôr hľadám niečo, čo nejaký čas bude šlapať bez nárokov na ďalšiu starostlivosť. :-) To Lubuntu mi celkom vyhovuje, až na to, že po zapnutí musím vždy naťukať heslo do WiFi. A je to už trošku staré... aj keď samozrejme samotný stroj je ešte o dosť starší.

            • RE: Non-PAE kompatibilné distro 05.03.2014 | 22:47
              Avatar Tony   Návštevník

              Ja som mal podobny problem s hladanim non-pae distra pre stary nb a momentalne mam LXLE co je vlastne upravene lubuntu. Inac zaujimavy je aj bodhi alebo crunchbang, idu svizne, alebo aj puppy linux. Na nonpae funguje aj napr linux mint debian, ale mne to islo velmi pomaly. Vyskusaj si ich cez live boot a uvidis, ktory ti sedi.

        • RE: Non-PAE kompatibilné distro 05.02.2014 | 13:40
          Avatar dodoedo Fedora Linux  Používateľ

          Ahoj Ľ. 

          Skús zábŕdnuť aj do Slax-base.

          Iba pre Tvoju lepšiu orientáciu:

          http://en.wikipedia.org/wiki/List_of_Linux_distributions_that_run_from_RAM

          G. Orwell: "Čím více se společnost vzdaluje od pravdy, tím více bude nenávidět ty, kteří ji říkají."