Apache a forbidden :/

Sekcia: Aplikácie & Desktop 17.08.2007 | 13:20
Avatar Dare_devil Debian, OpenSuse  Používateľ
Dobry den. Dnes som si nainstalil kubuntu. Nainstalil som si ako spravny admin apache2 php5 a mysql server.. ale document root bola nastavena na /var/www/ a cchel som ju zmenit na /home/viktor/www/ tak som zmenil ale teraz mi to robi 403 Forbidden sak to poznate ( Forbidden
You don't have permission to access / on this server.
Apache/2.2.3 (Ubuntu) PHP/5.2.1 Server at localhost Port 80 )
Neviete co s tym?
Chmod som uz skusal, 777 aj +x ale nejako to nepomohlo. Dost to potrebujem, predtym som s tym ziadne problemy nemal. Diks
Pozn. : za kazdou zmenou som restartoval apache takze tam chyba nebude
There is no flag large enough to cover the shame of killing innocent people
    • Re: Apache a forbidden :/ 17.08.2007 | 13:30
      Avatar uid0 Debian  Používateľ
      daj si to radsej niekam do /home/www a nastav vlastnika na seba a group na www-data (u teba k tomu zrejme nema server pristup)
      Debian. apt-get into it…
      • Re: Apache a forbidden :/ 17.08.2007 | 13:47
        Avatar Dare_devil Debian, OpenSuse  Používateľ
        User som dal viktor a Group bola www-data , zlozku som zmenil v konfiguraku na /home/www/ , restartoval apache, nastavil zlozke prava 777 a aj tak pise 403
        There is no flag large enough to cover the shame of killing innocent people
        • Re: Apache a forbidden :/ 17.08.2007 | 14:00
          Avatar uid0 Debian  Používateľ
          mas tam vobec index.* ?
          Debian. apt-get into it…
          • Re: Apache a forbidden :/ 17.08.2007 | 14:02
            Avatar Dare_devil Debian, OpenSuse  Používateľ
            mam tam index.html + 1 zlozku celeho webu.. nejde to absolutne, furt 403
            There is no flag large enough to cover the shame of killing innocent people
            • Re: Apache a forbidden :/ 17.08.2007 | 14:07
              Avatar uid0 Debian  Používateľ
              chyba bude zrejme v httpd.conf (ak mas teda tie prava uz v poriadku)
              Debian. apt-get into it…
              • Re: Apache a forbidden :/ 17.08.2007 | 14:42
                Avatar Dare_devil Debian, OpenSuse  Používateľ
                nevedel som kde ten httpd.conf je tak som ho dal hladat a naslo iba zlozku httpd nic ine :D mozes byt trosku podrobnejsi??
                There is no flag large enough to cover the shame of killing innocent people
                • Re: Apache a forbidden :/ 17.08.2007 | 14:57
                  Avatar uid0 Debian  Používateľ
                  tak skus vyhladat apache2.conf :)

                  /etc/apache2/
                  Debian. apt-get into it…
    • Re: Apache a forbidden :/ 17.08.2007 | 15:02
      Avatar Samuel BWPOW Kupka CentOS, Mandriva  Používateľ
      Bubuntu sice nepoznam, takze neviem presnu strukturu konfigov apache. Ale niekde v configu (asi v tom istom, ako sa nastavuje DocumentRoot, u mna /etc/httpd/conf/httpd.conf) by mala byt cast venovana nastaveniu adresarov.

      Najdi nieco ako:
      <Directory />
          Options -All -Multiviews
          AllowOverride None
          Order deny,allow
          Deny from all
      </Directory>
      
      a za tym by malo byt:
      <Directory "/var/www/">
          Options -Indexes FollowSymLinks MultiViews
          AllowOverride None
          Order allow,deny
          Allow from all
      </Directory>
      
      No, tam len zmen cestu z /var/www na novy adresar, ktory si si nastavil ako DocumentRoot. Kvoli bezpecnosti je totiz defaultne pristup do vsetkych adresarov na disku zakazany (ta prva cast to robi) a kazdy potom treba povolit.
      Strach dát najevo své pocity a zjednat si u druhých respekt je jedním z problémů civilizovaného člověka, který se naučil zpochybňovat svou vlastní pravdu pro zdání objektivity
      • Re: Apache a forbidden :/ 17.08.2007 | 15:08
        Avatar Dare_devil Debian, OpenSuse  Používateľ
        jea uz to ide.. diky moc :)
        btw. upravoval som to v /etc/apache2/sites-available/default
        There is no flag large enough to cover the shame of killing innocent people